Bug 20082 - Please document IP_FREEBIND
Summary: Please document IP_FREEBIND
Status: RESOLVED CODE_FIX
Alias: None
Product: Documentation
Classification: Unclassified
Component: man-pages (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: documentation_man-pages@kernel-bugs.osdl.org
URL:
Keywords:
: 16459 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-11 14:14 UTC by Lennart Poettering
Modified: 2010-10-13 04:35 UTC (History)
2 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Lennart Poettering 2010-10-11 14:14:14 UTC
IP_FREEBIND is one of my favourite sockopts ;-) , as it allows race-free listening on any socket without requiring the network interface to be up. Would be cool to document this in inet(7).
Comment 1 Lennart Poettering 2010-10-11 14:16:07 UTC
Oh, and there are actually a few more undocumented IP-related sockopts defined in /usr/include/linux/in.h that could use some documentation love.
Comment 2 Michael Kerrisk 2010-10-13 04:33:08 UTC
(In reply to comment #0)
> IP_FREEBIND is one of my favourite sockopts ;-) , as it allows race-free
> listening on any socket without requiring the network interface to be up.
> Would
> be cool to document this in inet(7).


How does the following look? 

+.TP
+.BR IP_FREEBIND " (since Linux 2.4)"
+.\" Precisely: 2.4.0-test10
+If enabled, this boolean option allows binding to an IP address
+that is nonlocal or does not (yet) exist.
+This permits listening on a socket,
+without requiring the underlying network interface or the
+specified dynamic IP address to be up at the time that
+the application is trying to bind to it.
+This option is the per-socket equivalent of the
+.IR ip_nonlocal_bind
+.I /proc
+interface described below.
Comment 3 Michael Kerrisk 2010-10-13 04:33:28 UTC
(In reply to comment #1)
> Oh, and there are actually a few more undocumented IP-related sockopts
> defined
> in /usr/include/linux/in.h that could use some documentation love.

This sounds like one or more separate bug reports...
Comment 4 Michael Kerrisk 2010-10-13 04:33:39 UTC
I'll close this now; please reopen if there is still something to be fixed.
Comment 5 Michael Kerrisk 2010-10-13 04:35:48 UTC
*** Bug 16459 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.