Bug 200713 - SMBus timeout on asus laptop
Summary: SMBus timeout on asus laptop
Status: RESOLVED DUPLICATE of bug 112811
Alias: None
Product: Drivers
Classification: Unclassified
Component: I2C (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Drivers/I2C virtual user
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-02 18:41 UTC by mirh
Modified: 2018-08-20 15:47 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.18
Tree: Mainline
Regression: No


Attachments
dmesg (56.93 KB, text/plain)
2018-08-02 18:41 UTC, mirh
Details
dmesg, no term_list (57.22 KB, text/plain)
2018-08-19 11:52 UTC, mirh
Details

Description mirh 2018-08-02 18:41:06 UTC
Created attachment 277669 [details]
dmesg

Kernels up to 4.16 didn't exhibit this problem

Contrarily to bug 198071, I don't seem to experience any particular problem in functionalities.
Comment 1 mirh 2018-08-14 19:04:14 UTC
After a looong bisect session, it seemingly is due to 5a8361f7ecceaed64b4064000d16cb703462be49
  ACPICA: Integrate package handling with module-level code
Comment 2 mirh 2018-08-19 11:52:34 UTC
Created attachment 277935 [details]
dmesg, no term_list

Actually, sorry Erik, I just realized this isn't a regression (something that previously was working, now doesn't anymore).. but actually a fix leading to the previously never initialized piix4_smbus to *start to do something at all*

I compiled 4.18 with acpi_gbl_execute_tables_as_methods (aka acpi_gbl_parse_table_as_term_list) set to FALSE, restoring previous behavior.. And I noticed where there always existed an acpi warning about conflicting SystemIO range with \_SB.SMB0 OpRegion, there now was the SMBus popping up.
Comment 3 mirh 2018-08-20 15:47:33 UTC
Well, in the meantime I'll go with module_blacklist=i2c_piix4
For the reminder duplicate of bug 112811

*** This bug has been marked as a duplicate of bug 112811 ***

Note You need to log in before you can comment on or make changes to this bug.