Bug 200407 - Potential deadlock when mount a btrfs image
Summary: Potential deadlock when mount a btrfs image
Status: RESOLVED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: btrfs (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: BTRFS virtual assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-04 17:31 UTC by Wen Xu
Modified: 2019-05-21 12:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.18
Tree: Mainline
Regression: No


Attachments
The (compressed) crafted image which causes hangs (135.60 KB, application/zip)
2018-07-04 17:31 UTC, Wen Xu
Details

Description Wen Xu 2018-07-04 17:31:41 UTC
Created attachment 277171 [details]
The (compressed) crafted image which causes hangs

- Reproduce
# mkdir mnt
# mount -t btrfs 15.img mnt

Not clear about the reasons...

Found by Wen Xu and Po-Ning Tseng from SSLab at Gatech.
Comment 1 David Sterba 2019-05-21 12:29:47 UTC
Thanks for the report. Fixed by cf90d884b347c50 "btrfs: Introduce mount time chunk <-> dev extent mapping check", in 4.19.

Note You need to log in before you can comment on or make changes to this bug.