Bug 20032 - 2.6.36-rc7 continuos kernel panics in cpu_idle (and intel_idle)
2.6.36-rc7 continuos kernel panics in cpu_idle (and intel_idle)
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: cpuidle
All Linux
: P1 normal
Assigned To: power-management_cpuidle@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-10-10 17:54 UTC by Maciej Rutecki
Modified: 2010-10-24 04:11 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.36-rc7
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-10-10 17:54:36 UTC
Subject    : 2.6.36-rc7 continuos kernel panics due to of cpu_idle (and cpu_intel_idle)
Submitter  : Patrizio Bassi <patrizio.bassi@gmail.com>
Date       : 2010-10-08 18:23
Message-ID : AANLkTi=2irM5tM2rNC5wHVV=Nw4cs_CK59pvXDD+Y5Dz@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=128656222919323&w=2

This entry is being used for tracking a regression from 2.6.35.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Len Brown 2010-10-19 03:46:24 UTC
Do the issues go away when you boot with "idle=poll"?
Comment 2 Patrizio Bassi 2010-10-19 08:11:11 UTC
After bumping to -rc8 with cpu_idle but without cpu_idle_intel compiled i can't reproduce the issue anymore.
It's really strange because i could not see any commit related to a similar issue.

I'll wait 2.6.36 vanilla to be out to test again with the intel module too.
Comment 3 Len Brown 2010-10-20 16:34:58 UTC
please re-open if you can reproduce this with 2.6.36-rc8 or later
Comment 4 Patrizio Bassi 2010-10-22 08:57:45 UTC
i confirm 2.6.36 final with 
CONFIG_ARCH_HAS_CPU_IDLE_WAIT=y
CONFIG_ARCH_HAS_DEFAULT_IDLE=y
CONFIG_CPU_IDLE=y
CONFIG_CPU_IDLE_GOV_LADDER=y
CONFIG_CPU_IDLE_GOV_MENU=y
CONFIG_INTEL_IDLE=y

looks stable now.

i will reopen if any issues happen
Comment 5 Len Brown 2010-10-24 04:11:41 UTC
Thanks for confirming 2.6.36 is working, Patrizio.
Please let us know if you see any troubles with the release,
no matter the .config

Note You need to log in before you can comment on or make changes to this bug.