Bug 200315 - [Regression] Wired network does not come back after reboot
Summary: [Regression] Wired network does not come back after reboot
Status: RESOLVED DUPLICATE of bug 200195
Alias: None
Product: Networking
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Stephen Hemminger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-28 01:59 UTC by Nícholas Lima de Souza Silva
Modified: 2018-08-07 12:01 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.17.2
Tree: Mainline
Regression: Yes


Attachments
It's a log from journalctl NetworkManager (27.04 KB, text/x-matlab)
2018-06-28 01:59 UTC, Nícholas Lima de Souza Silva
Details

Description Nícholas Lima de Souza Silva 2018-06-28 01:59:30 UTC
Created attachment 276937 [details]
It's a log from journalctl NetworkManager

Only difference is using kernel 4.17.2 vs kernel 4.16.15

When using 4.17.2, the network does not work after rebooting. With 4.16.15 it works as expected.

Complementing: The wired connection doesn't work if I choose to reboot, but It does work if I power it off and on again.
Comment 1 Nícholas Lima de Souza Silva 2018-07-26 14:46:23 UTC

*** This bug has been marked as a duplicate of bug 200195 ***
Comment 2 Heiner Kallweit 2018-08-07 11:47:10 UTC
This issue seems to be different from the linked one, the other was about issues after resume from suspend.

Please provide full dmesg output of
 1. a fresh boot (where network works)
 2. a reboot (where network doesn't work)

Does network work after resume from suspend-to-ram (if supported on your system)? 

Does kernel version 4.17.13 fix the issue?
Comment 3 Nícholas Lima de Souza Silva 2018-08-07 12:01:56 UTC
(In reply to Heiner Kallweit from comment #2)
> This issue seems to be different from the linked one, the other was about
> issues after resume from suspend.
> 
> Please provide full dmesg output of
>  1. a fresh boot (where network works)
>  2. a reboot (where network doesn't work)
> 
> Does network work after resume from suspend-to-ram (if supported on your
> system)? 
> 
> Does kernel version 4.17.13 fix the issue?

The issue was fixed on the kernel version 4.17.11

Note You need to log in before you can comment on or make changes to this bug.