Bug 200031 - power on / plugging in E-MU 0202 USB hangs up pulseaudio and USB bus
Summary: power on / plugging in E-MU 0202 USB hangs up pulseaudio and USB bus
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: Intel Linux
: P1 high
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-11 21:39 UTC by Dmitry Sutyagin
Modified: 2018-06-11 21:44 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.16.10
Tree: Mainline
Regression: No


Attachments

Description Dmitry Sutyagin 2018-06-11 21:39:30 UTC
On Arch Linux with GDM, I'm plugging in E-MU 0202 USB audio interface. As soon as I do that, I can no longer configure my audio devices, and if I keep trying to access audio then my USB mouse and keyboard stop working.

I've reported the bug "downstream"
on freedesktop (pulseaudio) https://bugs.freedesktop.org/show_bug.cgi?id=106557
and on Arch tracker https://bugs.archlinux.org/task/58327
on Arch forum - https://bbs.archlinux.org/viewtopic.php?pid=1780719

On pulseaudio tracker it was recommended to file a kernel bug.

I think this is some kind of race condition between kernel or systemd and pulseaudio, and worked around by first plugging the interface, then starting pulseaudio.

Log examples:
reproduced - https://pastebin.com/4en37K3L
not reproduced - https://pastebin.com/0xQRWmNk
reproduced with different resulting behavior (non-stop usb reset) -https://pastebin.com/Y5Ng2Fbs

There repro results depend on timing, how many pusleaudio running (default is 2 - gdm + user), and how I turn on the device - hotplug it or "cold"-plug it use the knob on the device which is a hardware on-off switch. The only scenario when it reliably works is when pulseaudio is not running (0 running instances), then I can plug any way, hot or cold, and have no issues.
Comment 1 Dmitry Sutyagin 2018-06-11 21:44:33 UTC
Also, the behavior is the same on my Arch system with any kernel version, I tried 4.15, 4.4, also tried building kernel 4.15 with config from Ubuntu. Same result.

However, on a different system with Ubuntu there's no such issue.

Note You need to log in before you can comment on or make changes to this bug.