Bug 19972 - System freeze on shutdown - bisected to commit 29d08b3efddc
System freeze on shutdown - bisected to commit 29d08b3efddc
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-10-09 19:08 UTC by Maciej Rutecki
Modified: 2010-10-09 20:12 UTC (History)
4 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-10-09 19:08:59 UTC
Subject    : System freeze on shutdown - bisected to commit 29d08b3efddc
Submitter  : Marc Dionne <marc.c.dionne@gmail.com>
Date       : 2010-10-05 22:24
Message-ID : AANLkTikBXb-QZ2twFUZHzzYSHyZz1Kca4GRLu_6bo+Oo@mail.gmail.com
References : http://marc.info/?l=linux-kernel&m=128631751031207&w=2

This entry is being used for tracking a regression from 2.6.35.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 29d08b3efddca628b0360411ab2b85f7b1723f48
Author: Dave Airlie <airlied@redhat.com>
Date:   Mon, 27 Sep 2010 06:17:17 +0000

   drm/gem: handlecount isn't really a kref so don't make it one.

   Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
   Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 29d08b3efddca628b0360411ab2b85f7b1723f48
Comment 1 Marc Dionne 2010-10-09 19:37:22 UTC
The fix for this has already made it to mainline as commit dab8dcfa3c8e3b021a138bee7c17791b4991ba55.

I've verified that current mainline no longer has this issue.

Thanks,
Marc

Note You need to log in before you can comment on or make changes to this bug.