Bug 199609 - System freezes after resuming from suspend to ram the second time x86 i7
Summary: System freezes after resuming from suspend to ram the second time x86 i7
Status: CLOSED MOVED
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: Intel Linux
: P1 blocking
Assignee: drivers_video-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 16:02 UTC by John Smith
Modified: 2018-05-15 07:27 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.14.38
Tree: Mainline
Regression: No


Attachments
journalctl_log (28.36 KB, text/plain)
2018-05-03 16:02 UTC, John Smith
Details

Description John Smith 2018-05-03 16:02:11 UTC
Created attachment 275751 [details]
journalctl_log

This happends after the second time of resuming from suspend. The first time I press the power button everything seems to be ok. Please see the dmesg log (suspend_error_log_after_1._resume). When I press a button the second time suspend, the system freezes with screen on. The keyboard/mouse is not working anymore. But I am quiet sure the suspendig mem state is never reached, because the backlight of my keys are still recognising the key pressing.

After that, I can only hard reset the system. Moreover it is not booting anymore. I need to plug-in the power-supply to reboot.

There is no difference between pressing the power-button or calling $echo mem > /sys/power/state

Please let me know, which additional logs do you need. I do not know how to catch error logs before completly freezing.
Comment 1 Chen Yu 2018-05-07 02:47:19 UTC
There are two issues after resumed 1st:
1. 
Mai 03 17:46:28 bang kernel: BUG: unable to handle kernel paging request at ffffa6a481eacfec
Mai 03 17:46:28 bang kernel: IP: smu7_populate_single_firmware_entry.isra.4+0x55/0xd0 [amdgpu]

which is a amdgpu driver bug, please blacklist this driver and try again.

2. xhci issue
 usb 1-7:1.0: rebind failed: -517


The  amdgpu is the most suspicious one broke your second suspend.
Comment 2 John Smith 2018-05-07 15:18:56 UTC
Thank you Chen. Blacklisting amdgpu seems to be the cause. So what is next, do I need to open a new issue for the amdgpu driver?
Comment 3 Chen Yu 2018-05-08 01:26:32 UTC
You can send the panic information to amd-gfx@lists.freedesktop.org and CC 
David (ChunMing) Zhou <David1.Zhou@amd.com>
Alex Deucher <alexander.deucher@amd.com>
Christian König <christian.koenig@amd.com>
Comment 6 Thomas Martitz 2018-05-15 05:25:09 UTC
Apparently the happened also for iceland gpus in the past, but was fixed (see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=885919). I don't know which commit fixed it for iceland, though.

FWIW, I am also affected. After I found a fix for https://bugzilla.kernel.org/show_bug.cgi?id=199693 I trapped into this issue.
Comment 7 Zhang Rui 2018-05-15 07:27:29 UTC
*** Bug 199693 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.