Bug 199607 - Audio codec suspend causes humming sound with snd-hda-intel on NUC5i7RYB
Summary: Audio codec suspend causes humming sound with snd-hda-intel on NUC5i7RYB
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-03 14:09 UTC by Viktor Ashirov
Modified: 2019-05-07 10:27 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.16.6-300.fc28.x86_64
Tree: Mainline
Regression: No


Attachments
alsa-info.txt (41.34 KB, text/plain)
2018-05-03 14:09 UTC, Viktor Ashirov
Details

Description Viktor Ashirov 2018-05-03 14:09:38 UTC
Created attachment 275745 [details]
alsa-info.txt

Following the instructions from here:
https://bugzilla.redhat.com/show_bug.cgi?id=1533858#c1

alsa-info.txt is attached
Comment 1 Takashi Iwai 2018-05-03 14:29:17 UTC
What is the symptom?  Could you elaborate the problem in a bit more details?

Also, as a blind shot: try to turn off "Loopback Mixing" mixer element.  This is known to do harmful on many machines and is off as default.
Comment 2 Hans de Goede 2018-05-23 12:27:11 UTC
Viktor,

It would be good to get feedback from you on Takashi's question, so that we can add a fix for this to the mainline kernel.

Please boot without snd_hda_intel.power_save=0 added to your kernel commandline and then turn off the "Loopback Mixing" mixer element by running:

amixer -c0 set "Loopback Mixing" Disabled
amixer -c1 set "Loopback Mixing" Disabled

(one of these 2 might fail).

And then let us know if this fixes things, or if you still hear plops / a hiss.

Thanks & Regards,

Hans
Comment 3 Viktor Ashirov 2018-05-28 16:46:53 UTC
Hi,

I'm sorry for the delay.

The symptom looks like this: https://vashirov.fedorapeople.org/share/bz199607.webm

Disabling "Loopback Mixing" doesn't help. I also hear the same hiss sound at the system shutdown.

Thanks!
Comment 4 Hans de Goede 2018-05-29 08:30:08 UTC
(In reply to Viktor Ashirov from comment #3)
> Hi,
> 
> I'm sorry for the delay.
> 
> The symptom looks like this:
> https://vashirov.fedorapeople.org/share/bz199607.webm
> 
> Disabling "Loopback Mixing" doesn't help. I also hear the same hiss sound at
> the system shutdown.
> 
> Thanks!

Thank you for the info, the patch adding a quirk for your NUC has been merged now, closing.
Comment 5 Adam Nielsen 2019-05-07 10:27:53 UTC
I am experiencing a similar issue with my NUC7i5BNK and suspect it may be related to this.

With earlier kernel versions I had to disable power saving to avoid constant clicking on the HDMI audio when no sound was being played, but after upgrading from 4.18.9 to 5.0.12 the clicking is back, even when setting both `power_save` to 0 and `power_save_controller` to N (by echoing the new value into `/sys/module/...`).  Loopback mixing has always been disabled, and enabling it does not change the behaviour in any way.

The symptom is that exactly 4 seconds after stopping playback, my amplifier switches from "48 kHz" to "unlocked" and then I get random clicks and pops anything from 500ms to 2 seconds apart, of varying volumes.  As long as I am playing audio then the quality is fine.  On the old kernel version with snd-hda-intel power saving disabled (via configuration in `/etc/modprobe.d`) there was no problem.

I am wondering whether power saving is not fully disabled with the new kernel, as it looks like some refactoring work was done since the last version I was using so I'm not sure whether that has changed anything in this respect.  I am also wondering whether adding my NUC to the blacklist will also solve the problem, given that the same model with a different CPU (i3) is already on the list?

My PCI IDs appear to be 8086:9d71.

Many thanks for any info you have.

Note You need to log in before you can comment on or make changes to this bug.