Bug 199529 - pinctrl-amd fails with error -22 on HP Envy x360
Summary: pinctrl-amd fails with error -22 on HP Envy x360
Status: RESOLVED DUPLICATE of bug 198715
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks: 198715
  Show dependency tree
 
Reported: 2018-04-26 21:20 UTC by Lukas Kahnert
Modified: 2018-11-26 08:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.16
Tree: Mainline
Regression: No


Attachments
dmesg for 4.16.4 (54.82 KB, text/plain)
2018-04-26 21:20 UTC, Lukas Kahnert
Details

Description Lukas Kahnert 2018-04-26 21:20:46 UTC
Created attachment 275611 [details]
dmesg for 4.16.4

The HP Envy x360(Ryzen 2500u) has an AMD GPIO device which is detected through ACPI. The pinctrl-amd driver probe fails with:

amd_gpio AMDI0030:00: Failed to get gpio IRQ: -22

I searched and found out that the driver calls platform_get_irq -> which calls acpi_irq_get if the detected device is also an ACPI device. But this function is only available when CONFIG_ACPI_GENERIC_GSI is set(only set for ARM64).
It looks like it's not implemented on x86/amd64.

FWIW if the ACPI code in platform_get_irq will be commented out(with the macro) the driver probes successful and devices like touchscreen will be correctly detected. I'm not sure how a clean fix should look like.
Comment 1 Lukas Kahnert 2018-11-26 08:29:10 UTC
This bug is a symptom of another bug already reported.

*** This bug has been marked as a duplicate of bug 198715 ***

Note You need to log in before you can comment on or make changes to this bug.