Bug 199171 - battery drain while off (HP Pavilion 15 gaming AK112NL)
Summary: battery drain while off (HP Pavilion 15 gaming AK112NL)
Status: CLOSED DUPLICATE of bug 198665
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Battery (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Zhang Rui
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-22 15:17 UTC by andreanottoli
Modified: 2018-05-30 05:38 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.14 - 4.15
Tree: Mainline
Regression: No


Attachments

Description andreanottoli 2018-03-22 15:17:53 UTC
On kernel 4.14.x and 4.15.x the battery of the notebook drain to 0% after shutdown.
Wake-on lan is disabled and the discharging stop if the battery is physically removed and reinserted (so it's not an hardware failure for sure).

Moreover the problem does not appear on kernel 4.9.x which report 100% of the battery after a day since the shutdown.

I don't know how investigate further the issue but i'm happy to provide some log or other if someone advice me what to log...
Comment 1 Giorgio 2018-03-23 12:05:41 UTC
Dear all,

I’ve the same problem of battery drain while the notebook is off (from now on: BD) and I’ve been struggling for weeks to solve this problem. At the moment, in my case too the only way to avoid BD, after shutting down the notebook, is to remove/reinsert the battery.
 My notebook is a HP Pavilion 15-ak112nl, and the OS is Slackware64 14.2.  Since this bug has already been reported (see https://bugzilla.kernel.org/show_bug.cgi?id=198665 ) I didn’t send a bug notification earlier. However, hoping it may prove useful in order to solve this annoying problem, let me point out to your attention few things that I can tell you about BD. 
1. As Andrea says, BD is kernel related since it is present on both 4.14.x and 4.15.x kernel, but – for instance – there is no BD on 4.12.x kernel (actually, I’m currently using 4.12.14 kernel and everything works fine).
2. BD is “manufacturer related”. In the past weeks I googled a lot on this matter, and I came to the conclusion that BD affects just some of HP notebooks (in particular, the “gaming” series).
3. BD is not related to data storage device type. Since in my case Slackware is installed on both HDD and SSD, I’ve noticed that BD is present on both storage devices.
4.  My notebook is equipped with nVidia Optimus Technology (GeForce GTX 950M graphical + Intel HD Graphics 530) but BD does not seem related to the discrete GPU. I currently use Bumblebee packages and everything works fine on both 4.12.14 and 4.14.x-4.15.x kernels. The recompilation of Bumblebee packages on 4.12.14 or on 4.14.x (or 4.15.x) kernel makes no difference: BD is still present on 4.14.x (4.15.x) kernel, but it is not present on 4.12.14 kernel.
5. In order to solve BD problem, I wasn’t able to find anything of really relevant in dmesg outputs, nor I found something of interest in comparing the kernel configuration files (if it may prove useful, I can upload the diff file between kernel 4.12.14 and kernel 4.14.x config files). However, in the kernel syslog file (i.e., /var/log/syslog) I found the following (apparently interesting) warning message: i801_smbus 0000:00:1f.4: An interrupt is pending! Consistently with this message, before shutting down the notebook I unloaded the i2c_i801 module: at the reboot I noticed that the warning message wasn’t there anymore, but BD was still present.

That’s all. Please, let me know if you need any further information (of course I can give you a detailed description of my hardware configuration, of loaded modules, of software configuration, and so on…).
All the best,

Giorgio
P.S.: as soon as possible I will test the 4.16 kernel (which is still in the rc state)...I’ll let you know...
Comment 2 andreanottoli 2018-05-01 14:14:07 UTC
I tried kernel 4.17.r180422 but bug still present :(
Comment 3 Giorgio 2018-05-01 19:42:43 UTC
Dear all,

I wanted to test the latest kernel patches before sending an upgrade notification about BD bug ...unfortunately, about two weeks ago my battery “died”  – I don’t know if this fact is in some way related to BD: in any case I’m going to replace the battery with a brand new one –  and then, at the moment, I can only tell you that BD was still present on 4.14.36 and 4.16.4 kernel.
However, as to 4.14.x kernel line, I noticed that the latest patches fixed various errors related to ACPI /bus ( see for instance: https://mirrors.edge.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.37  ): Andrea, did you try 4.14.37 and 4.14.38 kernel? Please, let me (us) know.
All the best,

Giorgio
Comment 4 andreanottoli 2018-05-03 13:52:47 UTC
Hi Giorgio, i'm currently on Manjaro where >= 4.14.37 isn't avaiable. I'll check with a live distro like ubuntu where it should be avaiable and i'll be back soon...
cheers,

Andrea
Comment 5 Zhang Rui 2018-05-08 02:29:22 UTC
please confirm if this is a duplicate of bug #198665.

please follow comment #40 of that thread and confirm if commit de3ef1eb1cd0cc3a75f7a3661e10ed827f370ab8 introduces the problem or not.
Comment 6 andreanottoli 2018-05-09 09:45:38 UTC
Hi, yes the problem appear to be the same. I've just installed 4.19.39 and i'll let you know if in some way it fixed the problem. I currently cannot compile kernel on this machine sorry :(
Comment 7 andreanottoli 2018-05-10 13:10:06 UTC
Yes, i confirm taht on 4.14.39 bug is still present. I'll try to build the kernel the commit before in next days... i'll be back, thanks again!
Comment 8 Giorgio 2018-05-10 14:33:27 UTC
Andrea,

tx for the information…bad news from 4.14.x kernel line…unfortunately, as I’ve already said, my battery is gone and at the moment I can’t make any test at all. However,  as to the commit  de3ef1eb1cd0cc3a75f7a3661e10ed827f370ab8:  Zhang, are you referring to the patches that can be found here
http://kernel.ubuntu.com/~jsalisbury/lp1745646/  ?

Best,

Giorgio
Comment 9 Zhang Rui 2018-05-30 05:38:14 UTC
the fix patch in bug #198665 has been shipped in 4.17-rc5
commit cfcadfaad7251d8b640713724b388164d75465b2
Author:     Rafael J. Wysocki <rafael.j.wysocki@intel.com>
AuthorDate: Wed May 9 00:18:32 2018 +0200
Commit:     Rafael J. Wysocki <rafael.j.wysocki@intel.com>
CommitDate: Thu May 10 16:50:26 2018 +0200

    PCI / PM: Check device_may_wakeup() in pci_enable_wake()
    
    Commit 0847684cfc5f0 (PCI / PM: Simplify device wakeup settings code)
    went too far and dropped the device_may_wakeup() check from
    pci_enable_wake() which causes wakeup to be enabled during system
    suspend, hibernation or shutdown for some PCI devices that are not
    allowed by user space to wake up the system from sleep (or power off).
    
    As a result of this, excessive power is drawn by some of the affected
    systems while in sleep states or off.
    
    Restore the device_may_wakeup() check in pci_enable_wake(), but make
    sure that the PCI bus type's runtime suspend callback will not call
    device_may_wakeup() which is about system wakeup from sleep and not
    about device wakeup from runtime suspend.
    
    Fixes: 0847684cfc5f0 (PCI / PM: Simplify device wakeup settings code)
    Reported-by: Joseph Salisbury <joseph.salisbury@canonical.com>
    Cc: 4.13+ <stable@vger.kernel.org> # 4.13+
    Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
    Acked-by: Bjorn Helgaas <bhelgaas@google.com>

please confirm if the problem still exists in upstream kernel later than 4.17-rc5.
Comment 10 Zhang Rui 2018-05-30 05:38:57 UTC
Mark as duplicate.
But anyway, please feel free to reopen it if the problem still exists in the latest upstream kernel.

*** This bug has been marked as a duplicate of bug 198665 ***

Note You need to log in before you can comment on or make changes to this bug.