Bug 198921 - amdgpu - dc module conflict - does not detect 2560x1080 resolution anymore - RX460
Summary: amdgpu - dc module conflict - does not detect 2560x1080 resolution anymore - ...
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-other
URL: https://bbs.archlinux.org/viewtopic.p...
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-24 17:21 UTC by cyril.raphanel
Modified: 2018-04-20 16:25 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.15.5
Tree: Mainline
Regression: Yes


Attachments

Description cyril.raphanel 2018-02-24 17:21:46 UTC
Hi,

I had to disable the dc module from the kernel (amdgpu.dc=0) in order to get back my 2560x1080 resolution otherwise it was stuck in 1920x1080.

2560x1080 was not detected and trying to add it manually using cvt and xrand did not work I got:
xrandr: Configure crtc 0 failed

I am using DVI-D connection with a RX460 graphic card.

Thanks for your great work!
Comment 1 cyril.raphanel 2018-03-21 07:24:02 UTC
Related/similar bug opened in freedesktop list 
https://bugs.freedesktop.org/show_bug.cgi?id=103953

I will check if solved in 4.16 when it goes stable.
Comment 2 cyril.raphanel 2018-04-20 16:24:34 UTC
Seems solved in 4.16.3 at least the way it is compiled in Arch.
I did not have to set amdgpu.dc=0. Works out of the box!

Note You need to log in before you can comment on or make changes to this bug.