Bug 198917 - SD card reader doesn't work
Summary: SD card reader doesn't work
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: MMC/SD (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: drivers_mmc-sd
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-24 10:42 UTC by Lev
Modified: 2018-03-03 10:55 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.16.0-041600rc2-generic
Tree: Mainline
Regression: No


Attachments

Description Lev 2018-02-24 10:42:35 UTC
I have a Jumper EZbook 3 Plus running Ubuntu 16.04.4 with the latest kernel, 4.16.0-rc2. The built-in SD card reader has stopped working ever since I updated the kernel to 4.16 (it is operating normally on recent previous kernels, specifically 4.15.*).  
   
Here's the relevant `dmesg` output  
[    2.115420] mmc0: SDHCI controller on PCI [0000:00:1e.4] using ADMA 64-bit
[    2.115450] sdhci-pci 0000:00:1e.6: SDHCI controller found [8086:9d2d] (rev 21)
[    2.115780] sdhci-pci 0000:00:1e.6: failed to setup card detect gpio
[    2.116048] mmc1: SDHCI controller on PCI [0000:00:1e.6] using ADMA 64-bit

No new entries seem to appear when I insert or remove the actual SD card from the reader slot.

The kernels were obtained here: http://kernel.ubuntu.com/~kernel-ppa/mainline/

I've found this bug here on Bugzilla but it seems to be different. I don't get the dmesg output that they describe there and also their workaround to add debug_quirks2=0x10000 to the kernel parameters did not seem to have any effect.
Comment 1 Thorsten Leemhuis 2018-02-26 09:32:59 UTC
JFYI: This issues is tracked in the regression reports for Linux 4.16 (http://bit.ly/lnxregrep416 ) with this id:

Linux-Regression-ID: lr#9adeaf

Please include this line in the comment section of patches that are supposed to fix the issue. Please also mention the string once in other mailinglist threads or different bug tracking entries if you or someone else start to discuss the issue there. By including that string you make it a whole lot easier to track where an issue gets discussed and how far patches to fix it have made it. For more details on this please see here: http://bit.ly/lnxregtrackid

Thx for your help. Ciao, Thorsten
Comment 2 Lev 2018-03-03 10:55:56 UTC
The issue seems to be fixed in 4.16.0-rc3.

Note You need to log in before you can comment on or make changes to this bug.