Bug 198705 - mq-bfq breaks usb drives under kernel 4.15.x
Summary: mq-bfq breaks usb drives under kernel 4.15.x
Status: RESOLVED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: io_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-06 20:52 UTC by siyia
Modified: 2018-03-19 04:41 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.15.x
Tree: Mainline
Regression: Yes


Attachments

Description siyia 2018-02-06 20:52:03 UTC
Hello, under kernel when i am using the mq-bfq i/o scheduler i cannot mount any usb drives and some apps are hanging.This issue is limited only to using mq-bfq scheduler under the 4.15 kernel series,mq-bfq worked fine with 4.14.x and all the other schedulers work properly on 4.15.x.
Comment 1 loqs 2018-02-07 13:43:17 UTC
bisected between 4.14 and 4.15 first bad commit was a6a252e6491443c1c18eab7e254daee63d4a7a04
running blkid the command will hang in the D state on this commit but not its parent if a USB thumb drive is present and the bfq scheduler is used for that device.
Comment 2 loqs 2018-02-08 15:57:19 UTC
Appears to be this issue http://lkml.org/lkml/2018/2/7/529
Comment 3 siyia 2018-02-14 02:34:29 UTC
Resolved in kernel 4.15.3
Comment 4 siyia 2018-02-15 11:32:46 UTC
Reopend only two of my flash drives work with the current state of bfq a data traveller 4.0gb usb2 and a no name 1gb usb2 drive which is weird.
Comment 5 siyia 2018-03-15 04:12:47 UTC
Problem persists with kernel 4.15.8 ,but has been resolved in linux 4.16 mainline since rc1, last time i checked.
Comment 6 siyia 2018-03-19 04:41:23 UTC
Issue resolved under kernel 4.15.10

Note You need to log in before you can comment on or make changes to this bug.