Bug 19862 - [REGRESSION] no sound on T60 laptop (HDA Intel)
[REGRESSION] no sound on T60 laptop (HDA Intel)
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Takashi Iwai
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-10-07 18:49 UTC by Maciej Rutecki
Modified: 2010-11-02 21:27 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.36-rc
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-10-07 18:49:03 UTC
Subject    : [REGRESSION] no sound on T60 laptop (HDA Intel)
Submitter  : Miklos Szeredi <miklos@szeredi.hu>
Date       : 2010-10-05 9:25
Message-ID : E1P33mT-0003qa-Fv@pomaz-ex.szeredi.hu
References : http://marc.info/?l=linux-kernel&m=128627079921512&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Florian Mickler 2010-11-02 21:27:21 UTC
Fixed by:

commit 0e7adbe263f89ea2ef15b5af5e80a812b2a85025
Author: Takashi Iwai <tiwai@suse.de>
Date:   Mon Oct 25 10:37:11 2010 +0200

    ALSA: hda - Disable sticky PCM stream assignment for AD codecs

which is marked for stable backport. 


On Tue, 02 Nov 2010 15:16:23 +0100
Miklos Szeredi <miklos@szeredi.hu> wrote:

> On Tue, 02 Nov 2010, Takashi Iwai wrote:
> > At Tue, 02 Nov 2010 10:34:58 +0100,
> > Miklos Szeredi wrote:
> > > 
> > > On Sun, 31 Oct 2010, Florian Mickler wrote:
> > > > > Hmm, now there's no sound even with the revert.  I guess reproducing
> > > > > this is not completely reliable so the bisect gave a false result.  Oh
> > > > > well.
> > > > > 
> > > 
> > > > Did you get to the bottom of this?
> > > 
> > > No, the regression is still there in 2.6.36-final.
> > 
> > This should be fixed by the commit
> > 0e7adbe263f89ea2ef15b5af5e80a812b2a85025.
> > Give it a try.
> 
> Yes, it fixes it.  Cool.
> 
> Thanks,
> Miklos

Note You need to log in before you can comment on or make changes to this bug.