Bug 198287 - NUC7i7BNH broken sensor after bios update 0060
Summary: NUC7i7BNH broken sensor after bios update 0060
Status: RESOLVED DUPLICATE of bug 199147
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL: https://communities.intel.com/message...
Keywords:
Depends on:
Blocks:
 
Reported: 2017-12-27 09:18 UTC by beta990
Modified: 2018-07-26 20:13 UTC (History)
2 users (show)

See Also:
Kernel Version: Linux archie-nuc 4.16.8-1-ck-skylake #1 SMP PREEMPT Wed May 9 17:17:52 EDT 2018 x86_64 GNU/Linux
Tree: Mainline
Regression: No


Attachments
acpidump (1023.82 KB, text/plain)
2018-04-02 13:29 UTC, beta990
Details
dmidecode (21.03 KB, text/plain)
2018-04-02 13:29 UTC, beta990
Details
thermal (5.40 KB, text/plain)
2018-04-02 13:29 UTC, beta990
Details

Description beta990 2017-12-27 09:18:50 UTC
$ sensors

coretemp-isa-0000

Adapter: ISA adapter

Package id 0:  +34.0°C  (high = +100.0°C, crit = +100.0°C)

Core 0:        +34.0°C  (high = +100.0°C, crit = +100.0°C)

Core 1:        +33.0°C  (high = +100.0°C, crit = +100.0°C)

 

acpitz-virtual-0

Adapter: Virtual device

temp1:       -263.2°C << this one

 

iwlwifi-virtual-0

Adapter: Virtual device

temp1:        +47.0°C

 

pch_skylake-virtual-0

Adapter: Virtual device

temp1:        +37.0°C

 

It shows ACPI/DSDT parse errors - this wasn't the case before.

Another question in the BIOS the temps. are way higher then when booted into Linux, is this normal?

It displays ~58°C as CPU temp. idle. in BIOS, but way lower when booted into Linux.
 

Thanks!
Comment 1 beta990 2017-12-27 09:20:00 UTC
Note: I'm unable to downgrade, mainly because this causes other issues like a really loud fan and HDMI issues that have been fixed in this release.
Comment 2 Zhang Rui 2017-12-27 14:14:11 UTC
are you able to downgrade to help us find the difference between these two BIOS versions?
If yes, then please attach the acpidump output and "grep . /sys/class/thermal/thermal*/*" for both old and new BIOS.
Comment 3 beta990 2017-12-29 09:18:53 UTC
@Zhang Rui Going to try, but if I'm not mistaken it is impossible when a certain switch has been turned on in the BIOS.

Will let you know!
Comment 4 Zhang Rui 2018-04-02 02:04:38 UTC
please attach the acpidump and output of "grep . /sys/class/thermal/thermal*/*" for the new BIOS.
please also attach the dmidecode output
Comment 5 beta990 2018-04-02 13:29:03 UTC
Created attachment 275049 [details]
acpidump
Comment 6 beta990 2018-04-02 13:29:16 UTC
Created attachment 275051 [details]
dmidecode
Comment 7 beta990 2018-04-02 13:29:32 UTC
Created attachment 275053 [details]
thermal
Comment 8 beta990 2018-04-02 13:30:00 UTC
@ Zhang Rui: done. :)
Comment 9 Zhang Rui 2018-05-07 06:30:28 UTC
            ThermalZone (TZ0)
            {
                Method (_TMP, 0, Serialized)  // _TMP: Temperature
                {
                    If ((ONEW == Zero))
                    {
                        Return (0x64)
                    }

                    Return (0x07D1)
                }

                Method (_HOT, 0, Serialized)  // _HOT: Hot Temperature
                {
                    Return (0x07D0)
                }
            }

The ACPI thermal zone is total crap on this NUC.
it just returns static value, thus it will never be able to report real temperature.

It is apparently a BIOS bug.
can you please check if there is any new BIOS available?
or can you please disable the ACPI thermal control in BIOS?
Comment 10 beta990 2018-05-10 16:54:51 UTC
@Zhang Rui Thanks for looking into this issue! :)
Seems more people reported this in the forum, hope the new BIOS indeed fixes this error.

I'll try to update the bios as soon as possible and report back to you.
Comment 11 beta990 2018-07-26 20:13:33 UTC

*** This bug has been marked as a duplicate of bug 199147 ***

Note You need to log in before you can comment on or make changes to this bug.