Bug 19802 - [drm:init_ring_common] *ERROR* render ring head not reset to zero
[drm:init_ring_common] *ERROR* render ring head not reset to zero
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-10-06 19:10 UTC by Maciej Rutecki
Modified: 2010-12-19 12:19 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.36-rc
Tree: Mainline
Regression: Yes


Attachments
proposed patch (2.01 KB, patch)
2010-12-06 17:24 UTC, Florian Mickler
Details | Diff

Description Maciej Rutecki 2010-10-06 19:10:26 UTC
Subject    : [drm:init_ring_common] *ERROR* render ring head not reset to zero
Submitter  : Thomas Meyer <thomas@m3y3r.de>
Date       : 2010-10-04 20:31
Message-ID : 201010042231.20320.thomas@m3y3r.de
References : http://marc.info/?l=linux-kernel&m=128622441331199&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Chris Wilson 2010-12-05 20:47:29 UTC
The hardware reset on the second attempt, so I am treating this as an overzealous warning. According to the code comments, gm45 is known to be prone to failing to reset on the first attempt.


commit 07af08d2cc7b9fd7f15f82c1ad49b28d20dc60e0
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Sun Dec 5 20:42:33 2010 +0000

    drm/i915/ringbuffer: Only print an error on the second attempt to reset he
    
    There's not much we can do here but hope for the best. However the first
    failure happens quite frequently and if often remedied by the second
    attempt to reset HEAD. So only print the error if that attempt also
    fails.
    
    Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=19802
    Reported-by: Thomas Meyer <thomas@m3y3r.de>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: stable@kernel.org
Comment 2 Florian Mickler 2010-12-06 17:24:17 UTC
Created attachment 39152 [details]
proposed patch

    drm/i915/ringbuffer: Only print an error on the second attempt to reset head
Comment 3 Thomas Meyer 2010-12-06 18:02:39 UTC
So my original question was: "Bug or feature?" So i guess the warning and/or error message is both! I could easily live with the error message...
Comment 4 Rafael J. Wysocki 2010-12-19 12:19:07 UTC
Fixed by commit 6fd0d56 drm/i915/ringbuffer: Only print an error on the second attempt to reset head .

Note You need to log in before you can comment on or make changes to this bug.