Bug 198003 - ACPI BIOS Error (bug) - \_SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 - Acer Aspire 5315, Intel Celeron M 550
Summary: ACPI BIOS Error (bug) - \_SB.PCI0._OSC: Excess arguments - ASL declared 5, AC...
Status: CLOSED DOCUMENTED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Erik Kaneda
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-27 09:09 UTC by Karen
Modified: 2018-05-07 06:19 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.9-4.14
Tree: Mainline
Regression: No


Attachments
screen (382.35 KB, image/png)
2017-11-27 09:09 UTC, Karen
Details
out from my acpidump (178.40 KB, text/plain)
2018-04-03 15:47 UTC, Karen
Details

Description Karen 2017-11-27 09:09:52 UTC
Created attachment 260889 [details]
screen

ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20170728/nsarguments-198)

[drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:33:pipe A] flip_done timed out

[drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:33:pipe A] flip_done timed out

Hello. After upgrading from 4.4 kernel on a newer kernel (4.9 - 4.14) were when the system appear these errors. Not depend on the distribution system. That Ubuntu that Manjaro - errors are always present. On the operating system - the visible work - these errors do not affect. Manjaro XFCE x86 64 4.14. (Acer Aspire 5315, Intel Celeron M 550 (2 Ghz)
Comment 1 Len Brown 2017-12-11 23:17:38 UTC
please attach the output from acpidump
Comment 2 Karen 2017-12-17 15:38:30 UTC

(In reply to Len Brown from comment #1)
> please attach the output from acpidump

Iam sorry, i don't have utility (acpidump) in my linux distributive (Manjaro Linux - Arch-based). What can I do?
Comment 3 Zhang Rui 2017-12-18 05:47:02 UTC
acpidump should be available in some package, like pm-utils or acpica-tools

Or you can build one from the kernel source.
it's under kernel_src/tools/power/acpi/tools/acpidump/
Comment 4 Zhang Rui 2018-01-22 07:50:11 UTC
ping ...
Comment 5 Karen 2018-01-22 08:08:10 UTC
(In reply to Zhang Rui from comment #4)
> ping ...

Sorry, Arch-based (manjaro) don't have this utilits. I don't know what can i do...
Comment 6 Karen 2018-01-22 08:09:14 UTC
Today i use kernel 4.4 - not problem))
Comment 7 Zhang Rui 2018-04-02 01:45:07 UTC
as I said, you can build one from kernel source.
1. git clone or download the latest kernel source from www.kernel.org
2. cd kernel_src/tools/power/acpi/tools/acpidump/
3. make
4. ./acpidump acpidump.out
5. attach the acpidump.out to this bug report
Comment 8 Karen 2018-04-03 15:40:01 UTC
(In reply to Zhang Rui from comment #7)
> as I said, you can build one from kernel source.
> 1. git clone or download the latest kernel source from www.kernel.org
> 2. cd kernel_src/tools/power/acpi/tools/acpidump/
> 3. make
> 4. ./acpidump acpidump.out
> 5. attach the acpidump.out to this bug report

Sorry for your waiting.
https://pastebin.com/C3L8CmsV
Comment 9 Karen 2018-04-03 15:47:55 UTC
Created attachment 275087 [details]
out from my acpidump
Comment 10 Zhang Rui 2018-05-02 03:49:04 UTC
following is the PCI0 _OSC
            Method (_OSC, 5, NotSerialized)  // _OSC: Operating System Capabilities
            {
                Local0 = Arg3
                Local1 = (Local0 * 0x04)
                Name (BUF1, Buffer (Local1){})
                BUF1 = Arg4
                Local1 = 0x00
                Local2 = 0x00
                While (Local0)
                {
                    Local2 = (Local1 * 0x04)
                    CreateDWordField (BUF1, Local2, CAPB)
                    If (Arg2)
                    {
                        If ((Local1 == 0x00))
                        {
                            (CAPB & 0xFFFFFFFC)
                        }
                    }
                    Else
                    {
                    }

                    Local1++
                    Local0--
                }

                Return (BUF1) /* \_SB_.PCI0._OSC.BUF1 */
            }

it is true that the ASL declares 5 arguments, while it should have 4 according to ACPI spec.
Erik, is this the root cause that causing this error message?
I have seen similar ASL writing on a couple of platforms as well, but they are all pretty old platforms.
Comment 11 Erik Kaneda 2018-05-04 21:47:08 UTC
Yes, this is the root cause.. One solution is to see if there is a firmware update for this platform or contact Acer directly about this issue. Other than that, there's not much we can do for these ACPI tables.
Comment 12 Zhang Rui 2018-05-07 06:19:05 UTC
So, this is a BIOS bug, which is detected by Linux kernel, and the right way to fix it is to raise the problem to Acer instead.
As there is nothing we can do in Linux kernel, bug closed.

Note You need to log in before you can comment on or make changes to this bug.