Bug 197917 - pipe(7): 'Open file status flags' is missing O_DIRECT
Summary: pipe(7): 'Open file status flags' is missing O_DIRECT
Status: RESOLVED CODE_FIX
Alias: None
Product: Documentation
Classification: Unclassified
Component: man-pages (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: documentation_man-pages@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-19 14:57 UTC by Martin H.
Modified: 2017-11-23 12:24 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Martin H. 2017-11-19 14:57:53 UTC
pipe(2) already documents this flag.
Since the following commit changes to O_DIRECT via fcntl are allowed too:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/fs/fcntl.c?id=0dbf5f20652108106cb822ad7662c786baaa03ff
Comment 1 Michael Kerrisk 2017-11-23 12:24:49 UTC
I've added this sentence to pipe(2):

              Since Linux 4.5, it is possible to change the O_DIRECT set‐
              ting of a pipe file descriptor using fcntl(2).

I'll close this bug now. Please reopen if you think more work is needed.

Note You need to log in before you can comment on or make changes to this bug.