Bug 197787 - Lenovo Professional Keyboard not working
Summary: Lenovo Professional Keyboard not working
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-11-06 07:56 UTC by David Demelier
Modified: 2019-02-11 09:46 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.12
Tree: Mainline
Regression: No


Attachments

Description David Demelier 2017-11-06 07:56:41 UTC
Hello,

I have a Lenovo Professional Keyboard combo which is not working on Linux because it sends an extra byte (0x71) for each key.

Some people explains the situation in the followings links:

https://forums.lenovo.com/t5/Linux-Discussion/Professional-Wireless-Keyboard-not-working-on-Linux/td-p/3726486

https://github.com/y-trudeau/linux_lenovo_ultraslim_plus

Do you think it's possible to make usb keyboard driver able to understand this extra byte?
Comment 1 Greg Kroah-Hartman 2017-11-06 08:17:38 UTC
On Mon, Nov 06, 2017 at 07:56:41AM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=197787
> 
>             Bug ID: 197787
>            Summary: Lenovo Professional Keyboard not working
>            Product: Drivers
>            Version: 2.5
>     Kernel Version: 4.12

All USB bugs should be sent to the linux-usb@vger.kernel.org mailing
list, and not entered into bugzilla.  Please bring this issue up there,
if it is still a problem in the latest kernel release.
Comment 2 Pavel Studeník 2018-05-06 14:15:14 UTC
I have installed Kernel 4.16.6-302.fc28.x86_64 (Fedora) and 4.15.0-20 (Uubntu) and the keyboard still doesn't work. Is ts possible to fixed it?
Comment 3 Michal Polovka 2019-02-11 09:46:38 UTC
Keyboard is sending extra byte with each key-press, as temporary workaaround you can use mapping in this repository (tested on Fedora 28 with 4.20 kernel)
https://github.com/miskopo/lenovo-professional-wireless-kbd-linux-driver

Note You need to log in before you can comment on or make changes to this bug.