Bug 197135 - Thinkpad 8 realtek ASoC no sound
Summary: Thinkpad 8 realtek ASoC no sound
Status: RESOLVED DUPLICATE of bug 96691
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-05 11:26 UTC by freemancrowbar100500
Modified: 2017-11-13 11:00 UTC (History)
0 users

See Also:
Kernel Version: 4.13.3
Tree: Mainline
Regression: No


Attachments
Full dmesg (51.32 KB, text/plain)
2017-10-05 11:26 UTC, freemancrowbar100500
Details
sound modules loaded (475 bytes, text/plain)
2017-10-05 11:27 UTC, freemancrowbar100500
Details
Kernel config (180.19 KB, text/x-mpsub)
2017-10-05 11:28 UTC, freemancrowbar100500
Details
alsa-info report (18.38 KB, text/plain)
2017-10-05 11:28 UTC, freemancrowbar100500
Details
DSDT (555.08 KB, text/x-csrc)
2017-10-05 11:29 UTC, freemancrowbar100500
Details
New dmesg (36.86 KB, text/plain)
2017-10-23 14:22 UTC, freemancrowbar100500
Details

Description freemancrowbar100500 2017-10-05 11:26:21 UTC
Created attachment 258723 [details]
Full dmesg

Hi.

The ship used is RT5640 (ACPI ID is 10EC5640).

dmesg shows multiple attempts to probe the hardware

[ 1180.449211] bytcr_rt5640 bytcr_rt5640: quirk DMIC1_MAP enabled
[ 1180.449221] bytcr_rt5640 bytcr_rt5640: quirk DMIC enabled
[ 1180.449230] bytcr_rt5640 bytcr_rt5640: quirk MCLK_EN enabled
[ 1180.449287] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI rt5640-aif1 not registered
[ 1180.449303] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517

I've tried enabling quirks for ssp0 aif1/aif2 to no avail

[ 2640.774310] bytcr_rt5640 bytcr_rt5640: Overriding quirk 0x410000 => 0x200000
[ 2640.774317] bytcr_rt5640 bytcr_rt5640: quirk DMIC1_MAP enabled
[ 2640.774322] bytcr_rt5640 bytcr_rt5640: quirk SSP0_AIF2 enabled
[ 2640.774349] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI rt5640-aif2 not registered
[ 2640.774356] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[ 2675.455574] bytcr_rt5640 bytcr_rt5640: Overriding quirk 0x410000 => 0x100000
[ 2675.455581] bytcr_rt5640 bytcr_rt5640: quirk DMIC1_MAP enabled
[ 2675.455586] bytcr_rt5640 bytcr_rt5640: quirk SSP0_AIF1 enabled
[ 2675.455613] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI rt5640-aif1 not registered
[ 2675.455621] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
Comment 1 freemancrowbar100500 2017-10-05 11:27:34 UTC
Created attachment 258725 [details]
sound modules loaded
Comment 2 freemancrowbar100500 2017-10-05 11:28:04 UTC
Created attachment 258727 [details]
Kernel config
Comment 3 freemancrowbar100500 2017-10-05 11:28:48 UTC
Created attachment 258729 [details]
alsa-info report
Comment 4 freemancrowbar100500 2017-10-05 11:29:40 UTC
Created attachment 258731 [details]
DSDT
Comment 5 freemancrowbar100500 2017-10-23 14:21:12 UTC
Based on this bug thread https://bugzilla.kernel.org/show_bug.cgi?id=96691, I've hacked my local version of the ASoC driver to load rt5672. While mapping is ok and the new soundcard does appear, I still don't get any sound and dmesg shows   Audio Port: ASoC: no backend DAIs enabled for Audio Port while trying to play anything. Attaching new dmesg
Comment 6 freemancrowbar100500 2017-10-23 14:22:13 UTC
Created attachment 260341 [details]
New dmesg
Comment 7 freemancrowbar100500 2017-11-13 11:00:35 UTC

*** This bug has been marked as a duplicate of bug 96691 ***

Note You need to log in before you can comment on or make changes to this bug.