Bug 196641 - iwlwifi: 8265: ASSERT 1007
Summary: iwlwifi: 8265: ASSERT 1007
Status: CLOSED DUPLICATE of bug 172431
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: DO NOT USE - assign "network-wireless-intel" component instead
Depends on:
Reported: 2017-08-11 13:09 UTC by Alexander Willing
Modified: 2017-08-17 12:57 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.11.11-300.fc26.x86_64
Regression: No
Bisected commit-id:

dmesg output (6.19 KB, text/plain)
2017-08-11 13:09 UTC, Alexander Willing
ethtool output (255 bytes, text/plain)
2017-08-11 13:10 UTC, Alexander Willing
grep . -r /sys/firmware/acpi/interrupts/ (10.08 KB, text/plain)
2017-08-11 13:11 UTC, Alexander Willing

Description Alexander Willing 2017-08-11 13:09:19 UTC
Created attachment 257887 [details]
dmesg output

I run Fedora 26 on an HP Spectre x360 Kaby Lake (w063-nr) with an Intel 8265 and iwlwifi crashes every ~9 seconds when using the wireless connection. Websites load very slowly, if they finish loading at all. At the same time I see high CPU usage by kworkers to the point my mouse pointer lags and Rhythmbox's audio output stutters (playing a local file). I also observe a lot of interrupts on /sys/firmware/acpi/interrupts/gpe17.

Looking at the firmware version in the dmesg output, I tried going back to firmware 21, but the problem persisted. I found https://bugzilla.kernel.org/show_bug.cgi?id=195299 but do not think it's the same, since the firmware I'm running (27.455470.0) should have the fix described there included, right?
Comment 1 Alexander Willing 2017-08-11 13:10:46 UTC
Created attachment 257889 [details]
ethtool output
Comment 2 Alexander Willing 2017-08-11 13:11:36 UTC
Created attachment 257891 [details]
grep . -r /sys/firmware/acpi/interrupts/
Comment 3 Emmanuel Grumbach 2017-08-12 19:27:13 UTC

we already invested a lot of time to debug this one as you can in the bug I linked to this one. Unfortunately, we couldn't do much. You can read the details inside the bug I attached.

You can try to upgrade to kernel 4.13 to be able to load -31.ucode to see whether it behaves better.

I am marking this bug as duplicate for now.
We'll keep getting the updates you may write here.

*** This bug has been marked as a duplicate of bug 172431 ***

Note You need to log in before you can comment on or make changes to this bug.