Bug 196211 - Kernel panic or freezes when connecting to wireless network
Summary: Kernel panic or freezes when connecting to wireless network
Status: CLOSED DUPLICATE of bug 195299
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: DO NOT USE - assign "network-wireless-intel" component instead
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-28 20:29 UTC by Łukasz Siudut
Modified: 2017-06-28 21:12 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.11 4.9
Tree: Mainline
Regression: No


Attachments
dmesg from kernel 4.9 (107.76 KB, text/plain)
2017-06-28 20:29 UTC, Łukasz Siudut
Details

Description Łukasz Siudut 2017-06-28 20:29:41 UTC
Created attachment 257203 [details]
dmesg from kernel 4.9

Hardware:
ThinkPad Yoga X1 gen 1
04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

Plot:
I bought recently a TP-LINK Archer C7 v2 router and started to play with alternative firmwares. Since LEDE was not satisfying me in terms of wireless performance I decided to give DD-WRT a try. After installation of the newest  firmware I setup VHT80 network + WPA2 personal and tried to connect:

- on KSPP kernel 4.11 computer freezed immediately, I couldn't even check tty for OOPS
- on generic 4.11 it also got a freeze, but I was able to switch to ttyS2 and make a picture of the OOPS
- on generic 4.9 kernel I was able to save dmesg output (see attached file), eventually didn't connect - but also didn't freeze

The freeze is 100% reproducable. I didn't try to play with module parameters nor wireless network settings, but I can do it tomorrow if necessary.

I use Arch with testing repositories enabled. Was connecting through network manager. 

Also I tried another computers, one with Atheros 9280 wifi card, another with Intel 7260 (non-ac version). Both connected successfully.

Once again - let me know if I can provide you more details. I don't know what information would be useful to you and don't have time to try random combinations of module params / wireless network settings.
Comment 1 Łukasz Siudut 2017-06-28 20:35:56 UTC
Also semi-elegant url to picture of OOPS on 4.11:

https://drive.google.com/file/d/0Bwm2q-PtQUkZNV83c3B2a3ZCYUk/view
Comment 2 Emmanuel Grumbach 2017-06-28 21:11:00 UTC

*** This bug has been marked as a duplicate of bug 195299 ***

Note You need to log in before you can comment on or make changes to this bug.