Bug 196041 - ACPI Error: [CFGD] Namespace lookup failure, AE_NOT_FOUND
Summary: ACPI Error: [CFGD] Namespace lookup failure, AE_NOT_FOUND
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-12 06:36 UTC by Artur Plysyuk
Modified: 2018-02-27 11:59 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.11.3-1-ARCH
Tree: Mainline
Regression: No


Attachments
ACPI dump (785.84 KB, text/plain)
2017-06-12 21:26 UTC, Artur Plysyuk
Details
dmesg output (66.52 KB, text/plain)
2017-06-26 06:42 UTC, Artur Plysyuk
Details

Description Artur Plysyuk 2017-06-12 06:36:16 UTC
$ sudo dmidecode | grep -e Date -e Vendor -e Version -e Product | head -n 4
	Vendor: Hewlett-Packard
	Version: L70 Ver. 01.36
	Release Date: 09/26/2016
	Product Name: HP ZBook 15


Errors from logs:

$ journalctl -b | grep "ACPI Error"
чер 12 09:17:48 arch kernel: ACPI Error: [CFGD] Namespace lookup failure, AE_NOT_FOUND (20170119/psargs-363)
чер 12 09:17:48 arch kernel: ACPI Error: Method parse/execution failed [\_TZ.PSL] (Node ffff88048d0a90f0), AE_NOT_FOUND (20170119/psparse-543)
чер 12 09:17:48 arch kernel: ACPI Error: Method parse/execution failed [\_TZ.GFXZ._PSL] (Node ffff88048d0a9e88), AE_NOT_FOUND (20170119/psparse-543)
чер 12 09:17:49 arch kernel: ACPI Error: [CFGD] Namespace lookup failure, AE_NOT_FOUND (20170119/psargs-363)
чер 12 09:17:49 arch kernel: ACPI Error: Method parse/execution failed [\_TZ.PSL] (Node ffff88048d0a90f0), AE_NOT_FOUND (20170119/psparse-543)
чер 12 09:17:49 arch kernel: ACPI Error: Method parse/execution failed [\_TZ.BATZ._PSL] (Node ffff88048d0a92d0), AE_NOT_FOUND (20170119/psparse-543)

and warnings:
$ journalctl -b | grep Warning     
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000001828-0x000000000000182F conflicts with OpRegion 0x0000000000001800-0x000000000000187F (\PMIO) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000840-0x000000000000084F conflicts with OpRegion 0x0000000000000800-0x0000000000000BFF (\GPIO) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000830-0x000000000000083F conflicts with OpRegion 0x0000000000000800-0x000000000000083F (\GPRL) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000830-0x000000000000083F conflicts with OpRegion 0x0000000000000800-0x0000000000000BFF (\GPIO) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000800-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x000000000000083F (\GPRL) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000800-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x0000000000000BFF (\GPIO) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000800-0x000000000000082F conflicts with OpRegion 0x0000000000000810-0x0000000000000813 (\IO_D) (20170119/utaddress-247)
чер 12 09:17:48 arch kernel: ACPI Warning: SystemIO range 0x0000000000000800-0x000000000000082F conflicts with OpRegion 0x0000000000000800-0x000000000000080F (\IO_T) (20170119/utaddress-247)
чер 12 09:17:49 arch kernel: ACPI Warning: \_SB.PCI0.PEGP.DGFX._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170119/nsarguments-95)
чер 12 09:17:49 arch kernel: ACPI Warning: \_SB.PCI0.PEGP.DGFX._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170119/nsarguments-95)
Comment 1 Len Brown 2017-06-12 21:24:20 UTC
please attach the output from "sudo acpidump > acpidump.out"
Comment 2 Artur Plysyuk 2017-06-12 21:26:44 UTC
Created attachment 256967 [details]
ACPI dump
Comment 3 Lv Zheng 2017-06-26 06:37:47 UTC
CFGD defined in ssdt5.dsl:

It looks like _PSL was executed too early.
Could you upload full dmesg for further investigation?
Comment 4 Artur Plysyuk 2017-06-26 06:42:13 UTC
Created attachment 257177 [details]
dmesg output
Comment 5 Zhang Rui 2017-07-02 08:43:50 UTC
dsdt.dsl:    External (CFGD, UnknownObj)
ssdt10.dsl:    External (CFGD, UnknownObj)
ssdt2.dsl:    External (CFGD, UnknownObj)

    Scope (\_PR)
    {
        OperationRegion (PPMT, SystemMemory, 0x5EF67F98, 0x003A)
        Field (PPMT, AnyAcc, Lock, Preserve)
        {
            PGRV,   8,
            CFGD,   32,
    ...

Lv,
should CFGD be declared as External(CFGD) or External(_PR_.CFGD)?
Comment 6 Zhang Rui 2017-07-03 07:25:17 UTC
This is caused by buggy firmware.
External (_PR_.CFGD, UnknownObj) should be used to refer to the CFGD object. 

We can not do anything in Linux kernel. Bug closed.
Comment 7 Jeremy Murphy 2018-02-26 10:58:41 UTC
Erk, I also have this problem. Time to take it up with HP, I guess.
Comment 8 Jeremy Murphy 2018-02-27 11:59:07 UTC
In case anyone else is interested, I've posted a discussion for this on their support forum: 

https://h30434.www3.hp.com/t5/Notebook-Operating-System-and-Recovery/ZBook-15-ACPI-Error-in-Linux-kernel-CFGD-is-an-unknown/m-p/6600728

I don't know how much traction that will get but I'm not sure what else to try.

Note You need to log in before you can comment on or make changes to this bug.