Bug 1960 - S3 resume - no video - Dell 5150
Summary: S3 resume - no video - Dell 5150
Status: REJECTED DUPLICATE of bug 3670
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 low
Assignee: Venkatesh Pallipadi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-27 15:11 UTC by Kevin
Modified: 2005-01-03 18:47 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.0 and 2.6.1
Tree: Mainline
Regression: ---


Attachments
dmesg output (12.32 KB, application/octet-stream)
2004-01-27 15:25 UTC, Kevin
Details

Description Kevin 2004-01-27 15:11:52 UTC
Distribution: Fedora core 1
Hardware Environment: Dell 5150 inspiration bios A29 
Software Environment: Default Gnome
Problem Description: /proc/acpi/sleep (any state) the system goes into standby
just fine, upon pressing power button to resume I get the following

Back to C!
i8042c: Warning: Keylock active
PM: Finishing up
PCI: Setting latency timer of device 0000:00:id.0 to64
PCI: Setting latency timer of device 0000:00:id.1
PCI: Setting latency timer of device 0000:00:id.2

System just sits there idle, after some time fan runs on high, keyboard
unresponsive, mouse and wifi card dead, have to do a hard reboot of the system
by holding power button down 10 seconds.

Steps to reproduce: have disconnected external mouse, wifi card and printer,
tried without an X server running and booted with "pci=noacpi" but the problem
persists. Same exact symptoms on either 2.6.0 or 2.6.1 kernel. Stock Fedora
kernel system resumes fine.
Comment 1 Kevin 2004-01-27 15:25:42 UTC
Created attachment 1957 [details]
dmesg output

dmesg output
Comment 2 Len Brown 2004-02-18 18:35:08 UTC
any luck with 2.6.3 -- it is working for me.  thanks, -Len
Comment 3 Robert Paskowitz 2004-02-21 23:12:45 UTC
Problem still occurs up to 2.6.3 here. 
 
Symptoms are similar, but not identical. 
 
Going to S1, I get the same messages, but actually going into the mode, the 
LCD does not turn off. (I have the Radeon 9000 video card) 
 
Going into S3, the LCD does not come back on, so no messages can be found 
 
S4 actually works, so long as X is not running, and that may be related to 
known DRI issues. 
Comment 4 Philippe Chatelain 2004-02-22 20:58:07 UTC
Just to add my 2 cents:
Similar behavior observed on my system:
Distro: FC1
Hardware: Dell 600m BIOS 09, w/ Centrino Wireless, ACPI enabled
Software: Stock Gnome + XFree86 4.3.99.903 + kernel 2.6.3

Only have tried S1, from X:
system goes into standby, screen goes to a console and does not go off.
(that's why I can see all the messages going into std-by and resuming)
Try to resume, I see the 3 messages "PCI: Setting latency ..."
and the system just hangs there.
Comment 5 Kester Maddock 2004-03-18 01:03:32 UTC
Same problem here, however, my 5150 can resume from S1 if: 
IO-APIC & Local APIC are enabled (or crashes at Back to C!) 
ehci-hcd is rmmod'd 
snd-intel8x0 (ALSA) is rmmod'd 
 
Screen & keyboard are dead on resume from S3 
Comment 6 Len Brown 2004-07-22 10:43:12 UTC
I ran 2.6.7 + the latest ACPI patch on a Dell 5150 yesterday
and S3 resume worked except the video.  Was running text-mode
console on NVIDIA hardware.
Comment 7 Len Brown 2004-07-25 20:11:55 UTC
please test this patch and let me know if
wakes up the blank screen after resume.

http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/test/2.6.8/wake
up.patch
Comment 8 Josh Abraham 2004-08-01 13:09:49 UTC
i have tried everything possible to get this to work on the
5150. I have the latest bios version A35 also, compiled the 
kernel with smp without smp. I have applied the most recent 
patch, as you know len, and it currently does suspend properly
however, it does resume but X doesn't work. 

Kernel 2.6.7  + 
http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.7/a
cpi-20040715-2.6.7.diff.bz2 +

http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/test/2.6.8/wake
up.patch

Thanks 
Josh Abraham

If anymore information would help let me know.
Comment 9 Len Brown 2004-11-15 22:09:53 UTC
so with the latest kernel and a recent X sub-system, we're down 
to video restore on resume? 
 
Please try out the acpi_sleep options from Documentation/power/video.txt 
Also, please try out the workaround in bug 3670 
Comment 10 Josh Abraham 2004-11-16 10:50:32 UTC
I tried passing the following parameters to the kernel

acpi_sleep=s3_bios 

Also tried

acpi_sleep=s3_bios 

I had the same result. The system suspends just fine. However, when I go to
resume the system reboots. I have tried this running in X and in console mode
with the same result. 

I am currently running the following:

kernel 2.6.9
NVIDIA-Linux-x86-1.0-6629

Let me know if anyone needs more information.

-Josh Abraham
Comment 11 Josh Abraham 2004-11-16 10:58:18 UTC
the second parameter is

acpi_sleep=s3_mode

sorry for the mistake.
-Josh
Comment 12 Josh Abraham 2004-11-28 11:02:39 UTC
I decided to do some more testing on the kernel to make sure I could still
access the machine. I was able to ssh to the machine after I suspend and resume. 
Comment 13 Len Brown 2005-01-03 18:47:56 UTC

*** This bug has been marked as a duplicate of 3670 ***

Note You need to log in before you can comment on or make changes to this bug.