Bug 195975 - Kernels 4.11+ reset BIOS settings on Thinkpad Yoga
Summary: Kernels 4.11+ reset BIOS settings on Thinkpad Yoga
Status: RESOLVED DUPLICATE of bug 195951
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: acpi_bios
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-04 10:13 UTC by Julius Bullinger
Modified: 2017-06-04 10:15 UTC (History)
0 users

See Also:
Kernel Version: 4.11, 4.12
Tree: Mainline
Regression: No


Attachments
boot.log (2.60 KB, application/octet-stream)
2017-06-04 10:13 UTC, Julius Bullinger
Details

Description Julius Bullinger 2017-06-04 10:13:17 UTC
Created attachment 256855 [details]
boot.log

Kernels 4.11+ reset BIOS settings on Thinkpad Yoga

Description of problem:
After installing Linux 4.11, my BIOS settings get reset on every restart. Booting the system after it was run with kernel-4.11.3-200.fc25.x86_64 shows a BIOS message "Configuration was reset", the system restarts and all settings are reset to default.
This doesn't happen with the 4.10 kernels.

Version-Release number of selected component (if applicable):
 * kernel-4.10.17-200.fc25.x86_64
 * kernel-4.11.2-200.vanilla.knurd.1.fc25.x86_64
 * kernel-4.11.3-200.fc25.x86_64
 * kernel-4.12.0-0.rc2.git0.1.vanilla.knurd.1.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install kernel-4.11 or 4.12-rc2
2. Boot into it
3. Restart the system
4. "Configuration was reset" BIOS message is shown
5. The system resets
6. BIOS settings are back to default
7. Change some BIOS settings
8. Boot with an older kernel (<=4.10), and reboot
9. BIOS settings stay as set

Actual results:
see above

Expected results:
The system restarts without resetting BIOS settings

Additional info:
* Thinkpad S1 Yoga (Type 20CD)
* Tested BIOS versions 1.29 and 1.31 (latest)
Comment 1 Julius Bullinger 2017-06-04 10:15:41 UTC
Sorry, seems like this was already reported as #195951. My bad!

*** This bug has been marked as a duplicate of bug 195951 ***

Note You need to log in before you can comment on or make changes to this bug.