Bug 195931 - Random crashes on mostly idle laptop
Summary: Random crashes on mostly idle laptop
Status: RESOLVED INVALID
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-30 18:48 UTC by André Breda
Modified: 2017-06-29 18:55 UTC (History)
0 users

See Also:
Kernel Version: 4.12-rc3
Tree: Mainline
Regression: No


Attachments
kernel log (from netconsole) (56.64 KB, text/plain)
2017-05-30 18:48 UTC, André Breda
Details

Description André Breda 2017-05-30 18:48:28 UTC
Created attachment 256781 [details]
kernel log (from netconsole)

My new Kaby Lake laptop (HP 15-ay105n with an Intel i7-7500U) seems to not like Linux at all.
At seemingly random times, the system crashes (screen freezes, no caps lock blink, does not respond to magic SysRq commands) or I experience a normal kernel panic with the blinky caps lock. It's a bit difficult to capture logs for the crash since sometimes I get nothing even without starting X11. With netconsole and a few attempts, I managed to capture what might be related to this issue.
This problem seems to be present from earlier versions of the Kernel, so I suspect it's either a Kaby Lake-specific bug, a bug that was "dormant" until something in my hardware (kaby lake, the motherboard...) helped waking it or bad firmware from HP that might require special handling to work properly.
Comment 1 André Breda 2017-06-29 18:55:34 UTC
Hardware issue: HP replaced my motherboard.

Note You need to log in before you can comment on or make changes to this bug.