Bug 195319 - PCI IRQ allocation broken
Summary: PCI IRQ allocation broken
Status: CLOSED DUPLICATE of bug 195311
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Tables (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-11 01:33 UTC by Bjorn Helgaas
Modified: 2017-07-04 01:25 UTC (History)
3 users (show)

See Also:
Kernel Version: v4.11-rc5
Tree: Mainline
Regression: Yes


Attachments
v4.11-rc5 dmesg log (34.08 KB, text/plain)
2017-04-11 01:33 UTC, Bjorn Helgaas
Details
acpidump output from an affected Dell Vostro 1500 (121.89 KB, text/plain)
2017-04-12 22:47 UTC, Michael Marley
Details
dmesg output from 4.11-rc6 on an affected Dell Vostro 1500 (55.96 KB, text/plain)
2017-04-12 22:47 UTC, Michael Marley
Details
dmesg output from 4.10.10 on an affected Dell Vostro 1500 (58.32 KB, text/plain)
2017-04-12 22:48 UTC, Michael Marley
Details

Description Bjorn Helgaas 2017-04-11 01:33:43 UTC
Created attachment 255817 [details]
v4.11-rc5 dmesg log

[Opened on behalf of Meelis Roos <mroos@linux.ee> for the problem reported at https://lkml.kernel.org/r/alpine.LRH.2.20.1704102317110.14071@math.ut.ee]

This happens on my HP Compaq 8100 Elite SFF PC. While 4.10 works fine,
4.11.-rc5 and at least back to 4.10.0-10770-g2d6be4abf514 fail to assign
PCI IRQ to multiple devices (no GSI messages in the dmesg). This results
in mouse in one USB port working and keyboard in another USB port not
working, reproducibly.

Will bisect.
Comment 1 Bjorn Helgaas 2017-04-11 01:46:33 UTC
Reassigning to ACPI because something went wrong parsing the PNP0A08 host bridge device (there are several other ACPI warnings in the dmesg log as well):

  acpi PNP0A08:00: [Firmware Bug]: no secondary bus range in _CRS
  ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20170119/nsarguments-189)
  acpi PNP0A08:00: failed to parse _CRS method, error code -5
  acpi PNP0A08:00: Bus 0000:00 not present in PCI namespace

I think the PCI IRQ problems are probably a consequence of these ACPI-related issues.
Comment 2 Zhang Rui 2017-04-12 02:35:01 UTC
(In reply to Bjorn Helgaas from comment #1)
> Reassigning to ACPI because something went wrong parsing the PNP0A08 host
> bridge device (there are several other ACPI warnings in the dmesg log as
> well):
> 
>   acpi PNP0A08:00: [Firmware Bug]: no secondary bus range in _CRS
>   ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL declared 5,
> ACPI requires 4 (20170119/nsarguments-189)
>   acpi PNP0A08:00: failed to parse _CRS method, error code -5
>   acpi PNP0A08:00: Bus 0000:00 not present in PCI namespace
> 
Are all these new in 4.11-rc?
it would be nice if you can attach the dmesg for both 4.10 and 4.11-rc, and also the acpidump.
Comment 3 Michael Marley 2017-04-12 22:47:19 UTC
Created attachment 255871 [details]
acpidump output from an affected Dell Vostro 1500
Comment 4 Michael Marley 2017-04-12 22:47:52 UTC
Created attachment 255873 [details]
dmesg output from 4.11-rc6 on an affected Dell Vostro 1500
Comment 5 Michael Marley 2017-04-12 22:48:11 UTC
Created attachment 255875 [details]
dmesg output from 4.10.10 on an affected Dell Vostro 1500
Comment 6 Michael Marley 2017-04-12 22:49:44 UTC
One of my laptops (an old Dell Vostro 1500) is also affected by this bug, causing (among other things) the USB controllers and the NIC to not work.  I have attached dmesg outputs from working and non-working kernels and acpidump output.  If I can provide anything else, please let me know.
Comment 7 Lv Zheng 2017-04-13 06:40:33 UTC
Could you check bug 195311 and see if reverting "commit 57707a9a77 (ACPICA: Resources: Not a valid resource if buffer length too long)" helps.
Comment 8 Michael Marley 2017-04-13 11:02:07 UTC
The computer works correctly with that commit reverted, thanks!
Comment 9 Zhang Rui 2017-04-13 12:51:27 UTC

*** This bug has been marked as a duplicate of bug 195311 ***
Comment 10 Lv Zheng 2017-07-04 01:25:09 UTC
Closing duplicated bugs

Note You need to log in before you can comment on or make changes to this bug.