Bug 195231 - Continuous messages of "*ERROR* UVD not responding, trying to reset the VCPU!!!" and frozen screen
Summary: Continuous messages of "*ERROR* UVD not responding, trying to reset the VCPU!...
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-03 15:37 UTC by Rogério Brito
Modified: 2018-07-20 22:16 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.10.3
Tree: Mainline
Regression: No


Attachments
Messages that I get from the kernel. (3.56 MB, image/jpeg)
2017-04-03 15:38 UTC, Rogério Brito
Details
dmesg log with showing the problem and with oops (69.79 KB, text/plain)
2017-04-03 18:20 UTC, Rogério Brito
Details
Xorg log when it crashes (43.17 KB, text/plain)
2017-04-03 18:21 UTC, Rogério Brito
Details
dmesg log with radeon.runpm=0 (96.13 KB, text/plain)
2017-04-03 18:22 UTC, Rogério Brito
Details
Xorg log with radeon.runpm=0 (43.17 KB, text/plain)
2017-04-03 18:23 UTC, Rogério Brito
Details

Description Rogério Brito 2017-04-03 15:37:22 UTC
Hi.

First of all, I'm not sure if I selected the correct category when filing this bug. I don't mind being corrected here.

OK, now, to the actual bug report.

My mother has a Dell Inspiron 15R N5110, which has an intel Sandy Bridge integrated card and an AMD Radeon card (if I'm not mistaken it is reported as an HD6400 series card, not being more specific).

According to my mother, it was working correctly with an Ubuntu running their kernel 4.4 until it started only showing a black screen about 15 days ago.

I took her notebook and saw that the problem is that the kernel is now showing many times the message "*ERROR* UVD not responding, trying to reset the VCPU!!!" and the graphical environment does not completes loading.

I tried using Ubuntu's precompiled and unpatched 4.10.3, but the problem persists (in fact, I was ping-pong'ing with many kernel versions to see if something worked).

Besides working around the issue with radeon.modeset=0, so that the computer can successfully boot, I don't know what to do to fix this issue, but I can provide as much information as needed about it.

The unfortunate thing with the radeon.modeset=0 (that wasn't necessary, say, about one month ago) is that she can't play some games that she used to and that's her only entertainment, after having been diagnosed with some serious illness. :(

Again, I can provide as much information as needed.


Thanks,

Rogério Brito.
Comment 1 Rogério Brito 2017-04-03 15:38:48 UTC
Created attachment 255739 [details]
Messages that I get from the kernel.
Comment 2 Alex Deucher 2017-04-03 16:02:42 UTC
Please attach your xorg log and dmesg output.  Does appending radeon.runpm=0 on the kernel command line in grub help?
Comment 3 Rogério Brito 2017-04-03 18:16:59 UTC
Dear Alex,

(In reply to Alex Deucher from comment #2)
> Please attach your xorg log and dmesg output.  Does appending radeon.runpm=0
> on the kernel command line in grub help?

I'm attaching them.

The dmesg output shows an Ooops when I start X from a command line. I had to arrange things via SSH, since the keyboard stops responding and, sometimes, the kernel reboots the system.

Regarding your question, appending radeon.runpm=0 does help. The Oops is absent, but "UVD not responding messages are still present". At least, the system boots up to the desktop and it works, but I don't quite know how to check which card is working at a given point in time (if the Intel one or the if the radeon card).

Thanks,

Rogério.
Comment 4 Rogério Brito 2017-04-03 18:20:32 UTC
Created attachment 255745 [details]
dmesg log with showing the problem and with oops
Comment 5 Rogério Brito 2017-04-03 18:21:41 UTC
Created attachment 255747 [details]
Xorg log when it crashes
Comment 6 Rogério Brito 2017-04-03 18:22:45 UTC
Created attachment 255749 [details]
dmesg log with radeon.runpm=0
Comment 7 Rogério Brito 2017-04-03 18:23:31 UTC
Created attachment 255751 [details]
Xorg log with radeon.runpm=0
Comment 8 Rogério Brito 2017-04-03 18:25:12 UTC
If you need more information, please let me know and I will try my best to provide anything.

Thanks,

Rogério.
Comment 9 Rogério Brito 2017-04-06 04:03:43 UTC
(In reply to Alex Deucher from comment #2)
> Please attach your xorg log and dmesg output.  Does appending radeon.runpm=0
> on the kernel command line in grub help?

Dear Alex and other developers, do you need any extra information from me? I will do my best to gather anything that may be helpful in fixing this bug.


Thanks,

Rogério.
Comment 10 rbrito 2017-04-07 20:54:50 UTC
Dear Alex and other developers,

On Thu, Apr 6, 2017 at 1:03 AM,  <bugzilla-daemon@bugzilla.kernel.org> wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=195231
>
> --- Comment #9 from Rogério Brito (rbrito@ime.usp.br) ---
> (In reply to Alex Deucher from comment #2)
>> Please attach your xorg log and dmesg output.  Does appending radeon.runpm=0
>> on the kernel command line in grub help?
>
> Dear Alex and other developers, do you need any extra information from me? I
> will do my best to gather anything that may be helpful in fixing this bug.

I just installed Ubuntu's precompiled and unpatched kernel 4.11-rc5
and the messages of "UVD not responding" like in the subject persist,
also with the whole system hanging.

If I append radeon.runpm=0, the system does boot, but the messages are
still there. It is, though, taking ages to boot, compared to what it
used to be.

Once again, if anybody wants me to try any kernel, just tell me and I
will do my best.

I will update the information that I grab and/or those that people ask
me and put those at this bug on bugzilla
(https://bugzilla.kernel.org/show_bug.cgi?id=195231).


Thanks,

Rogério.
Comment 11 Christian König 2017-04-10 06:50:08 UTC
Well bisecting which patch caused the break would be a good idea.

To start that I suggest you try to compile kernel 4.4 by yourself first.

That should also yield a temporary solution until we can narrow down the root cause.
Comment 12 rbrito 2017-04-10 17:27:19 UTC
Dear Alex, Christian and others,

On Mon, Apr 10, 2017 at 3:50 AM,  <bugzilla-daemon@bugzilla.kernel.org> wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=195231
> --- Comment #11 from Christian König (deathsimple@vodafone.de) ---
> Well bisecting which patch caused the break would be a good idea.

First of all, I hope you don't mind that I'm including my mom here, so
that she can follow how her computer is doing, or, rather, what I am
doing with her computer.

> To start that I suggest you try to compile kernel 4.4 by yourself first.
>
> That should also yield a temporary solution until we can narrow down the root
> cause.

I tried using Ubuntu's unpatched/precompiled kernels 4.2, 4.4, 4.8,
4.10 and 4.11-rc5 and, apparently, they now always show this message
*and* it frequently freezes to the point that no magic Sysrq keys
work, sometimes the caps lock kernel blinks and so on.

Booting with radeon.modeset=0 allows the computer to boot to the
desktop environment, but makes the CPU so hot when she plays her
flashplayer-based games that the kernel shows many messages of thermal
limit being reached and CPU speed being throttled.

Booting with radeon.runpm=0 still gets me all the error messages
listed in the subject (and present in the logs that I sent to
bugzilla), but the temperature *seems* to be slightly lower (not
enough testing was done with this configuration).

I don't know how to see/check what GPU is being used at a given time:
if the Intel GPU or if the AMD GPU...

So, given that the problem now seems to be present with all those
kernel versions that I tested, is it worthwhile to compile my own
kernels?

As before, I will try to do whatever I'm directed to.


Thanks a lot,

Rogério.
Comment 13 Rogério Brito 2018-07-20 22:16:52 UTC
I don't have the hardware in question at hand anymore.

Thanks for all the help.

Note You need to log in before you can comment on or make changes to this bug.