Bug 194941 - dvb_usb_mxl111sf: transfer buffer not dma capable
Summary: dvb_usb_mxl111sf: transfer buffer not dma capable
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-19 22:34 UTC by Dan Ziemba
Modified: 2017-08-06 04:04 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.10.4
Tree: Mainline
Regression: No


Attachments
stack trace with 4.10.4 (5.54 KB, text/plain)
2017-03-19 22:34 UTC, Dan Ziemba
Details

Description Dan Ziemba 2017-03-19 22:34:24 UTC
Created attachment 255353 [details]
stack trace with 4.10.4

After upgrading to kernel 4.9+, "Hauppauge WinTV-Aero-M" usb ATSC tuner card using the mxl111sf driver is no longer usable.  Dmesg shows error "transfer buffer not dma capable".  4.8.12 was the last kernel where this worked properly (I have not tried any later 4.8.x versions).  All versions of 4.9 and 4.10 that I have tested fail with the same error, including current 4.9.16 and 4.10.4. Stack trace from dmesg is attached.

This seems similar to the Fedora bug here, although this bug is about a dvb v1 driver and mxl111sf is dvb v2:
https://bugzilla.redhat.com/show_bug.cgi?id=1417829

Which seems to have been fixed by this change:
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?id=43fab9793c1f44e665b4f98035a14942edf03ddc
Comment 1 Dan Ziemba 2017-08-06 04:04:18 UTC
Driver is now working correctly with kernel 4.12.6 since this was added:
https://patchwork.kernel.org/patch/9693445/

Note You need to log in before you can comment on or make changes to this bug.