Bug 194719 - ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
Summary: ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160...
Status: CLOSED DOCUMENTED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-27 00:16 UTC by Martin Mokrejs
Modified: 2017-07-04 01:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.10.0-gentoo
Tree: Mainline
Regression: No


Attachments
Linux kernel .config for Asus G552VW (120.33 KB, text/plain)
2017-02-27 00:18 UTC, Martin Mokrejs
Details
dmesg-4.10.0-gentoo.acpi_osi__unchanged.txt (60.86 KB, text/plain)
2017-02-27 00:34 UTC, Martin Mokrejs
Details
dmesg-4.10.0-gentoo.acpi_osi__Linux.txt (63.80 KB, text/plain)
2017-02-27 00:34 UTC, Martin Mokrejs
Details
dmesg-4.10.0-gentoo.acpi_osi__Windows.txt (60.92 KB, text/plain)
2017-02-27 00:34 UTC, Martin Mokrejs
Details
dmesg-4.10.0-gentoo.acpi_osi__exclamation_mark.txt (60.98 KB, text/plain)
2017-02-27 00:34 UTC, Martin Mokrejs
Details
dmesg-4.10.0-gentoo.BIOS_2.18.txt (62.96 KB, text/plain)
2017-02-27 00:46 UTC, Martin Mokrejs
Details
Asus_G552VW.acpidump (973.94 KB, text/plain)
2017-02-27 00:55 UTC, Martin Mokrejs
Details
grep . /sys/firmware/acpi/interrupts/* (9.94 KB, text/plain)
2017-02-27 01:02 UTC, Martin Mokrejs
Details
/proc/interrupts (4.38 KB, text/plain)
2017-02-27 01:08 UTC, Martin Mokrejs
Details
Asus_G552VW.dmidecode.txt (13.51 KB, text/plain)
2017-02-27 01:19 UTC, Martin Mokrejs
Details
ls -latr /sys/class/leds/ (1.64 KB, text/plain)
2017-02-27 01:23 UTC, Martin Mokrejs
Details
dmesg-4.10.0-gentoo.acpi_osi__Windows.dyndbg.txt (640.12 KB, text/plain)
2017-02-27 10:01 UTC, Martin Mokrejs
Details

Description Martin Mokrejs 2017-02-27 00:16:13 UTC
Hi,
  on Asus laptop G552VW with latest UEFI BIOS 3.0 and I have problems, like many others (previous BIOS was 2.81 or 2.18? but seemed same in behavior). I have no keyboard backlight and some Fn buttons do not work. I have some ACPI related errors triggered by those key-presses:

[  513.317864] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[  513.317869] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0E] (Node ffff88048187da78), AE_NOT_FOUND (20160930/psparse-543)


[ 1651.727340] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1651.727345] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0F] (Node ffff88048187da50), AE_NOT_FOUND (20160930/psparse-543)


[ 1652.204458] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1652.204460] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0E] (Node ffff88048187da78), AE_NOT_FOUND (20160930/psparse-543)





I used acpi_listen to monitor key codes. I used 4.10.0-gentoo kernel with acpi_osi=Windows kernel commandline option.


Fn+F1
button/sleep SBTN 00000080 00000000
button/sleep PNP0C0E:00 00000080 00000001

Fn+F2
really does rfkill so I do not see the code captured, acpi_listen shows nothing

Fn+F3 decrease keyboard light?
PNP0C14:01 000000ff 00000000

Fn+F4 increase keyboard light?
PNP0C14:01 000000ff 00000000

Fn+F5
video/brightnessdown BRTDN 00000087 00000000

Fn+F6
video/brightnessup BRTUP 00000086 00000000

Fn+F7 turn on/off display
 PNP0C14:01 000000ff 00000000
 video/displayoff DOFF 00000089 00000000 K

Fn+F8 switch displays
really started xfce4 app to switch displays, acpi_listen shows nothing

Fn+F9 disable ELAN touchpad (no, my mouse pointer still moves)
 PNP0C14:01 000000ff 00000000

Fn+F10 mute sound
button/mute MUTE 00000080 00000000 K

Fn+F11
button/volumedown VOLDN 00000080 00000000 K

Fn+F12
button/volumeup VOLUP 00000080 00000000 K


I was fiddling with the kernel commandline so I will upload all the dmesg outputs so that you can use diff command to inspect the differences. Notably, I tried:

'none changes to the running kernel'
acpi_osi=!
acpi_osi=Linux
acpi_osi=Windows

The acpi_osi=! causes that I loose:
input: Asus Wireless Radio Control as /devices/LNXSYSTM:00/LNXSYBUS:00/ATK4002:00/input/input8
Comment 1 Martin Mokrejs 2017-02-27 00:18:05 UTC
Created attachment 254931 [details]
Linux kernel .config for Asus G552VW
Comment 2 Martin Mokrejs 2017-02-27 00:34:00 UTC
Created attachment 254933 [details]
dmesg-4.10.0-gentoo.acpi_osi__unchanged.txt
Comment 3 Martin Mokrejs 2017-02-27 00:34:21 UTC
Created attachment 254935 [details]
dmesg-4.10.0-gentoo.acpi_osi__Linux.txt
Comment 4 Martin Mokrejs 2017-02-27 00:34:36 UTC
Created attachment 254937 [details]
dmesg-4.10.0-gentoo.acpi_osi__Windows.txt
Comment 5 Martin Mokrejs 2017-02-27 00:34:54 UTC
Created attachment 254939 [details]
dmesg-4.10.0-gentoo.acpi_osi__exclamation_mark.txt
Comment 6 Martin Mokrejs 2017-02-27 00:46:01 UTC
Created attachment 254941 [details]
dmesg-4.10.0-gentoo.BIOS_2.18.txt

Here is one with previous BIOS 2.18 before an upgrade but based on a bit different .config.
Comment 7 Martin Mokrejs 2017-02-27 00:55:33 UTC
Created attachment 254943 [details]
Asus_G552VW.acpidump
Comment 8 Martin Mokrejs 2017-02-27 01:02:11 UTC
Created attachment 254945 [details]
grep . /sys/firmware/acpi/interrupts/*

grep . /sys/firmware/acpi/interrupts/*

Just guessing what you may need, thanks to https://bugzilla.kernel.org/show_bug.cgi?id=112531#c11
Comment 9 Martin Mokrejs 2017-02-27 01:08:37 UTC
Created attachment 254947 [details]
/proc/interrupts
Comment 10 Martin Mokrejs 2017-02-27 01:19:51 UTC
Created attachment 254949 [details]
Asus_G552VW.dmidecode.txt
Comment 11 Martin Mokrejs 2017-02-27 01:23:01 UTC
Created attachment 254951 [details]
ls -latr /sys/class/leds/
Comment 12 Martin Mokrejs 2017-02-27 10:01:10 UTC
Created attachment 254959 [details]
dmesg-4.10.0-gentoo.acpi_osi__Windows.dyndbg.txt

I added acpi.trace_state=enable "dyndbg=file ec.c +p" to my kernel commandline and booted like in 

attachment_id:254937: dmesg-4.10.0-gentoo.acpi_osi__Windows.txt

and pressed all the Fn keys while being in framebuffer console, from Fn+F1 to Fn+F12, twice each.
Comment 13 Lv Zheng 2017-02-28 01:05:25 UTC
Indeed, there is only one PRST (Method) in the namespace:

  194719\dsdt.dsl (15 hits)
	Line 78:     External (_SB_.PCI0.GFX0.PRST, IntObj)
	Line 88:     External (_SB_.PCI0.PEG0.PEGP.PRST, IntObj)
	Line 30191:             If (\_SB.PCI0.GFX0.PRST)
	Line 30196:             If (\_SB.PCI0.PEG0.PEGP.PRST)
	Line 30206:             If (\_SB.PCI0.GFX0.PRST)
	Line 30211:             If (\_SB.PCI0.PEG0.PEGP.PRST)
	Line 30221:             If (\_SB.PCI0.GFX0.PRST)
	Line 30227:             If (\_SB.PCI0.PEG0.PEGP.PRST)
	Line 30238:             If (\_SB.PCI0.GFX0.PRST)
	Line 30243:             If (\_SB.PCI0.PEG0.PEGP.PRST)
	Line 37399:             If (^^^GFX0.PRST)
	Line 37421:                 If (^^^GFX0.PRST)
	Line 37432:                 If (^^^PEG0.PEGP.PRST)
	Line 37499:                 If (^^^GFX0.PRST)
	Line 37510:                 If (^^^PEG0.PEGP.PRST)
  194719\ssdt2.dsl (1 hit)
	Line 4049:         Method (PRST, 0, NotSerialized)
Looks like a BIOS issue to me if the iasl disassembly result was correct.
Please contact the BIOS vendor.

Thanks
Lv
Comment 14 Martin Mokrejs 2017-03-06 22:11:59 UTC
(In reply to Lv Zheng from comment #13)
> Indeed, there is only one PRST (Method) in the namespace:
...
> Looks like a BIOS issue to me if the iasl disassembly result was correct.
> Please contact the BIOS vendor.
> 
> Thanks
> Lv

Sorry but I got rejected by ASUS support as this is not an MS Windows-based report. If anybody has some contacts there please try to get it fixed your way. Or try to find out how to repeat this under MS Win 10.
Comment 15 Lv Zheng 2017-07-04 01:13:45 UTC
Closing as documented to be a BIOS problem.

Note You need to log in before you can comment on or make changes to this bug.