Bug 194711 - Xbox 360 controller does not work when PC wakes from Suspend
Summary: Xbox 360 controller does not work when PC wakes from Suspend
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: drivers_input-devices
Depends on:
Reported: 2017-02-26 12:45 UTC by questionman1
Modified: 2017-02-26 23:47 UTC (History)
0 users

See Also:
Kernel Version: 4.8.0-39-generic
Regression: Yes
Bisected commit-id:


Description questionman1 2017-02-26 12:45:45 UTC
I recently bought a 360 controller and it has exhibited this problem in every rolling distro I've tried.  In Arch, Manjaro, and OpenSuse, the controller works fine when the PC starts.  But after waking up from suspend mode, the inputs are recognized, but the central LED flashes as the controller can't figure out which "player" it is.  Playing around with various drivers, including xpad, xboxdrv, steamos-xpad, did not resolve the issue.

Not only is this aesthetically inconvenient, but the controller then does not work for many games.

The controller works fine for all Ubuntu 16.04 distros I've used, Linux Mint 18 and KDE Neon.  Even after waking from suspend mode, the controller works fine.

In order to resolve another issue, I updated the default kernel in KDE Neon from 4.4.0-64-generic to the latest one on offer, 4.8.0-39-generic.  With that being the ONLY change I did, the controller problem began to exhibit itself once more.

This leads me to believe, along with the fact that I've tested this across 5 distros, that somewhere between 4.4.0-64-generic and 4.8.0-39-generic, a change was made that has caused this error.

If someone can look into this, I (and I'm assuming other gamers) would appreciate it.

Overview: Xbox 360 controller normally works fine.  When waking up from suspend, its central ring flashes and it can't figure out which "player" it is making it not work with games.

Steps to Produce:  1.) Put computer into suspend mode.  2.) Wake computer

Results: Central LED ring flashes continuously, controller is confused about which player it corresponds to, and ceases to work with various games I've tried.

Build: Tested across rolling distributions of Arch, Manjaro, and OpenSuse.  With their post 4.8 kernels, the problem exists.  Tested in Ubuntu 16.04 builds, with kernel 4.4.0-64-generic, and the problem does not exist.  The controller works fine.  ONLY updating the kernel (eg in KDE Neon) to 4.8.0-39-generic, causes the problem to appear.
Comment 1 questionman1 2017-02-26 23:47:53 UTC
Just for clarification, it is a wired controller.

Note You need to log in before you can comment on or make changes to this bug.