Bug 194697 - Xorg freeze on Apple MacBook Pro 8,2
Summary: Xorg freeze on Apple MacBook Pro 8,2
Status: RESOLVED DUPLICATE of bug 88861
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: drivers_video-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-24 20:33 UTC by Wilfried Klaebe
Modified: 2017-03-08 11:23 UTC (History)
0 users

See Also:
Kernel Version: 4.10 and others
Tree: Mainline
Regression: No


Attachments
Xorg and kernel logs (250.00 KB, application/x-tar)
2017-02-24 20:33 UTC, Wilfried Klaebe
Details

Description Wilfried Klaebe 2017-02-24 20:33:55 UTC
Created attachment 254909 [details]
Xorg and kernel logs

Hi all,

with Linux 4.10 I still have a problem I already had with at least 4.8: On my MacBook Pro 8.2 (aka "early 2011") with Intel IGD and AMD Radeon discrete GPU, using the Radeon (not switching to IGD with vga_switcheroo before) causes Xorg not to start. Somewhere I had found this mentioned in some discussion, together with a hint to revert commit 4eebd5a4e72697aac25a8a57d3f888a9d5f80370 ("apple-gmux: lock iGP IO to protect from vgaarb changes"), which helps.
I seem to remember there was a mention of some kind of deadlock somewhere in the DRM infrastructure that thread, causing not only Xorg to hang, but also making it impossible to access any gpu-driven console. It is possible to do a regular shutdown via ACPI powerbutton though.

I had hoped this would somehow get resolved by the people on that thread, but obviously, it didn't.

I'm attaching some Xorg and kernel logs of both working and non-working states. The kernel logs both(!) contain a warning about a possible circular locking dependency where vgaswitcheroo tries to acquire a lock it already holds. The "4.10.0" logs are from the non-working, hanging state, while the "4.10.0-00001-gdf6ffb763137" logs are from the working state running 4.10.0 with the mentioned commit reverted.
Comment 1 Jani Nikula 2017-03-08 11:23:31 UTC

*** This bug has been marked as a duplicate of bug 88861 ***

Note You need to log in before you can comment on or make changes to this bug.