Bug 193531 - Module Level Code - [_UPC] Namespace lookup failure, AE_ALREADY_EXISTS
Summary: Module Level Code - [_UPC] Namespace lookup failure, AE_ALREADY_EXISTS
Status: RESOLVED MOVED
Alias: None
Product: ACPI
Classification: Unclassified
Component: BIOS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-29 12:18 UTC by Radek Podgorny
Modified: 2018-11-10 00:15 UTC (History)
28 users (show)

See Also:
Kernel Version: 4.9.6
Tree: Mainline
Regression: No


Attachments
acpi info (809.12 KB, application/zip)
2017-01-29 12:18 UTC, Radek Podgorny
Details
acpidump.out (1006.91 KB, application/octet-stream)
2017-02-03 10:17 UTC, Radek Podgorny
Details
acpidump/out on fedora 25 (407.13 KB, application/octet-stream)
2017-02-03 13:27 UTC, Jose Luis Mantilla
Details
"sudo acpidump > acpidump.out" of a Dell Inspiron 7348 (714.26 KB, application/octet-stream)
2017-02-03 15:16 UTC, Vinícius Reis
Details
acpidump (763.14 KB, text/plain)
2017-02-11 21:40 UTC, Mentat
Details
Kernel Bisection rsult and log (3.92 KB, text/plain)
2017-02-15 00:56 UTC, Doug Smythies
Details
acpidump (500.58 KB, text/plain)
2017-02-23 14:58 UTC, Aleksandar
Details

Description Radek Podgorny 2017-01-29 12:18:12 UTC
Created attachment 253521 [details]
acpi info

i know nearly nothing about acpi so i'm sorry if there's some info missing (or not relevant):

after transition from 4.8 to 4.9 on my asus ux330ua with bios version 302 i get this error:

Jan 29 13:05:19 pupik kernel: ACPI Error: [_UPC] Namespace lookup failure, AE_ALREADY_EXISTS (20160831/dswload-378)
Jan 29 13:05:19 pupik kernel: ACPI Exception: AE_ALREADY_EXISTS, During name lookup/catalog (20160831/psobject-227)
Jan 29 13:05:19 pupik kernel: ACPI Exception: AE_ALREADY_EXISTS, (SSDT:xh_rvp07) while loading table (20160831/tbxfload-228)
Jan 29 13:05:19 pupik kernel: ACPI Error: 1 table load failures, 7 successful (20160831/tbxfload-246)

...attached is the output of this script: https://github.com/FadeMind/archbash/blob/master/bash_scripts/acpi_tables_tools/ACPI.EXTRACT.TABLES.LOG.BASH
Comment 1 Jose Luis Mantilla 2017-01-31 05:22:59 UTC
As for the technical details, these messages originates from the ACPI core. The _GPE._Lxx methods are level-triggered interrupts if I remember correctly and are triggered by the hardware (not Linux). Apparently this specific methods tries to evaluate some method or object at _TZ.THRM which failed because this ACPI scope does not exist.
-----------------------------------------------------------------------------
The possible fix right now is booting from whatever kernel 4.8.x or < 4.9.x. -- The kernel 4.9 includes something strange.

journalctl -b 0 -p err 
-- Logs begin at Thu 2017-01-26 08:58:56 EST, end at Fri 2017-01-27 18:59:23 EST. 
-- Jan 27 18:47:31 linux.soporte.com kernel: ACPI Exception: AE AMLPACKAGE_LIMIT, Index (0x000000003) is beyond end of object (length 0x0) (20160831/exoparg2-427)
Jan 27 18:47:31 linux.soporte.com kernel: ACPI Error: Method parse/execution failed [_SB.PCI0.GFX0. DSM] (Node ffff9b94a24c3a50), AEAMLPACKAGELIMIT (20160831/psparse-543)
Jan 27 18:47:31 linux.soporte.com kernel: ACPI Exception: AE AMLPACKAGE_LIMIT, Index (0x000000003) is beyond end of object (length 0x0) (20160831/exoparg2-427)
Jan 27 18:47:31 linux.soporte.com kernel: ACPI Error: Method parse/execution failed [_SB.PCI0.GFX0. DSM] (Node ffff9b94a24c3a50), AEAMLPACKAGELIMIT (20160831/psparse-543)
Jan 27 18:47:31 linux.soporte.com kernel: ACPI Error: Method parse/execution failed [_SB.PCI0.PEG0.PEGP. DSM] (Node ffff9b94a24dd9b0), AEAMLPACKAGELIMIT (20160831/psparse-543)
(END)
Comment 2 Vinícius Reis 2017-02-01 14:07:00 UTC
There are  people facing a similar issue on Fedora and Arch:
https://bugzilla.redhat.com/show_bug.cgi?id=1413342
Comment 3 Lv Zheng 2017-02-03 02:38:30 UTC
Hi,

Please just attach the output of the following command here:
 $ sudo acpidump > acpidump.out

Thanks and best regards
Lv
Comment 4 Radek Podgorny 2017-02-03 10:17:35 UTC
Created attachment 253911 [details]
acpidump.out
Comment 5 Radek Podgorny 2017-02-03 10:18:39 UTC
also, i forgot to mention i use this kernel cmdline:

Command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img root=/dev/disk/by-label/PUPIK_ROOT rw ___acpi_osi=
Comment 6 Jose Luis Mantilla 2017-02-03 13:27:39 UTC
Created attachment 253961 [details]
acpidump/out on fedora 25
Comment 7 Vinícius Reis 2017-02-03 15:16:07 UTC
Created attachment 253971 [details]
"sudo acpidump > acpidump.out" of a Dell Inspiron 7348
Comment 8 Jose Luis Mantilla 2017-02-03 15:42:36 UTC
I just want to say it happens only on kernels 4.9.x on whatever distro.
Comment 9 Vinícius Reis 2017-02-03 17:25:24 UTC
(In reply to Jose Luis Mantilla from comment #8)
> I just want to say it happens only on kernels 4.9.x on whatever distro.

Yes, well observed.
Comment 10 Ivan Jurišić 2017-02-05 10:42:13 UTC
I using motherboard: 

System Information
	Manufacturer: MSI
	Product Name: MS-7885
	Version: 5.0

BIOS Information
	Vendor: American Megatrends Inc.
	Version: P.50
	Release Date: 07/19/2016

dmesg | grep "ACPI Error":

[    2.170921] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    2.171107] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT1.SPT0._GTF] (Node ffff97449ed66b68), AE_NOT_FOUND (20160831/psparse-543)
[    2.171483] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    2.171670] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT1.SPT0._GTF] (Node ffff97449ed66b68), AE_NOT_FOUND (20160831/psparse-543)
[    2.171921] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    2.172122] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT1.SPT1._GTF] (Node ffff97449ed66690), AE_NOT_FOUND (20160831/psparse-543)
[    2.172714] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    2.172909] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT1.SPT1._GTF] (Node ffff97449ed66690), AE_NOT_FOUND (20160831/psparse-543)
[    2.173244] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    2.173442] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT1.SPT2._GTF] (Node ffff97449ed66640), AE_NOT_FOUND (20160831/psparse-543)
[    2.174741] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    2.174924] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT1.SPT2._GTF] (Node ffff97449ed66640), AE_NOT_FOUND (20160831/psparse-543)


I try with "acpidump > acpidump.out" but cannot extract data:
Cannot map /dev/mem
Could not map table header at 0x000000003A9A8090
Could not get ACPI tables, AE_ACCE
Comment 11 Jose Luis Mantilla 2017-02-10 18:01:15 UTC
I wonder what have happened about the issue -- I want to fix this error and the new updated kernel is equal.
Comment 12 Mentat 2017-02-11 21:40:05 UTC
Created attachment 254703 [details]
acpidump

[    0.018737] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[    0.019014] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-227)
[    0.019206] ACPI Exception: AE_NOT_FOUND, (SSDT:xh_rvp08) while loading table (20160831/tbxfload-228)
[    0.025848] ACPI Error: 1 table load failures, 5 successful (20160831/tbxfload-246)
Comment 13 Doug Smythies 2017-02-14 07:36:40 UTC
My test computer is an Ubuntu server, on which this issue only occurs on resume from suspend. Normally this computer is not suspended, which is why I did not notice the issue until now. Kernel 4.8 is good, kernel 4.9-rc1 is bad. I've started a kernel bisection. It'll take a couple of days.
Comment 14 Doug Smythies 2017-02-15 00:56:27 UTC
Created attachment 254759 [details]
Kernel Bisection rsult and log

O.K. so the kernel bisection says the guilty commit is:

commit b5c0875a16039d90f4cdf6b75ae4031daae01d56
Author: Lv Zheng <lv.zheng@intel.com>
Date:   Thu Aug 4 16:42:49 2016 +0800

ACPICA: Utilities: Introduce facility to allow Linux to set correct logging levels

So it seems, at least for me, that this issue was always there, but just not reported before. If I correctly understand bug 43229, the root issue is actually a BIOS problem.

I further tested on kernel 4.10-rc8, by reverting the above commit:

doug@s15:~/temp-k-git/linux$ git log --oneline
1dc8c4f Revert "ACPICA: Utilities: Introduce facility to allow Linux to set correct logging levels"
7089db8 Linux 4.10-rc8
...

And indeed upon resume from suspend, those messages no longer appeared.
Comment 15 Doug Smythies 2017-02-15 22:30:59 UTC
Addendum:
In my case the errors appear on my console as a result of the above isolated commit. However, they still, and always did, appear in the /var/log/kern.log file.
This may be slightly different than what others on this bug report are experiencing.
Comment 16 Radek Podgorny 2017-02-15 22:33:29 UTC
hmm, i can't really tell. i don't have the old kernels anymore...
Comment 17 Vincent Gerris 2017-02-19 18:10:14 UTC
I see this in dmesg output on my Lenovo Yoga 2 11, BIOS 1.93 (latest) and N3520 processor:

snippet 1:
[    1.811096] [Firmware Bug]: ACPI(PEGP) defines _DOD but not _DOS
[    1.812306] ACPI: Video Device [PEGP] (multi-head: yes  rom: no  post: no)
[    1.812316] ACPI Error: [\_SB_.PCI0.GFX0.DD02._BCL] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    1.812328] ACPI Error: Method parse/execution failed [\_SB.PCI0.RP01.PEGP.DD02._BCL] (Node ffffa0cbfb0e34d8), AE_NOT_FOUND (20160831/psparse-543)
[    1.812643] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:17/LNXVIDEO:00/input/input6
[    1.813856] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)

snippet 2:

[    7.469149] thinkpad_acpi: ThinkPad ACPI Extras v0.25
[    7.469152] thinkpad_acpi: http://ibm-acpi.sf.net/
[    7.469153] thinkpad_acpi: ThinkPad BIOS 92CN93WW(V1.93), EC unknown
[    7.469155] thinkpad_acpi: Lenovo Lenovo Yoga 2 11, model 20332
[    7.473056] ACPI Error: [\_SB_.PCI0.GFX0.DD02._BCL] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[    7.473195] ACPI Error: Method parse/execution failed [\_SB.PCI0.RP01.PEGP.DD02._BCL] (Node ffffa0cbfb0e34d8), AE_NOT_FOUND (20160831/psparse-543)
[    7.473413] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one
[    7.474550] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)

I read somewhere there a changes going on regarding the iasl compiler, but they may be old.
The messages do not seem to impact any functionality, since I did not see them on 4.8, but I do have this issue:
https://bugzilla.kernel.org/show_bug.cgi?id=109051

I guess it is unrelated and I mostly post to share if useful, if anyone thinks it's related I am interested to read how.
Comment 18 Vitaly 2017-02-23 14:40:20 UTC
Bump, I also have it since ~4.9 in fedora 25.

 ~ dmesg | grep -i 'lookup'

[    0.016446] ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_NOT_FOUND (20160831/dswload-210)
[    0.016451] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20160831/psobject-227)

 ~ uname -a
Linux 4.9.10-200.fc25.x86_64 #1 SMP Wed Feb 15 23:28:59 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Comment 19 Aleksandar 2017-02-23 14:54:58 UTC
I can also report the bug, since I've updated to 4.9 debian 9.

dmesg | grep -i 'lookup'
[    0.599214] ACPI Error: [_PPC] Namespace lookup failure, AE_ALREADY_EXISTS (20160831/dswload-378)
[    0.599220] ACPI Exception: AE_ALREADY_EXISTS, During name lookup/catalog (20160831/psobject-227)

uname -a
Linux abukva 4.9.0-1-amd64 #1 SMP Debian 4.9.6-3 (2017-01-28) x86_64 GNU/Linux
Comment 20 Aleksandar 2017-02-23 14:58:12 UTC
Created attachment 254901 [details]
acpidump

Here is my acpidump
Comment 21 Lv Zheng 2017-02-28 01:22:36 UTC
(In reply to Radek Podgorny from comment #5)
> also, i forgot to mention i use this kernel cmdline:
> 
> Command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img
> root=/dev/disk/by-label/PUPIK_ROOT rw ___acpi_osi=

It looks your ssdt6 contains same information as dsdt.

 193531\dsdt.dsl (18 hits)
	Line 41101:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41133:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41165:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41197:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41229:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41261:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41293:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41325:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41357:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41389:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41421:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41453:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41485:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41517:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41549:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41581:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41613:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 41645:         Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
  193531\ssdt6.dsl (20 hits)
	Line 81:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 94:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 107:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 120:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 133:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 146:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 159:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 172:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 185:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 198:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 211:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 224:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 237:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 250:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 263:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 276:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 289:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 302:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port Capabilities
	Line 409:             Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities
	Line 432:             Method (_UPC, 0, Serialized)  // _UPC: USB Port Capabilities

So the error was reported when SSDT6 was loaded.

Looks like a firmware issue to me if you didn't customize your DSDT by combining original one with SSDTs.

Thanks
Lv
Comment 22 Radek Podgorny 2017-02-28 07:49:46 UTC
(In reply to Lv Zheng from comment #21)
> (In reply to Radek Podgorny from comment #5)
> > also, i forgot to mention i use this kernel cmdline:
> > 
> > Command line: initrd=\intel-ucode.img initrd=\initramfs-linux.img
> > root=/dev/disk/by-label/PUPIK_ROOT rw ___acpi_osi=
> 
> It looks your ssdt6 contains same information as dsdt.
> 
>  193531\dsdt.dsl (18 hits)
>       Line 41101:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41133:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41165:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41197:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41229:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41261:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41293:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41325:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41357:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41389:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41421:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41453:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41485:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41517:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41549:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41581:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41613:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 41645:         Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>   193531\ssdt6.dsl (20 hits)
>       Line 81:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 94:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 107:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 120:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 133:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 146:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 159:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 172:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 185:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 198:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 211:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 224:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 237:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 250:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 263:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 276:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 289:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 302:         Method (_UPC, 0, NotSerialized)  // _UPC: USB Port
> Capabilities
>       Line 409:             Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
>       Line 432:             Method (_UPC, 0, Serialized)  // _UPC: USB Port
> Capabilities
> 
> So the error was reported when SSDT6 was loaded.
> 
> Looks like a firmware issue to me if you didn't customize your DSDT by
> combining original one with SSDTs.
> 
> Thanks
> Lv

ok, so if i understand it correctly, the error has always been there but is now being displayed with the 4.9 kernel?
Comment 23 Ivan Jurišić 2017-02-28 07:54:23 UTC
> ok, so if i understand it correctly, the error has always been there but is
> now > being displayed with the 4.9 kernel?

Yes, very annoying :-(
Comment 24 Doug Smythies 2017-02-28 17:53:07 UTC
(In reply to Ivan Jurišić from comment #23)
>> ok, so if i understand it correctly, the error has always been there but is
>> now > being displayed with the 4.9 kernel?
> 
> Yes, very annoying :-(

That is my limited understanding, yes.
And yes, I agree, very annoying.
Comment 25 Jose Luis Mantilla 2017-03-28 02:17:38 UTC
When we will have the fix -- I am so tired about these messages.
Comment 26 Jakub Jankiewicz 2017-04-24 20:45:37 UTC
I'm using Xubuntu 17.04 with kernel 4.10.0 on ASUS GL552VW laptop and I have this from dmesg:

$ dmesg | grep ACPI | grep -E 'Warning|Error'

[   18.315874] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.164551] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.164711] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.164827] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.164909] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.165017] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.165185] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.165269] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[   39.197478] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160930/nsarguments-95)
[ 1177.932199] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1177.932217] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0E] (Node ea0b5378), AE_NOT_FOUND (20160930/psparse-543)
[ 1178.186249] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1178.186266] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0E] (Node ea0b5378), AE_NOT_FOUND (20160930/psparse-543)
[ 1178.356224] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1178.356242] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0E] (Node ea0b5378), AE_NOT_FOUND (20160930/psparse-543)
[ 1178.510269] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1178.510288] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0E] (Node ea0b5378), AE_NOT_FOUND (20160930/psparse-543)
[ 1178.834323] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1178.834342] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0F] (Node ea0b5768), AE_NOT_FOUND (20160930/psparse-543)
[ 1178.988259] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1178.988278] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0F] (Node ea0b5768), AE_NOT_FOUND (20160930/psparse-543)
[ 1179.147706] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1179.147725] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0F] (Node ea0b5768), AE_NOT_FOUND (20160930/psparse-543)
[ 1179.291016] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1179.291034] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0F] (Node ea0b5768), AE_NOT_FOUND (20160930/psparse-543)
[ 1179.466337] ACPI Error: [^^^PEG0.PEGP.PRST] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
[ 1179.466356] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPCB.EC0._Q0F] (Node ea0b5768), AE_NOT_FOUND (20160930/psparse-543)

and when I add kernel option acpi_osi= I've only get warnings the errors are gone.
Comment 27 pick.d 2017-05-02 08:51:30 UTC
ASUSTeK COMPUTER INC.
P8Z77-V LK with latest BIOS update (dated 2014 thought)

The problem exists when using all kernels above 4.9 for sure (including latest 4.9.*, 4.10.* and 4.11.0)

It doesn't actually break anything, or at least I can't notice it, but it's quite annoying.
Comment 28 Lv Zheng 2017-05-04 06:39:20 UTC
Be patient.
ACPICA team now is actively working on this pull request:
https://github.com/acpica/acpica/pull/189/

So the issue shall be solved soon.

Thanks
Lv
Comment 29 Jose Luis Mantilla 2017-06-04 12:09:02 UTC
Hello Mr. Zheng.

I have the same issue since I reported this bug.

Now I have these messages:

-- Logs begin at Mon 2017-02-20 21:07:06 -05, end at Sun 2017-06-04 07:06:49 -05. --
Jun 04 06:54:58 soporte.fedora.local kernel: ACPI Error: Needed type [Reference], found [Integer] ffff9c9e20108a68 (20170119/exresop-103)
Jun 04 06:54:58 soporte.fedora.local kernel: ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/dswe
Jun 04 06:54:58 soporte.fedora.local kernel: ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff9c9e225022d0), AE_AML_OPERAND_TYPE (
Jun 04 06:54:59 soporte.fedora.local kernel: ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000003) is beyond end of object (length 0x0) (20170119/
Jun 04 06:54:59 soporte.fedora.local kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.GFX0._DSM] (Node ffff9c9e224c5168), AE_AML_PACKAGE_L
Jun 04 06:54:59 soporte.fedora.local kernel: ACPI Exception: AE_AML_PACKAGE_LIMIT, Index (0x000000003) is beyond end of object (length 0x0) (20170119/
Jun 04 06:54:59 soporte.fedora.local kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.GFX0._DSM] (Node ffff9c9e224c5168), AE_AML_PACKAGE_L
Jun 04 06:54:59 soporte.fedora.local kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.PEG0.PEGP._DSM] (Node ffff9c9e224df9b0), AE_AML_PACK
Jun 04 06:55:01 soporte.fedora.local systemd[1]: systemd-rfkill.socket: Socket service systemd-rfkill.service not loaded, refusing.
Jun 04 06:55:01 soporte.fedora.local systemd[1]: Failed to listen on Load/Save RF Kill Switch Status /dev/rfkill Watch.
Jun 04 06:55:04 soporte.fedora.local systemd[1]: Failed to start SYSV: This service starts and stops VMware services.
Jun 04 06:55:06 soporte.fedora.local gdm-launch-environment][1400]: PAM unable to dlopen(/usr/lib64/security/pam_oddjob_mkhomedir.so): /usr/lib64/secu
Jun 04 06:55:06 soporte.fedora.local gdm-launch-environment][1400]: PAM adding faulty module: /usr/lib64/security/pam_oddjob_mkhomedir.so
Jun 04 06:55:06 soporte.fedora.local systemd[1410]: PAM unable to dlopen(/usr/lib64/security/pam_oddjob_mkhomedir.so): /usr/lib64/security/pam_oddjob_
Jun 04 06:55:06 soporte.fedora.local systemd[1410]: PAM adding faulty module: /usr/lib64/security/pam_oddjob_mkhomedir.so
Jun 04 06:55:08 soporte.fedora.local spice-vdagent[1764]: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
Jun 04 06:55:30 soporte.fedora.local gdm-password][1961]: PAM unable to dlopen(/usr/lib64/security/pam_oddjob_mkhomedir.so): /usr/lib64/security/pam_o
Jun 04 06:55:30 soporte.fedora.local gdm-password][1961]: PAM adding faulty module: /usr/lib64/security/pam_oddjob_mkhomedir.so
Jun 04 06:55:32 soporte.fedora.local systemd[1971]: PAM unable to dlopen(/usr/lib64/security/pam_oddjob_mkhomedir.so): /usr/lib64/security/pam_oddjob_
Jun 04 06:55:32 soporte.fedora.local systemd[1971]: PAM adding faulty module: /usr/lib64/security/pam_oddjob_mkhomedir.so
Jun 04 06:55:33 soporte.fedora.local pkexec[2008]: PAM unable to dlopen(/usr/lib64/security/pam_oddjob_mkhomedir.so): /usr/lib64/security/pam_oddjob_m
Jun 04 06:55:33 soporte.fedora.local pkexec[2008]: PAM adding faulty module: /usr/lib64/security/pam_oddjob_mkhomedir.so
Jun 04 06:55:34 soporte.fedora.local pulseaudio[2113]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Un
Jun 04 06:55:35 soporte.fedora.local spice-vdagent[2215]: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
Jun 04 06:55:35 soporte.fedora.local vmusr[2232]: [Jun 04 06:55:35.481] [   error] [Gdk] The program 'vmware-user' received an X Window System error.
                                                  This probably reflects a bug in the program.
                                                  The error was 'BadWindow (invalid Window parameter)'.
                                                    (Details: serial 137 error_code 3 request_code 20 minor_code 0)
                                                    (Note to programmers: normally, X errors are reported asynchronously;
                                                     that is, you will receive the error a while after causing it.
                                                     To debug your program, run it with the --sync command line
                                                     option to change this behavior. You can then get a meaningful
                                                     backtrace from your debugger if you break on the gdk_x_error() function.)
Jun 04 06:55:35 soporte.fedora.local abrt-hook-ccpp[2286]: Process 2232 (vmtoolsd) of user 1000 killed by SIGABRT - dumping core
Jun 04 07:01:11 soporte.fedora.local gnome-session-binary[2018]: GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
lines 1-36

Could anyone help us really?
Comment 30 Lv Zheng 2017-07-04 01:14:32 UTC
Let me mark this as RESOLVED/MOVED.
Comment 31 Martin Millnert 2017-10-16 08:00:45 UTC
(In reply to Lv Zheng from comment #30)
> Let me mark this as RESOLVED/MOVED.

On what basis did you mark it RESOLVED/MOVED?
I notice that the PR hasn't been merged yet: https://github.com/acpica/acpica/pull/189/

What's the current status of this bug?
Thanks!
Comment 32 zhb888999 2017-12-24 07:20:57 UTC
kail linux
#uname -a
Linux localhost 4.14.8 #4 SMP Sat Dec 23 14:33:47 CST 2017 x86_64 GNU/Linux
#dmesg | grep pcspkr
Error: Driver 'pcspkr' is already registered, aborting...
#dmesg | grep ACPI | grep -E 'Warning|Error'
[    0.036580] ACPI Error: [GPLD] Namespace lookup failure, AE_ALREADY_EXISTS (20170728/dswload-378)
[    0.037969] ACPI Error: 1 table load failures, 12 successful (20170728/tbxfload-246)
[    4.157907] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20170728/psargs-364)
[    4.157981] ACPI Error: Method parse/execution failed \_SB.PCI0.SAT0.PRT2._GTF, AE_NOT_FOUND (20170728/psparse-550)
[    4.160396] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20170728/psargs-364)
[    4.160469] ACPI Error: Method parse/execution failed \_SB.PCI0.SAT0.PRT2._GTF, AE_NOT_FOUND (20170728/psparse-550)
[   11.601550] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20170728/dsopcode-235)
[   11.601642] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.601718] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.601874] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20170728/dsopcode-235)
[   11.601954] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.602025] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.602173] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20170728/dsopcode-235)
[   11.602253] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.602324] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.602699] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20170728/dsopcode-235)
[   11.602783] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.602854] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.603001] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20170728/dsopcode-235)
[   11.603081] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
[   11.603151] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20170728/psparse-550)
Comment 33 thierryb 2018-11-10 00:15:17 UTC
Hi,

it is funny that after running kernel 4.9 for a long time and an "old" BIOS on my motherboard for years , I get these error message only now, just after updating the bios to the last version ...


Nov  9 13:05:09 thierrybo-desk kernel: [    0.994303] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.994701] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.994943] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT5._GTF] (Node ffffa08f921d24d8), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.995317] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.995548] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT4._GTF] (Node ffffa08f921d2668), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.995840] ata5.00: ATAPI: TSSTcorp CDDVDW SH-222AB, SB01, max UDMA/100
Nov  9 13:05:09 thierrybo-desk kernel: [    0.995887] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.996119] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffffa08f921d2000), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.996410] ata1.00: supports DRM functions and may not be fully accessible
Nov  9 13:05:09 thierrybo-desk kernel: [    0.996457] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.996687] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT2._GTF] (Node ffffa08f921d20a0), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997005] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997256] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT1._GTF] (Node ffffa08f921d22d0), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997548] ata1.00: ATA-10: CT500MX500SSD1, M3CR010, max UDMA/133
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997551] ata1.00: 976773168 sectors, multi 1: LBA48 NCQ (depth 31/32), AA
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997563] ata6.00: ATA-8: ST750LX003-1AC154, SM12, max UDMA/133
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997565] ata6.00: 1465149168 sectors, multi 16: LBA48 NCQ (depth 31/32)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997712] ata3.00: ATA-8: WDC WD5001AALS-00L3B2, 01.03B01, max UDMA/133
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997715] ata3.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997793] ata2.00: ATA-8: ST500DM002-1BD142, KC45, max UDMA/133
Nov  9 13:05:09 thierrybo-desk kernel: [    0.997796] ata2.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.998013] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.998249] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffffa08f921d2000), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.998561] ata1.00: supports DRM functions and may not be fully accessible
Nov  9 13:05:09 thierrybo-desk kernel: [    0.998614] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.998861] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT4._GTF] (Node ffffa08f921d2668), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.999169] ata5.00: configured for UDMA/100
Nov  9 13:05:09 thierrybo-desk kernel: [    0.999216] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.999480] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT5._GTF] (Node ffffa08f921d24d8), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    0.999813] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    1.000054] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT2._GTF] (Node ffffa08f921d20a0), AE_NOT_FOUND (20160831/psparse-543)
Nov  9 13:05:09 thierrybo-desk kernel: [    1.000400] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
Nov  9 13:05:09 thierrybo-desk kernel: [    1.000660] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT1._GTF] (Node ffffa08f921d22d0), AE_NOT_FOUND (20160831/psparse-543)

Note You need to log in before you can comment on or make changes to this bug.