Bug 19342 - ACPI video backlight control doesn't work -- need backlight manager
ACPI video backlight control doesn't work -- need backlight manager
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: Zhang Rui
:
: 14216 15513 15528 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 05:29 UTC by Zhang Rui
Modified: 2011-07-30 06:47 UTC (History)
7 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Zhang Rui 2010-09-30 05:29:45 UTC
the ACPI video backlight control doesn't work on some machines. i.e. the backlight control method is evaluated properly but the backlight is not actually changed.
For these machines, we need to control the backlight via other ways, like, platform driver, PCI legacy register, graphics native register, etc.
So I'm planning to re-write the backlight sysfs class device to a backlight manager. More than one backlight driver can register to this backlight manager, and provide different callbacks to change the backlight.
And we can switch to other drivers if ACPI video driver doesn't work.
Even more, we can setup a blacklist for the laptops that known broken.

In a word, this bug report is a gathering of all the bugs that ACPI backlight control is broken and we don't/can't fix in Linux/kernel.
Comment 1 Zhang Rui 2010-09-30 05:30:11 UTC
*** Bug 15513 has been marked as a duplicate of this bug. ***
Comment 2 Zhang Rui 2010-09-30 05:30:44 UTC
*** Bug 14216 has been marked as a duplicate of this bug. ***
Comment 3 Jonathan 2010-10-18 23:50:53 UTC
Have you looked at these patches?

https://patchwork.kernel.org/patch/163961/
https://patchwork.kernel.org/patch/163971/
Comment 4 Zhang Rui 2010-10-19 00:19:05 UTC
No, I only saw the first patch before.
This is exactly what I want to do, and thanks for pointing it out. Jonathan,:)

Matthew,
what's the status of these patches?
Comment 5 Sachin Garg 2010-10-19 02:08:00 UTC
Hello,

I am the reporter for the Bug:15513. I can confirm controlling the brightness work with PPA kernel

https://launchpad.net/~kamalmostafa/+archive/linux-kamal-mjgbacklight

But I need supply acpi_backlight=vendor

Thhanks,
Sachin.
Comment 6 Zhang Rui 2010-11-03 06:02:38 UTC
*** Bug 15528 has been marked as a duplicate of this bug. ***
Comment 7 Zhang Rui 2010-12-27 01:51:59 UTC
workaround is available here:
http://marc.info/?l=linux-kernel&m=129018220313303&w=2
http://marc.info/?l=linux-kernel&m=129018215513192&w=2

Bug closed.
It would be great if I can add "Tested-by:" before pushing these patches upstream.
Comment 8 Del 2011-07-09 12:30:29 UTC
Did the patches go in? I just had a go with Kubuntu 11.04 and back-light is still non-functional.
Comment 9 Len Brown 2011-07-30 06:47:27 UTC
shipped in 2.6.39

closed


commit bb7ca747f8d6243b3943c5b133048652020f4a50
Author: Matthew Garrett <mjg@redhat.com>
Date:   Tue Mar 22 16:30:21 2011 -0700

    backlight: add backlight type
    
    There may be multiple ways of controlling the backlight on a given
    machine.  Allow drivers to expose the type of interface they are
    providing, making it possible for userspace to make appropriate policy
    decisions.
    
    Signed-off-by: Matthew Garrett <mjg@redhat.com>
    Cc: Richard Purdie <rpurdie@rpsys.net>
    Cc: Chris Wilson <chris@chris-wilson.co.uk>
    Cc: David Airlie <airlied@linux.ie>
    Cc: Alex Deucher <alexdeucher@gmail.com>
    Cc: Ben Skeggs <bskeggs@redhat.com>
    Cc: Zhang Rui <rui.zhang@intel.com>
    Cc: Len Brown <lenb@kernel.org>
    Cc: Jesse Barnes <jbarnes@virtuousgeek.org>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

Note You need to log in before you can comment on or make changes to this bug.