Bug 191801 - Kernels from 4.9-rc1 through 4.10-rc2 fail to boot
Summary: Kernels from 4.9-rc1 through 4.10-rc2 fail to boot
Status: RESOLVED DUPLICATE of bug 191121
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: Intel Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-03 02:14 UTC by Gene
Modified: 2017-01-11 04:43 UTC (History)
4 users (show)

See Also:
Kernel Version: 4.9 and 4.10
Tree: Mainline
Regression: Yes


Attachments
ver_linux (2.14 KB, text/plain)
2017-01-03 02:15 UTC, Gene
Details
/proc/cpuinfo (1.00 KB, text/plain)
2017-01-03 02:15 UTC, Gene
Details
lspci -vvv (34.26 KB, text/plain)
2017-01-03 02:16 UTC, Gene
Details
/proc/modules (7.26 KB, text/plain)
2017-01-03 02:16 UTC, Gene
Details
/proc/scsi/scsi (495 bytes, text/plain)
2017-01-03 02:22 UTC, Gene
Details

Description Gene 2017-01-03 02:14:40 UTC
have one laptop on which Kernels from 4.9-rc1 through 4.9 and 4.10-rc2 all fail to boot. 

        4.8.15 and all previous kernels have worked fine. 4.9-rc1 is first kernel which will not bo
ot. 

        Refind prints the kernel boot command and then nothing happens at all. No output.
 
        I am booting using refind on a lenovo W540 laptop:

        Files attached: 
                + ver_linux.out = output of ver_linux
                + cpuinfo.out   = /proc/cpuinfo
                + lspci.out     = lspci -vvv
                + modules.out   = /proc/modules
                + scsi.out      = /proc/scsi/scsi 

        These machines all boot 4.9 no problem:

Lenovo Laptop W540 i7-4700 MQ           - Boot Failed
Lenovo Laptop W520 i7-2720QM            - OK
Desktop I7-4770                         - OK
Desktop i7-4790                         - OK
Desktop i7-4771                         - OK
Desktop Core i7 Lynnfield (860)         - OK
Desktop i7-4770K                        - OK
Desktop Intel NUC Skylake i5-6260U      - OK
Comment 1 Gene 2017-01-03 02:15:21 UTC
Created attachment 249751 [details]
ver_linux
Comment 2 Gene 2017-01-03 02:15:49 UTC
Created attachment 249771 [details]
/proc/cpuinfo
Comment 3 Gene 2017-01-03 02:16:13 UTC
Created attachment 249781 [details]
lspci -vvv
Comment 4 Gene 2017-01-03 02:16:37 UTC
Created attachment 249791 [details]
/proc/modules
Comment 5 Gene 2017-01-03 02:22:29 UTC
Created attachment 249801 [details]
/proc/scsi/scsi

Root
Comment 6 Gene 2017-01-03 13:28:41 UTC
is this a duplicate of https://bugzilla.kernel.org/show_bug.cgi?id=191121
Comment 7 Mike Cloaked 2017-01-04 20:56:38 UTC
Is it worth adding a boot parameter to the kernel line during boot to get early printk by adding: "earlyprintk=efi,keep" and then posting the result even if taking a photo of the screen if the system has hung at that point?
Comment 8 Borislav Petkov 2017-01-10 13:51:09 UTC
Can you try and bisect it?

https://wiki.gentoo.org/wiki/Kernel_git-bisect
Comment 9 Gene 2017-01-11 04:34:00 UTC
This is indeed a duplicate of 
https://bugzilla.kernel.org/show_bug.cgi?id=191121

Furthermore as in that bug this patch fixes the problem:

http://git.kernel.org/cgit/linux/kernel/git/efi/efi.git/diff/?h=next&id=b2a91a35445229d596de6697a0b8b6596b858021

I applied this and tested 4.10-rc3 and with the patch it boots fine - Without it it does not. I have not yet tried patching 4.9.2 but I am pretty confident it will boot with the efi patch as well.
Comment 10 Gene 2017-01-11 04:43:54 UTC

*** This bug has been marked as a duplicate of bug 191121 ***

Note You need to log in before you can comment on or make changes to this bug.