Bug 19142 - Screen flickers when switching from the console to X
Screen flickers when switching from the console to X
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-09-27 12:05 UTC by Andrey Rahmatullin
Modified: 2010-12-16 23:52 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.36-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Andrey Rahmatullin 2010-09-27 12:05:02 UTC
This is Ironlake i3-530 with latest Linux tree (32163f4b2cef28a5aab8b226ffecfc6379a53786). It was just the same on earlier .36 though. When I switch from X to the console there is no flicker, as with other kernels. But when I switch back, the X image shows for a moment, then instantly disappears and reappears after about 1 second. Then after several (10 or less) seconds the screen blackens and restores one more time.
I can bisect this if needed.
Comment 1 Andrew Morton 2010-09-27 19:46:51 UTC
From which kernel version did we regress?  Was 2.6.25 OK?

Thanks.
Comment 2 Andrey Rahmatullin 2010-09-30 07:12:33 UTC
.35 is OK. Even bc584c5107bfd97e2aa41c798e3b213bcdd4eae7 is OK. The main part of the problem appears after merging of anholt/drm-intel (4fefe435626758b14e6c05d2a5f8d71a997c0ad6) at 4238a417a91643e1162a98770288f630e37f0484: the screen flickers when switching to the X, but the second flicker doesn't happen. I think the second flicker starts to appear between rc4 and rc5, but I may remember wrong.
I couldn't bisect that anholt/drm-intel branch because apparently all its commits from 3e33d94df7f5c94adb09139b5d816a248d703a36 to 4fefe435626758b14e6c05d2a5f8d71a997c0ad6 hang on boot here.
Comment 3 Chris Wilson 2010-12-16 14:36:29 UTC
From the description the flicker is related to hotplug polling, and I think is the one meant to be addressed by this patch:

commit e7dbb2f2f8ac843ab5e4d6a8e9a71d16089d324b
Author: Keith Packard <keithp@keithp.com>
Date:   Tue Nov 16 16:03:53 2010 +0800

    drm/i915: Take advantage of auto-polling CRT hotplug detection on PCH hardware
    
    Both IBX and CPT have an automatic hotplug detection mode which appears to work reliably enough that we can dispense with the manual force hotplug trigger stuff. This means that hotplug detection is as simple as reading the current hotplug register values.
    
    The first time the hotplug detection is activated, the code synchronously waits for a hotplug sequence in case the hardware hasn't bothered to do a detection cycle since being initialized.
    
    Signed-off-by: Keith Packard <keithp@keithp.com>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 4 Andrey Rahmatullin 2010-12-16 18:23:21 UTC
I've finally tested this again on newer setup. The bug is reproducible on 2.6.36 but not on 2.6.37-rc6. Feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.