Bug 19112 - 2.6.32.20 and 2.6.35.4 regression: Acer notebook does not power off but shutdown only
2.6.32.20 and 2.6.35.4 regression: Acer notebook does not power off but shutd...
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Off
x86-64 Linux
: P1 blocking
Assigned To: acpi_power-off
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-09-26 10:41 UTC by Alex
Modified: 2010-10-25 13:00 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.35.x and I think >= 2.6.32.21
Tree: Mainline
Regression: Yes


Attachments
system log (56.84 KB, text/plain)
2010-09-26 10:41 UTC, Alex
Details

Description Alex 2010-09-26 10:41:36 UTC
Created attachment 31532 [details]
system log

Ubuntu waits any key press from me to power off notebook completely. I think shutdown is ok because hard disks powers off( only motherboard cooler is working).Notebook is Acer Aspire 7520G. Earlier it worked ok with the same configuration. All generic Ubuntu kernels are ok, preempt kernels are wrong beginning from 2.6.32-23. I tried 2.6.35.4 and .5 kernels and they are both wrong for me. I have also Winxp x64 installed and it is ok. There are no any wrong message in system log. ACPI is working ok. The system hangs and waits the key press after halt -f -p -i -d command started.
Comment 1 Alex 2010-09-26 11:01:16 UTC
forgot to say - arch is amd64.
Comment 2 Rafael J. Wysocki 2010-09-27 21:14:19 UTC
Is the Ubuntu's 2.6.32-23 a counterpart of 2.6.32.23 from kernel.org?
Comment 3 Alex 2010-09-28 04:56:28 UTC
No, Ubuntu's 2.6.32-23 based on 2.6.32.21.
Comment 4 Len Brown 2010-09-29 04:00:06 UTC
what is the latest upstream kernel that works?
Comment 5 Alex 2010-09-29 04:48:56 UTC
2.6.32.20 worked ok. May be (no idea) 2.6.35.1 is ok too. I tested 2.6.35 kernels started from 2.6.35.4.
Comment 6 Len Brown 2010-09-30 02:05:32 UTC
can you isolate which kernel between 2.6.32.20 and 2.6.35.4 causes the problem?
Comment 7 Alex 2010-09-30 15:52:33 UTC
2.6.32.21 causes the problem for me. But the basic question is: why does it wait the key pressing from me at all? Does kernel code contain something like getch()?
Please say me where is this code and I will isolate this part for me.
Comment 8 Len Brown 2010-10-19 02:12:24 UTC
2.6.32.20 works and 2.6.32.21 fails?
Okay, that is great, can you bisect which patch between those
stable releases introduced the problem?

The only one that jumps out at me is
82c09de9159a15a8892bc0d732383febd6220ab6
"x86, apic: ack all pending irqs when crashed/on kexec"
so you could start by reverting that patch to see
if it caused it -- maybe we'll get lucky:-)

No, the kernel is not doing a getch(), but it is likely that there is
an issue with a timer not working and so that the interrupts of the
keyboard are causing the system to wake up and continue working...
Comment 9 Alex 2010-10-19 05:28:23 UTC
Yes, I have found it powers off ok if hpet=disabled. So I'm forced to agree: it is timer problem. Also I have found that hpet problems is fixed (may be is not fixed but disguised) with 2.6.36-rc8. It is because the kernels from 2.6.32 to 2.6.35 have the problems with kde4 games. Any games (where timer is used) work in discontinuous manner (for example: ball twitches during its movement). Also the system powers off ok with 2.6.36-rc8 and hpet enabled. But I have found other strange issues with the kernels >= 2.6.35 (or may be it is xorg 1.9.0 + nvidia problem): mplayer using xv eats more cpu and any mouse movement in menu or toolbar is cause the interruptions of video or sound. I increased the latency of sound card (using setpci) and it seems the interruption of sound is discontinued but video is still slowest. Nvidia driver - 260.19.12.
Comment 10 Alex 2010-10-25 13:00:09 UTC
I think this bug can be closed for now :)

Note You need to log in before you can comment on or make changes to this bug.