Bug 19062 - Dirtiable inode bdi default != sb bdi btrfs
Dirtiable inode bdi default != sb bdi btrfs
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: btrfs
All Linux
: P1 normal
Assigned To: fs_btrfs@kernel-bugs.osdl.org
:
: 19082 19362 (view as bug list)
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-09-26 06:26 UTC by Maciej Rutecki
Modified: 2010-10-08 19:14 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.36-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-09-26 06:26:39 UTC
Subject    : Dirtiable inode bdi default != sb bdi btrfs
Submitter  : Cesar Eduardo Barros <cesarb@cesarb.net>
Date       : 2010-09-23 0:54
Message-ID : 4C9AA546.6050201@cesarb.net
References : http://marc.info/?l=linux-kernel&m=128520328929595&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Cesar Eduardo Barros 2010-09-26 22:36:02 UTC
Still happening as of v2.6.36-rc5-149-g56162ba.
Comment 2 Rafael J. Wysocki 2010-09-27 19:24:12 UTC
*** Bug 19082 has been marked as a duplicate of this bug. ***
Comment 3 Chris Mason 2010-09-27 22:18:35 UTC
Christoph and I talked this bug over last night.  Btrfs cannot do the simple/naive fix and always set the bdi on all my inodes, because it will cause problems on some special inodes (block devices, char devices).

But the mark_inode_dirty call is going to complain for every inode.  He is going to work up an alternative patch.
Comment 4 Rafael J. Wysocki 2010-10-02 21:56:30 UTC
On Saturday, October 02, 2010, Ted Ts'o wrote:
> On Sun, Sep 26, 2010 at 10:04:15PM +0200, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > from 2.6.35.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=19062
> > Subject		: Dirtiable inode bdi default != sb bdi btrfs
> > Submitter	: Cesar Eduardo Barros <cesarb@cesarb.net>
> > Date		: 2010-09-23 0:54 (4 days old)
> > Message-ID	: <4C9AA546.6050201@cesarb.net>
> 
> Note: I'm seeing this warning (Dirtiable inode bdi default != sb bdi)
> when I moved from 2.6.36-rc3 to 2.6.36-rc6, using ext4 as a root
> partition, and running mke2fs and e2fsck on ext2, ext3, and ext4 file
> systems.  So I'm seeing this as a known regression from rc3 to rc6.
> Maybe it's different bug with ext4, but in any case, it's highly
> annoying.
Comment 5 Julian Andres Klode 2010-10-06 07:43:49 UTC
That seems to be a generic issue, I can reproduce it on ext4 and ecryptfs, for example:


[  234.977029] ------------[ cut here ]------------
[  234.977041] WARNING: at fs/fs-writeback.c:87 inode_to_bdi+0x55/0x5e()
[  234.977044] Hardware name: 03017VG
[  234.977046] Dirtiable inode bdi default != sb bdi ecryptfs
[  234.977048] Modules linked in: vboxnetadp vboxnetflt vboxdrv
[  234.977055] Pid: 2034, comm: chromium-browse Tainted: G        W   2.6.36-rc6+ #2
[  234.977057] Call Trace:
[  234.977065]  [<ffffffff810648b4>] ? warn_slowpath_common+0x78/0x8c
[  234.977069]  [<ffffffff81064967>] ? warn_slowpath_fmt+0x45/0x4a
[  234.977072]  [<ffffffff81121941>] ? inode_to_bdi+0x55/0x5e
[  234.977076]  [<ffffffff81122b46>] ? __mark_inode_dirty+0xc0/0x185
[  234.977081]  [<ffffffff81118cb8>] ? file_update_time+0xf6/0x121
[  234.977087]  [<ffffffff810cc097>] ? __generic_file_aio_write+0x164/0x280
[  234.977092]  [<ffffffff81057338>] ? __wake_up+0x35/0x46
[  234.977097]  [<ffffffff810fe4f6>] ? virt_to_head_page+0x9/0x2c
[  234.977101]  [<ffffffff810cc208>] ? generic_file_aio_write+0x55/0x9f
[  234.977105]  [<ffffffff81107c10>] ? do_sync_write+0xb1/0xea
[  234.977108]  [<ffffffff81108124>] ? vfs_write+0xa4/0x100
[  234.977111]  [<ffffffff81108233>] ? sys_write+0x45/0x6b
[  234.977117]  [<ffffffff8102aa02>] ? system_call_fastpath+0x16/0x1b
[  234.977119] ---[ end trace 4c0d64d4c1e7929f ]---

I don't know the exact way of handling this, but if multiple filesystems are affected, this bug should be cloned or reassigned to something more general, shouldn't it?
Comment 6 Thomas Renninger 2010-10-08 12:44:12 UTC
*** Bug 19362 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Renninger 2010-10-08 12:45:19 UTC
Bug #19362 shows the same warning, but it's ext4!
Comment 8 Julian Andres Klode 2010-10-08 12:56:52 UTC
The warning has been removed in commit aaead25b954879e1a708ff2f3602f494c18d20b5

Note You need to log in before you can comment on or make changes to this bug.