Bug 190281 - iwlwifi: 6235 Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms - WIFILNX-541
Summary: iwlwifi: 6235 Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms - WIF...
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 low
Assignee: DO NOT USE - assign "network-wireless-intel" component instead
URL:
Keywords:
: 192091 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-13 19:13 UTC by Cristian Aravena Romero
Modified: 2019-02-02 10:05 UTC (History)
6 users (show)

See Also:
Kernel Version: 4.9.0-040900-generic
Tree: Mainline
Regression: No


Attachments
dmesg_4.9.0-040900-generic (67.14 KB, text/plain)
2016-12-13 19:13 UTC, Cristian Aravena Romero
Details
lspci -vvnn (9.58 KB, text/plain)
2016-12-13 19:15 UTC, Cristian Aravena Romero
Details

Description Cristian Aravena Romero 2016-12-13 19:13:12 UTC
Created attachment 247581 [details]
dmesg_4.9.0-040900-generic

dmesg:

[ 2679.143729] iwlwifi 0000:01:00.0: Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms.
[ 2679.143738] iwlwifi 0000:01:00.0: Current CMD queue read_ptr 38 write_ptr 39
[ 2679.143769] iwlwifi 0000:01:00.0: Loaded firmware version: 18.168.6.1
[ 2679.143834] iwlwifi 0000:01:00.0: Microcode SW error detected.  Restarting 0x2000000.
[ 2679.143841] iwlwifi 0000:01:00.0: CSR values:
[ 2679.143844] iwlwifi 0000:01:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
[ 2679.143854] iwlwifi 0000:01:00.0:        CSR_HW_IF_CONFIG_REG: 0X00484b00
[ 2679.143863] iwlwifi 0000:01:00.0:          CSR_INT_COALESCING: 0X00000040
[ 2679.143869] iwlwifi 0000:01:00.0:                     CSR_INT: 0X00000000
[ 2679.143876] iwlwifi 0000:01:00.0:                CSR_INT_MASK: 0X00000000
[ 2679.143882] iwlwifi 0000:01:00.0:           CSR_FH_INT_STATUS: 0X00000000
[ 2679.143889] iwlwifi 0000:01:00.0:                 CSR_GPIO_IN: 0X00000030
[ 2679.143895] iwlwifi 0000:01:00.0:                   CSR_RESET: 0X00000000
[ 2679.143902] iwlwifi 0000:01:00.0:                CSR_GP_CNTRL: 0X080403cd
[ 2679.143908] iwlwifi 0000:01:00.0:                  CSR_HW_REV: 0X000000b0
[ 2679.143914] iwlwifi 0000:01:00.0:              CSR_EEPROM_REG: 0Xc4140ffd
[ 2679.143921] iwlwifi 0000:01:00.0:               CSR_EEPROM_GP: 0X90000801
[ 2679.143927] iwlwifi 0000:01:00.0:              CSR_OTP_GP_REG: 0X00030001
[ 2679.143934] iwlwifi 0000:01:00.0:                 CSR_GIO_REG: 0X00080044
[ 2679.143940] iwlwifi 0000:01:00.0:            CSR_GP_UCODE_REG: 0X0000198d
[ 2679.143946] iwlwifi 0000:01:00.0:           CSR_GP_DRIVER_REG: 0X00000000
[ 2679.143953] iwlwifi 0000:01:00.0:           CSR_UCODE_DRV_GP1: 0X00000000
[ 2679.143959] iwlwifi 0000:01:00.0:           CSR_UCODE_DRV_GP2: 0X00000000
[ 2679.143962] iwlwifi 0000:01:00.0: Start IWL Error Log Dump:
[ 2679.143966] iwlwifi 0000:01:00.0:                 CSR_LED_REG: 0X00000040
[ 2679.143967] iwlwifi 0000:01:00.0: Status: 0x000003CC, count: 6
[ 2679.143971] iwlwifi 0000:01:00.0: 0x00000084 | NMI_INTERRUPT_UNKNOWN       
[ 2679.143973] iwlwifi 0000:01:00.0: 0x00010564 | uPc
[ 2679.143975] iwlwifi 0000:01:00.0: 0x0001054E | branchlink1
[ 2679.143978] iwlwifi 0000:01:00.0: 0x00010580 | branchlink2
[ 2679.143980] iwlwifi 0000:01:00.0: 0x0000DBEA | interruptlink1
[ 2679.143982] iwlwifi 0000:01:00.0: 0x0000DBEA | interruptlink2
[ 2679.143984] iwlwifi 0000:01:00.0: 0x00000081 | data1
[ 2679.143987] iwlwifi 0000:01:00.0: 0x07030000 | data2
[ 2679.143989] iwlwifi 0000:01:00.0: 0x000260A4 | line
[ 2679.143991] iwlwifi 0000:01:00.0: 0x4200BF3A | beacon time
[ 2679.143993] iwlwifi 0000:01:00.0: 0x019D50C6 | tsf low
[ 2679.143996] iwlwifi 0000:01:00.0: 0x00000000 | tsf hi
[ 2679.143998] iwlwifi 0000:01:00.0: 0x00000000 | time gp1
[ 2679.144000] iwlwifi 0000:01:00.0: 0x01A82FEA | time gp2
[ 2679.144002] iwlwifi 0000:01:00.0: 0x00000000 | time gp3
[ 2679.144004] iwlwifi 0000:01:00.0: 0x754312A8 | uCode version
[ 2679.144007] iwlwifi 0000:01:00.0: 0x000000B0 | hw version
[ 2679.144009] iwlwifi 0000:01:00.0: 0x00484B00 | board version
[ 2679.144011] iwlwifi 0000:01:00.0: 0x0000001C | hcmd
[ 2679.144013] iwlwifi 0000:01:00.0: 0x27863040 | isr0
[ 2679.144015] iwlwifi 0000:01:00.0: 0x1181E000 | isr1
[ 2679.144018] iwlwifi 0000:01:00.0: 0x00000E02 | isr2
[ 2679.144020] iwlwifi 0000:01:00.0: 0x0143FC43 | isr3
[ 2679.144022] iwlwifi 0000:01:00.0: 0x00000000 | isr4
[ 2679.144024] iwlwifi 0000:01:00.0: 0x00000000 | isr_pref
[ 2679.144027] iwlwifi 0000:01:00.0: 0x000260A4 | wait_event
[ 2679.144029] iwlwifi 0000:01:00.0: 0x00000080 | l2p_control
[ 2679.144031] iwlwifi 0000:01:00.0: 0x00000000 | l2p_duration
[ 2679.144033] iwlwifi 0000:01:00.0: 0x0000003F | l2p_mhvalid
[ 2679.144036] iwlwifi 0000:01:00.0: 0x00200200 | l2p_addr_match
[ 2679.144038] iwlwifi 0000:01:00.0: 0x00000005 | lmpm_pmg_sel
[ 2679.144040] iwlwifi 0000:01:00.0: 0x13011136 | timestamp
[ 2679.144043] iwlwifi 0000:01:00.0: 0x00002030 | flow_handler
[ 2679.144052] iwlwifi 0000:01:00.0:        CSR_DRAM_INT_TBL_REG: 0X8830f713
[ 2679.144059] iwlwifi 0000:01:00.0:        CSR_GIO_CHICKEN_BITS: 0X27800200
[ 2679.144065] iwlwifi 0000:01:00.0:             CSR_ANA_PLL_CFG: 0X00000000
[ 2679.144071] iwlwifi 0000:01:00.0:      CSR_MONITOR_STATUS_REG: 0X43f7ff57
[ 2679.144077] iwlwifi 0000:01:00.0:           CSR_HW_REV_WA_REG: 0X0001001a
[ 2679.144083] iwlwifi 0000:01:00.0:        CSR_DBG_HPET_MEM_REG: 0Xffff0000
[ 2679.144086] iwlwifi 0000:01:00.0: FH register values:
[ 2679.144105] iwlwifi 0000:01:00.0:         FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X30a98700
[ 2679.144134] iwlwifi 0000:01:00.0:        FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X030a9860
[ 2679.144150] iwlwifi 0000:01:00.0: Start IWL Event Log Dump: display last 1 entries
[ 2679.144165] iwlwifi 0000:01:00.0:                  FH_RSCSR_CHNL0_WPTR: 0X00000020
[ 2679.144185] iwlwifi 0000:01:00.0: EVT_LOGT:0027799526:0x0000010c:0123
[ 2679.144205] iwlwifi 0000:01:00.0: Command REPLY_RXON failed: FW Error
[ 2679.144207] iwlwifi 0000:01:00.0:         FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X00801114
[ 2679.144214] iwlwifi 0000:01:00.0: Error clearing ASSOC_MSK on BSS (-5)
[ 2679.144225] iwlwifi 0000:01:00.0:          FH_MEM_RSSR_SHARED_CTRL_REG: 0X000000fc
[ 2679.144258] iwlwifi 0000:01:00.0:            FH_MEM_RSSR_RX_STATUS_REG: 0X07030000
[ 2679.144294] iwlwifi 0000:01:00.0:    FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000
[ 2679.144331] iwlwifi 0000:01:00.0:                FH_TSSR_TX_STATUS_REG: 0X07ff0001
[ 2679.144359] iwlwifi 0000:01:00.0:                 FH_TSSR_TX_ERROR_REG: 0X00000000
Comment 1 Cristian Aravena Romero 2016-12-13 19:15:47 UTC
Created attachment 247601 [details]
lspci -vvnn
Comment 2 Luca Coelho 2017-01-07 09:26:37 UTC
Thanks for your report!

How often does this happen? And does it disrupt your connectivity too much?

This is a very old NIC and, unfortunately, we don't make firmware fixes for it anymore (and this appears to be that the FW got stuck briefly).

We have a mechanism to recover from these errors (the warning you see) and try to continue operating as smoothly as possible.

We'll probably have to close this as won't-fix. :(
Comment 3 Emmanuel Grumbach 2017-01-08 21:15:15 UTC
*** Bug 192091 has been marked as a duplicate of this bug. ***
Comment 4 Piotr 2017-01-08 22:33:54 UTC
As my report has been marked as a duplicate I will have to step in.

It happens randomly, sometimes it just fails to connect right from the boot and will loop until I reboot. Sometimes reboot doesn't help and I have to shutdown.
Other times I'm happily surfing web and wifi just crashes. Then I get endless loop of:

[   46.054609] wlp3s0: aborting authentication with 50:6a:03:69:22:20 by local choice (Reason: 3=DEAUTH_LEAVING)

as you can see in duplicate attachments.

You call 2011 very old ? Wow, I think I need to drop off my T430 to a junkyard.

Anyhow, can recovery be made more reliable ? I'm not a big fan of endless loops.
Comment 5 Fabio Coatti 2017-01-10 08:14:47 UTC
This happens also on HP Folio 9470m, same behaviour.

Looking at my old logs, the first occurrence of this issue happened on a 4.8.10 kernel release.
Comment 6 Emmanuel Grumbach 2017-01-10 08:17:58 UTC
@Fabio, please attach your dmesg output.
We would like to be sure this is indeed the same issue.

Thanks.
Comment 7 Fabio Coatti 2017-01-10 08:24:39 UTC
Sure! here you go:

[dom gen  8 09:54:09 2017] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms.
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Current CMD queue read_ptr 34 write_ptr 35                                                  
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Loaded firmware version: 18.168.6.1                                                         
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Microcode SW error detected.  Restarting 0x2000000.                                         
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: CSR values:                                                                                 
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)                                    
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:        CSR_HW_IF_CONFIG_REG: 0X00484b00                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:          CSR_INT_COALESCING: 0X00000040                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                     CSR_INT: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                CSR_INT_MASK: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:           CSR_FH_INT_STATUS: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                 CSR_GPIO_IN: 0X00000030                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                   CSR_RESET: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                CSR_GP_CNTRL: 0X080403cd                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                  CSR_HW_REV: 0X000000b0                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:              CSR_EEPROM_REG: 0X60b10ffd                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:               CSR_EEPROM_GP: 0X90000801                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:              CSR_OTP_GP_REG: 0X00030001                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                 CSR_GIO_REG: 0X00080042                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:            CSR_GP_UCODE_REG: 0X00000510                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:           CSR_GP_DRIVER_REG: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:           CSR_UCODE_DRV_GP1: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:           CSR_UCODE_DRV_GP2: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                 CSR_LED_REG: 0X00000040                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:        CSR_DRAM_INT_TBL_REG: 0X880fffff                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:        CSR_GIO_CHICKEN_BITS: 0X27800200                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:             CSR_ANA_PLL_CFG: 0X00000000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:      CSR_MONITOR_STATUS_REG: 0X43f7f7d7                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:           CSR_HW_REV_WA_REG: 0X0001001a                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:        CSR_DBG_HPET_MEM_REG: 0Xffff0000                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: FH register values:                                                                         
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Start IWL Error Log Dump:                                                                   
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Status: 0x000003CC, count: 6                                                                
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000084 | NMI_INTERRUPT_UNKNOWN                                                          
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00010564 | uPc                                                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0001054E | branchlink1                                                                    
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00010580 | branchlink2                                                                    
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0000DBEA | interruptlink1                                                                 
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0000DBEA | interruptlink2                                                                 
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000081 | data1                                                                          
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x07030000 | data2                                                                          
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x000260A4 | line                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0D404250 | beacon time                                                                    
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00541DB0 | tsf low                                                                        
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000000 | tsf hi                                                                         
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000000 | time gp1                                                                       
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:         FH_RSCSR_CHNL0_STTS_WPTR_REG: 0X0ffffd00                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x005CBDCC | time gp2                                                                       
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000000 | time gp3                                                                       
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x754312A8 | uCode version                                                                  
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x000000B0 | hw version                                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00484B00 | board version                                                                  
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0000001C | hcmd                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x27863040 | isr0                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0181E000 | isr1                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:        FH_RSCSR_CHNL0_RBDCB_BASE_REG: 0X00ffffe0                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000E02 | isr2                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0143FCC3 | isr3                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000000 | isr4                                                                           
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000110 | isr_pref                                                                       
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x000260A4 | wait_event                                                                     
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000050 | l2p_control                                                                    
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000032 | l2p_duration                                                                   
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                  FH_RSCSR_CHNL0_WPTR: 0X00000010                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x0000003F | l2p_mhvalid                                                                    
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00101040 | l2p_addr_match                                                                 
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00000005 | lmpm_pmg_sel                                                                   
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x13011136 | timestamp                                                                      
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: 0x00001020 | flow_handler                                                                   
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:         FH_MEM_RCSR_CHNL0_CONFIG_REG: 0X00801114                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:          FH_MEM_RSSR_SHARED_CTRL_REG: 0X000000fc                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:            FH_MEM_RSSR_RX_STATUS_REG: 0X07030000                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:    FH_MEM_RSSR_RX_ENABLE_ERR_IRQ2DRV: 0X00000000                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Start IWL Event Log Dump: display last 1 entries                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                FH_TSSR_TX_STATUS_REG: 0X07ff0001                                            
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: EVT_LOGT:0006077896:0x0000010c:0123                                                         
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Command REPLY_RXON failed: FW Error                                                         
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Error clearing ASSOC_MSK on BSS (-5)                                                        
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0:                 FH_TSSR_TX_ERROR_REG: 0X00000000                                            
[dom gen  8 09:54:15 2017] ieee80211 phy0: Hardware restart was requested
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[dom gen  8 09:54:15 2017] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
[dom gen  8 09:54:15 2017] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[dom gen  8 09:54:20 2017] iwlwifi 0000:03:00.0: Failed to load firmware chunk!
[dom gen  8 09:54:20 2017] iwlwifi 0000:03:00.0: Could not load the [0] uCode section                                                        
[dom gen  8 09:54:20 2017] iwlwifi 0000:03:00.0: Failed to run INIT ucode: -110                                                              
[dom gen  8 09:54:20 2017] iwlwifi 0000:03:00.0: Unable to initialize device.                                                                
[dom gen  8 09:54:20 2017] ------------[ cut here ]------------
[dom gen  8 09:54:20 2017] WARNING: CPU: 3 PID: 2150 at net/mac80211/util.c:1863 ieee80211_reconfig+0x231/0xc30
[dom gen  8 09:54:20 2017] Hardware became unavailable during restart.
[dom gen  8 09:54:20 2017] Modules linked in: bnep joydev hp_wmi sparse_keymap uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 cdc_wdm cdc_acm snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_device videodev btusb videobuf2_core btintel bluetooth uas algif_skcipher snd_hda_codec_hdmi snd_hda_codec_generic intel_rapl x86_pkg_temp_thermal intel_powerclamp snd_hda_intel coretemp snd_hda_codec snd_hwdep kvm_intel snd_hda_core kvm snd_pcm snd_timer irqbypass snd crct10dif_pclmul crc32_pclmul iwldvm soundcore psmouse mei_me iwlwifi mei wmi hp_accel lis3lv02d hp_wireless sch_fq_codel vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) dm_zero dm_thin_pool dm_persistent_data dm_bio_prison dm_service_time dm_round_robin dm_queue_length dm_multipath dm_delay virtio_pci virtio_blk virtio_balloon vxlan ip6_udp_tunnel
[dom gen  8 09:54:20 2017]  udp_tunnel macvlan virtio_net virtio_ring virtio fuse overlay linear raid0 dm_raid dm_snapshot dm_bufio dm_mirror dm_region_hash dm_log hid_apple ohci_pci ohci_hcd uhci_hcd
[dom gen  8 09:54:20 2017] CPU: 3 PID: 2150 Comm: kworker/3:3 Tainted: G           OE   4.9.1-cova #1
[dom gen  8 09:54:20 2017] Hardware name: Hewlett-Packard HP EliteBook Folio 9470m/18DF, BIOS 68IBD Ver. F.63 04/26/2016
[dom gen  8 09:54:20 2017] Workqueue: events_freezable ieee80211_restart_work
[dom gen  8 09:54:20 2017]  0000000000000000 ffffffff8f4cda3d ffffa4904022bd38 0000000000000000
[dom gen  8 09:54:20 2017]  ffffffff8f0d2f64 ffff8bb4b0508700 ffffa4904022bd90 ffff8bb4b05093f0
[dom gen  8 09:54:20 2017]  ffff8bb4b0508700 0000000000000000 0000000000000000 ffffffff8f0d2fda
[dom gen  8 09:54:20 2017] Call Trace:
[dom gen  8 09:54:20 2017]  [<ffffffff8f4cda3d>] ? dump_stack+0x46/0x59
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d2f64>] ? __warn+0xb4/0xd0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d2fda>] ? warn_slowpath_fmt+0x5a/0x80
[dom gen  8 09:54:20 2017]  [<ffffffff8fa03371>] ? ieee80211_reconfig+0x231/0xc30
[dom gen  8 09:54:20 2017]  [<ffffffff8f1250ef>] ? try_to_del_timer_sync+0x4f/0x80
[dom gen  8 09:54:20 2017]  [<ffffffff8f9d3ac8>] ? ieee80211_restart_work+0x88/0xc0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e8e2f>] ? process_one_work+0x11f/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90f2>] ? worker_thread+0x42/0x4c0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90b0>] ? process_one_work+0x3a0/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90b0>] ? process_one_work+0x3a0/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d6cbe>] ? do_group_exit+0x2e/0xa0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0ee3d9>] ? kthread+0xc9/0xe0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0ee310>] ? kthread_park+0x50/0x50
[dom gen  8 09:54:20 2017]  [<ffffffff8fa20f42>] ? ret_from_fork+0x22/0x30
[dom gen  8 09:54:20 2017] ---[ end trace 06caf73550724986 ]---
[dom gen  8 09:54:20 2017] ------------[ cut here ]------------
[dom gen  8 09:54:20 2017] WARNING: CPU: 3 PID: 2150 at net/mac80211/driver-ops.h:17 ieee80211_do_stop+0x577/0x880
[dom gen  8 09:54:20 2017] wlo1:  Failed check-sdata-in-driver check, flags: 0x0
[dom gen  8 09:54:20 2017] Modules linked in: bnep joydev hp_wmi sparse_keymap uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 cdc_wdm cdc_acm snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_device videodev btusb videobuf2_core btintel bluetooth uas algif_skcipher snd_hda_codec_hdmi snd_hda_codec_generic intel_rapl x86_pkg_temp_thermal intel_powerclamp snd_hda_intel coretemp snd_hda_codec snd_hwdep kvm_intel snd_hda_core kvm snd_pcm snd_timer irqbypass snd crct10dif_pclmul crc32_pclmul iwldvm soundcore psmouse mei_me iwlwifi mei wmi hp_accel lis3lv02d hp_wireless sch_fq_codel vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) dm_zero dm_thin_pool dm_persistent_data dm_bio_prison dm_service_time dm_round_robin dm_queue_length dm_multipath dm_delay virtio_pci virtio_blk virtio_balloon vxlan ip6_udp_tunnel
[dom gen  8 09:54:20 2017]  udp_tunnel macvlan virtio_net virtio_ring virtio fuse overlay linear raid0 dm_raid dm_snapshot dm_bufio dm_mirror dm_region_hash dm_log hid_apple ohci_pci ohci_hcd uhci_hcd
[dom gen  8 09:54:20 2017] CPU: 3 PID: 2150 Comm: kworker/3:3 Tainted: G        W  OE   4.9.1-cova #1
[dom gen  8 09:54:20 2017] Hardware name: Hewlett-Packard HP EliteBook Folio 9470m/18DF, BIOS 68IBD Ver. F.63 04/26/2016
[dom gen  8 09:54:20 2017] Workqueue: events_freezable ieee80211_restart_work
[dom gen  8 09:54:20 2017]  0000000000000000 ffffffff8f4cda3d ffffa4904022bc00 0000000000000000
[dom gen  8 09:54:20 2017]  ffffffff8f0d2f64 ffff8bb4b05308c0 ffffa4904022bc58 0000000000000000
[dom gen  8 09:54:20 2017]  ffff8bb4b0508700 ffff8bb4b0508ee8 ffff8bb4b0531218 ffffffff8f0d2fda
[dom gen  8 09:54:20 2017] Call Trace:
[dom gen  8 09:54:20 2017]  [<ffffffff8f4cda3d>] ? dump_stack+0x46/0x59
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d2f64>] ? __warn+0xb4/0xd0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d2fda>] ? warn_slowpath_fmt+0x5a/0x80
[dom gen  8 09:54:20 2017]  [<ffffffff8f9e8607>] ? ieee80211_do_stop+0x577/0x880
[dom gen  8 09:54:20 2017]  [<ffffffff8f8b0565>] ? dev_deactivate_many+0x1f5/0x230
[dom gen  8 09:54:20 2017]  [<ffffffff8f9e8921>] ? ieee80211_stop+0x11/0x20
[dom gen  8 09:54:20 2017]  [<ffffffff8f8869a2>] ? __dev_close_many+0x82/0xe0
[dom gen  8 09:54:20 2017]  [<ffffffff8f886a88>] ? dev_close_many+0x88/0x130
[dom gen  8 09:54:20 2017]  [<ffffffff8f88b73f>] ? dev_close.part.17+0x3f/0x70
[dom gen  8 09:54:20 2017]  [<ffffffff8f88b77e>] ? dev_close+0xe/0x20
[dom gen  8 09:54:20 2017]  [<ffffffff8f9ad03e>] ? cfg80211_shutdown_all_interfaces+0x3e/0xb0
[dom gen  8 09:54:20 2017]  [<ffffffff8fa031e4>] ? ieee80211_reconfig+0xa4/0xc30
[dom gen  8 09:54:20 2017]  [<ffffffff8f1250ef>] ? try_to_del_timer_sync+0x4f/0x80
[dom gen  8 09:54:20 2017]  [<ffffffff8f9d3ac8>] ? ieee80211_restart_work+0x88/0xc0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e8e2f>] ? process_one_work+0x11f/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90f2>] ? worker_thread+0x42/0x4c0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90b0>] ? process_one_work+0x3a0/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90b0>] ? process_one_work+0x3a0/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d6cbe>] ? do_group_exit+0x2e/0xa0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0ee3d9>] ? kthread+0xc9/0xe0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0ee310>] ? kthread_park+0x50/0x50
[dom gen  8 09:54:20 2017]  [<ffffffff8fa20f42>] ? ret_from_fork+0x22/0x30
[dom gen  8 09:54:20 2017] ---[ end trace 06caf73550724987 ]---
[dom gen  8 09:54:20 2017] ------------[ cut here ]------------
[dom gen  8 09:54:20 2017] WARNING: CPU: 3 PID: 2150 at net/mac80211/driver-ops.c:39 ieee80211_do_stop+0x560/0x880
[dom gen  8 09:54:20 2017] Modules linked in: bnep joydev hp_wmi sparse_keymap uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 cdc_wdm cdc_acm snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_device videodev btusb videobuf2_core btintel bluetooth uas algif_skcipher snd_hda_codec_hdmi snd_hda_codec_generic intel_rapl x86_pkg_temp_thermal intel_powerclamp snd_hda_intel coretemp snd_hda_codec snd_hwdep kvm_intel snd_hda_core kvm snd_pcm snd_timer irqbypass snd crct10dif_pclmul crc32_pclmul iwldvm soundcore psmouse mei_me iwlwifi mei wmi hp_accel lis3lv02d hp_wireless sch_fq_codel vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) dm_zero dm_thin_pool dm_persistent_data dm_bio_prison dm_service_time dm_round_robin dm_queue_length dm_multipath dm_delay virtio_pci virtio_blk virtio_balloon vxlan ip6_udp_tunnel
[dom gen  8 09:54:20 2017]  udp_tunnel macvlan virtio_net virtio_ring virtio fuse overlay linear raid0 dm_raid dm_snapshot dm_bufio dm_mirror dm_region_hash dm_log hid_apple ohci_pci ohci_hcd uhci_hcd
[dom gen  8 09:54:20 2017] CPU: 3 PID: 2150 Comm: kworker/3:3 Tainted: G        W  OE   4.9.1-cova #1
[dom gen  8 09:54:20 2017] Hardware name: Hewlett-Packard HP EliteBook Folio 9470m/18DF, BIOS 68IBD Ver. F.63 04/26/2016
[dom gen  8 09:54:20 2017] Workqueue: events_freezable ieee80211_restart_work
[dom gen  8 09:54:20 2017]  0000000000000000 ffffffff8f4cda3d 0000000000000000 0000000000000000
[dom gen  8 09:54:20 2017]  ffffffff8f0d2f64 ffff8bb4b05308c0 ffff8bb4b0508ff0 0000000000000000
[dom gen  8 09:54:20 2017]  ffff8bb4b0508700 ffff8bb4b0508ee8 ffff8bb4b0531218 ffffffff8f9e85f0
[dom gen  8 09:54:20 2017] Call Trace:
[dom gen  8 09:54:20 2017]  [<ffffffff8f4cda3d>] ? dump_stack+0x46/0x59
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d2f64>] ? __warn+0xb4/0xd0
[dom gen  8 09:54:20 2017]  [<ffffffff8f9e85f0>] ? ieee80211_do_stop+0x560/0x880
[dom gen  8 09:54:20 2017]  [<ffffffff8f8b0565>] ? dev_deactivate_many+0x1f5/0x230
[dom gen  8 09:54:20 2017]  [<ffffffff8f9e8921>] ? ieee80211_stop+0x11/0x20
[dom gen  8 09:54:20 2017]  [<ffffffff8f8869a2>] ? __dev_close_many+0x82/0xe0
[dom gen  8 09:54:20 2017]  [<ffffffff8f886a88>] ? dev_close_many+0x88/0x130
[dom gen  8 09:54:20 2017]  [<ffffffff8f88b73f>] ? dev_close.part.17+0x3f/0x70
[dom gen  8 09:54:20 2017]  [<ffffffff8f88b77e>] ? dev_close+0xe/0x20
[dom gen  8 09:54:20 2017]  [<ffffffff8f9ad03e>] ? cfg80211_shutdown_all_interfaces+0x3e/0xb0
[dom gen  8 09:54:20 2017]  [<ffffffff8fa031e4>] ? ieee80211_reconfig+0xa4/0xc30
[dom gen  8 09:54:20 2017]  [<ffffffff8f1250ef>] ? try_to_del_timer_sync+0x4f/0x80
[dom gen  8 09:54:20 2017]  [<ffffffff8f9d3ac8>] ? ieee80211_restart_work+0x88/0xc0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e8e2f>] ? process_one_work+0x11f/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90f2>] ? worker_thread+0x42/0x4c0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90b0>] ? process_one_work+0x3a0/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0e90b0>] ? process_one_work+0x3a0/0x3a0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0d6cbe>] ? do_group_exit+0x2e/0xa0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0ee3d9>] ? kthread+0xc9/0xe0
[dom gen  8 09:54:20 2017]  [<ffffffff8f0ee310>] ? kthread_park+0x50/0x50
[dom gen  8 09:54:20 2017]  [<ffffffff8fa20f42>] ? ret_from_fork+0x22/0x30
[dom gen  8 09:54:20 2017] ---[ end trace 06caf73550724988 ]---
[dom gen  8 09:54:20 2017] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Comment 8 Emmanuel Grumbach 2017-01-10 08:26:48 UTC
indeed the same issue - thanks!
Comment 9 Fabio Coatti 2017-01-10 08:32:14 UTC
A possibly useful hint for who is hit by this issue: I'm usually able to make the network to work again by removing the modules and inserting them again:
modprobe -r iwldvm iwlwifi
modprobe iwlwifi

HTH
Comment 10 Emmanuel Grumbach 2017-01-10 11:37:06 UTC
I guess you could try to remove only iwldvm. It should do the trick as well.
Comment 11 Luca Coelho 2017-01-15 11:31:51 UTC
Created an internal bug report to track this.  We'll try to reproduce this and see if there's something obvious we can fix.  Though, since this NIC is very old and not really supported anymore, it has low priority.  But we'll do our best. :)
Comment 12 Piotr 2017-01-17 09:32:51 UTC
I'd like to note that when using 2,4 GHz networks it crashes everyday.
With 5GHz I can use it for days, sometimes it spams dmesg on shutdown.
Comment 13 Luca Coelho 2017-01-23 09:03:23 UTC
Unfortunately we won't be able to spend time on this. :(

If someone wants to bisect the problem (AFAICT this is only happening with v4.9), we can try to fix it once the problematic patch is found.

Closing for now.  Feel free to reopen if you find the culprit.
Comment 14 msalle 2017-01-25 11:06:35 UTC
I am seeing the same problem on a OpenSUSE Leap 42.2 installation, which is running a 4.4.36 kernel. As far as I could see none of OpenSUSE's patches is touching the iwlwifi. I'm using a 6230 on a Dell XPS 14z (which is less than 5 years old). It started after I updated from a OpenSUSE 42.1 with a 4.1.36 kernel.
I don't always see stack traces, but the typical lines with
  Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms.
and
  Microcode SW error detected.  Restarting 0x2000000
occur daily. At that point it often helps to restart the access point (ch. 4/2427MHz). Other than that specific AP seem to work fine. Re-loading the iwlwifi and/or iwldvm does not really seem to help...
Comment 15 Johannes 2018-05-30 08:13:39 UTC
I'm using the kernel 4.14 with Arch Linux and Plasma 5.12 on a Thinkpad x230 with an Intel 6205 wifi card. I have the exact same dmesg output as Fabio Coatti.
Comment 16 Jeremy Murphy 2018-11-11 05:40:30 UTC
Oooh, I am getting regularly hit by this bug too, same NIC, currently using 4.18.16.
Seems to mostly happen after resume from suspend, but I could be wrong.
Reloading the iwldvm module fixes it.
It is pretty annoying, so I'm willing to spend a bit of time to help track it down.

I don't do git bisects very often but I should be able to figure it out.

Any other hints on how to proceed?
Thanks, cheers.
Comment 17 Jeremy Murphy 2018-11-11 06:11:58 UTC
Hmmm, yeah, I might need some help here. I did a shallow clone of linux-stable to a depth of ~80, enough to get the v4.8 tag, but there are no tags or branches for 4.8.x. Do I need them?
Or should I just verify that the latest 4.4.x works first?
Comment 18 Jeremy Murphy 2018-12-11 08:42:24 UTC
Curiously, this issue hasn't happened to me for the past week or so, whereas previously it was happening daily or multiple times per day. 
But I haven't changed anything... other than upgrading to 4.18.20.
So I just looked back through the ChangeLogs, and... bingo! I think we got fixed in 4.18.19!

I still see dark red text that begins with:

iwlwifi 0000:5c:00.0: Error sending REPLY_SCAN_ABORT_CMD: time out after 2000ms.

in the kernel log, but it's not followed by the white stacktrace/dump any more.

It appears to have been fixed in response to bug report #200659, but I'm not 100% certain.

Can anyone else verify that 4.18.19 or 4.19.8 fixes the issue for them?
Comment 19 Johannes 2019-02-02 10:05:54 UTC
Can't confirm.
For me it happens also with Kernel 4.19.16. I will try a complete new installation of my system.

Note You need to log in before you can comment on or make changes to this bug.