Bug 190221 - regression from commit 4c63c2454eff996
Summary: regression from commit 4c63c2454eff996
Status: RESOLVED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: btrfs (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Josef Bacik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-13 08:47 UTC by Rolf Leggewie
Modified: 2017-08-31 14:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.9.0
Tree: Mainline
Regression: No


Attachments

Description Rolf Leggewie 2016-12-13 08:47:40 UTC
During triage of https://bugs.launchpad.net/bugs/1619918 it was found out today that apparently commit https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=4c63c2454eff996 introduces a regression when running an amd64 kernel with a system that is otherwise mostly i386.

I opened a ticket on launchpad in September since I was unable to use lsattr when having an amd64 kernel and i386 e2fsprogs.  The proposed and committed fix 4c63c2454eff996 was backported and introduced regressions into the Ubuntu trusty 3.13.0-97 kernel, one of which was confirmed to be present in last week's mainline as well.

With kernel 4.9.0 I can no longer take a btrfs snapshot of my system.  The error message is "Inappropriate ioctl for device", very similar to the original problem with lsattr before 4c63c2454eff996.
Comment 1 Rolf Leggewie 2017-08-31 14:21:07 UTC
I believe this problem was fixed (I have come across a number of other issues, though, when running i386-userland with an amd64-kernel)

Note You need to log in before you can comment on or make changes to this bug.