Bug 1901 - poweroff fails -- T41
poweroff fails -- T41
Status: REJECTED DUPLICATE of bug 3238
Product: ACPI
Classification: Unclassified
Component: Power-Off
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-18 02:15 UTC by Jurjen Oskam
Modified: 2004-11-05 22:28 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.1
Tree: Mainline
Regression: ---


Attachments
Used .config (26.47 KB, text/plain)
2004-01-18 02:16 UTC, Jurjen Oskam
Details
dmesg output of 2.6.1 with ACPI 20031203 (11.02 KB, text/plain)
2004-01-21 11:11 UTC, Jurjen Oskam
Details
acpidmp, dmidecode, interrupts and lspci in a bzip2 (24.66 KB, application/octet-stream)
2004-02-28 15:44 UTC, Georg Müller
Details
dmesg output on IBM T40/p (11.40 KB, text/plain)
2004-08-01 02:46 UTC, Ondrej Sury
Details
dmesg output on T40/p with disabled local apic (nolapic) (10.72 KB, text/plain)
2004-08-01 02:56 UTC, Ondrej Sury
Details
Disable local APIC when powering down. (542 bytes, patch)
2004-09-28 03:14 UTC, Herbert Xu
Details | Diff
Shutdown LAPIC at poweroff (1.80 KB, patch)
2004-10-20 02:29 UTC, Alexey Starikovskiy
Details | Diff

Description Jurjen Oskam 2004-01-18 02:15:40 UTC
Distribution: Slackware 9.1 
Hardware Environment: IBM Thinkpad T41 laptop 
Software Environment: Standard Slackware 9.1 install, security updates 
up-to-date as of 18 jan 2004, with clean 2.6.1 from kernel.org. 
Problem Description: Under 2.4.x with APM, this machine powered down correctly 
when entering shutdown -h now. With 2.6.1 (and ACPI), the same command only 
results in turning off the LCD screen (backlight is turned off), the machine 
stays powered on. I can't really tell how much of the kernel is left running, 
since the laptop isn't connected to any network. Just before the screen is 
turned off, I see the "Power down." message. 
 
Steps to reproduce: Issue "shutdown -h now".
Comment 1 Jurjen Oskam 2004-01-18 02:16:52 UTC
Created attachment 1884 [details]
Used .config
Comment 2 Jurjen Oskam 2004-01-18 02:18:29 UTC
Sorry, forgot to mention that I also reproduced the problem by booting 
with "init=/bin/bash", to minimize the impact of any running programs. 
Comment 3 Len Brown 2004-01-20 22:26:57 UTC
so 2.6.1 poweroff fails on this centrino. 
Any change if you apply the latest ACPI patch: 
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.1/ 
 
or the latest MM patch? 
http://ftp.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.1/ 
 
maybe duplicate of bug #1658 (T40 poweroff, now working with 2.6.0-mm1) 
 
thanks, 
-Len 
 
Comment 4 Jurjen Oskam 2004-01-21 11:08:46 UTC
2.6.1-mm5 panics when running the system startup scripts, so I booted it with 
'init=/bin/bash'. A '/sbin/halt -p' has the same result as stock 2.6.1: LCD 
screen turns off, but the machine stays on. 
 
2.6.1 with latest ACPI patches 20031203 doesn't show any notable difference 
with stock 2.6.1: it works just fine, but won't power off. 
Comment 5 Jurjen Oskam 2004-01-21 11:11:15 UTC
Created attachment 1916 [details]
dmesg output of 2.6.1 with ACPI 20031203
Comment 6 Volker Braun 2004-01-22 15:26:57 UTC
The problem is apparently the APIC stuff. I have that disabled on my T41, and
power off works fine (plain 2.6.1 and 2.6.1+latest acpi)

Comment 7 Jurjen Oskam 2004-01-23 11:45:18 UTC
Thanks! I've tried booting with "nolapic", and with that parameter, the 
machine powers off. (This is with 2.6.1 with ACPI 20031203). 
 
(After powering off the machine using this method about 3 times, it seems that 
the harddisk makes a sound that it doesn't make when using Windows to power 
off, however. A slight and very short "whooooooshCLICK", while in Windows it 
doesn't make any sound when powering off.) 
Comment 8 Georg Müller 2004-02-12 08:11:13 UTC
I have an Acer TM 630 and my system doesn't power down since 2.6.1
with 2.6.0 it works, later kernels (2.6.1, 2.6.2 and 2.6.3-rc2) don't power down.

I've tried it with the same settings as in 2.6.0, then with/without local apic
compiled in, with/without relaxed aml. No effect :(
Comment 9 Luming Yu 2004-02-12 19:33:33 UTC
Please post boot log as well as dmesg which can indicate where the poweroff 
has ran into. Thoese information will help us understand what's problem you 
could have.

--Luming
Comment 10 Georg Müller 2004-02-13 05:00:31 UTC
http://stinfwww.informatik.uni-leipzig.de/~mai01cha/2.6.3.dmesg.txt
(hm - upload feature doesn't worked - so as url)
Here is the dmesg from 2.6.3
Hm - boot log - I have no other boot log except the things from syslog, but
there are no acpi messages.
I can also post the dmesg of my 2.6.0, if you need it
Comment 11 Luming Yu 2004-02-13 05:48:38 UTC
Did you find the following message ?

flushing ide devices: hda hdc
Power down.
 hwsleep-0265 [01] acpi_enter_sleep_state: Entering sleep state [S5]
Comment 12 Georg Müller 2004-02-13 06:22:21 UTC
hm, no
in 2.6.0 I can only read a "power down" and then it turns off, but it happens
fast and with 2.6.3 there stands only "power down" and none of the lines you posted.
My devices are flushed before and remounted readonly, so I can't find such
messages in any files on my disk.
Comment 13 Georg Müller 2004-02-19 06:09:25 UTC
May I add some debug options in the kernel so that I can tell you a little bit
more about my problem?
When yes, witch ones?
Do you need my dsdt?
Comment 14 Georg Müller 2004-02-28 15:28:24 UTC
Strange things:
When I boot with init=/bin/bash and power off, power off happens correctly.
But when booting with normal init, this does not happen.
It also didn't power off properly when executing poweroff with -n, -d, -f and/or -h.
I didn't found the exact reason, but I can say that this does not happen with 2.6.0.
Comment 15 Georg Müller 2004-02-28 15:44:20 UTC
Created attachment 2245 [details]
acpidmp, dmidecode, interrupts and lspci in a bzip2

Here are some more infos on my system
Comment 16 Georg Müller 2004-04-05 06:14:56 UTC
Ok, my problem seems to be a dup of #2109 ...
Comment 17 Moshe Caspi 2004-04-15 03:35:18 UTC
Got the same problem on an old machine/bios, using APM, Mandrake 10.1 with  
kernel 2.6.3.  
Comment 18 Ondrej Sury 2004-08-01 02:46:31 UTC
Created attachment 3447 [details]
dmesg output on IBM T40/p

IBM TP 40/p (Centrino Chipset) - still same problem on 2.6.7
I can see "Power down" message then screen goes blank, but fans are still
running, BlueTooth diode is still on, etc.

I will try with nolapic flag and report results.

dmesg output attached

Ondrej
Comment 19 Ondrej Sury 2004-08-01 02:56:48 UTC
Created attachment 3448 [details]
dmesg output on T40/p with disabled local apic (nolapic)

Good news are that using nolapic work, bad news are that this is only
workaround.
Maybe using LAPIC with ACPI on IBM notebooks should be blacklisted?

Ondrej
Comment 20 Herbert Xu 2004-09-28 03:14:59 UTC
Created attachment 3732 [details]
Disable local APIC when powering down.

This is a work around patch presented in

http://mailman.linux-thinkpad.org/pipermail/linux-thinkpad/2004-September/020055.html
Comment 21 Alexey Starikovskiy 2004-10-20 02:29:45 UTC
Created attachment 3862 [details]
Shutdown LAPIC at poweroff

Could you please try the following patch? It should do the same, but cleaner.
Comment 22 Sérgio M Basto 2004-10-21 08:15:47 UTC
Definitely bug 1901 and 1619  are the same bug and one of then should be marked
has duplicated.
Both dmesgs have 
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
and 
ACPI: IRQ9 SCI: Edge set to Level Trigger.
Since kernel 2.6.9-rc4 if Bios don't enable Local APIC, we don't try reenabling.
At the end is the same of boot with nolapic. 
This bugs can be marked has depends on bug 1269 (you can beging to read from
comment #50 )
Comment 23 Len Brown 2004-11-05 22:28:51 UTC
> Local APIC disabled by BIOS -- reenabling.
> Found and enabled local APIC!

closing as duplicate.

*** This bug has been marked as a duplicate of 3238 ***

Note You need to log in before you can comment on or make changes to this bug.