Bug 18992 - warn_slow_path_common in iwlagn/mac80211 in 2.6.36-rc5
warn_slow_path_common in iwlagn/mac80211 in 2.6.36-rc5
Status: CLOSED DUPLICATE of bug 17722
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-09-23 03:07 UTC by rocko
Modified: 2010-10-03 20:57 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.36-rc5
Tree: Mainline
Regression: Yes


Attachments
syslog showing warn_slowpath_common (2.91 KB, text/plain)
2010-09-23 03:07 UTC, rocko
Details

Description rocko 2010-09-23 03:07:33 UTC
Created attachment 31062 [details]
syslog showing warn_slowpath_common

See attached log. The problem only appears in 2.6.36, not in 2.6.35 or earlier, and it happens fairly regularly. It doesn't seem to break anything, though.

The hardware is an Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61) 11N card.
Comment 1 wey-yi.w.guy 2010-09-23 15:00:21 UTC
There are some very recent changes submit by Stanislaw Gruszka in this area.

3a160a5b5fc7d45fa2f869b23f8fcd27a4c05f8f iwlwifi: apply settings when
finishing scan
7cf24421292d92556d53630e6973b34324c94103 iwlwifi: use IWL_DEBUG_SCAN for
debug scanning
74d81b259d6c8493f066e34c939cb6fb7d3129e5 iwlwifi: cleanup scan initiate
check
edeb78a7fa838b7fb9c2043680bd8da7cb5cb0e5 mac80211: wait for scan work
complete before restarting hw
e7e16b90b477a07d17af37dceb2e8af1ddbd9712 iwlwifi: do not force complete
scan too early
6bd1758d978f917dc0804f44e3528ef1a80d9d43 iwlwifi: assure we complete
scan in scan_abort and scan_check works
f5354c17dc29681c241f2774f3ef9478fb586673 iwlwifi: force scan complete
after timeout
02d8c14b590f583fd6e8c16fe779f845845effd9 iwlwifi: rewrite scan
completion
e693a802f06f538b711333a32a83e2732dc4773d iwlwifi: rework
iwl_scan_cancel_timeout
cd44600fdd89832c0bc898189270a81be0db01cd iwlwifi: report scan completion
when abort fail
d745d472afcbc6354ebfee008123894a7f37e97e iwlwifi: cancel scan when down
the device
b62177a0aa0521fd07cd7501534c0c3b256ebce6 iwlwifi: fix canceling
monitor_recover timer
c240879f3488ae0904a7ba5bdaaa54638b2d8852 iwlwifi: make scan workqueue
functions static
d28232b461b8d54b09e59325dbac8b0913ce2049 iwlwifi: fix scan abort


Wey
Comment 2 John W. Linville 2010-09-24 13:37:05 UTC
That is a long list of patches to consider for 2.6.36.  Is it possible we could have a targetted fix for that release?

rocko, would you care to do a bisect to determine what may be causing this message?
Comment 3 rocko 2010-09-25 01:48:43 UTC
Should those commits be the /linux/kernel/git/torvalds/linux-2.6 tree? The only one I can find there is the last one (fix scan abort). The kernel I'm using is built from the 2.6.36-rc5 source tarball, not from git. Is the tarball based on a different tree?
Comment 4 rocko 2010-09-28 03:16:09 UTC
FWIW, it also happens in 2.6.36-rc3. I don't have the source for 2.6.36-rc2, so I can't do much else unless someone can point me to the right tree to bisect against.
Comment 5 Florian Mickler 2010-09-28 05:52:24 UTC
Can check the patch attached to bug 17722?

*** This bug has been marked as a duplicate of bug 17722 ***
Comment 6 Florian Mickler 2010-09-28 05:53:44 UTC
Can you check the patch attached to bug 17722?
Comment 7 Rafael J. Wysocki 2010-09-28 10:43:48 UTC
On Tuesday, September 28, 2010, Rocko Requin wrote:
> 
> Yes, this bug should still be listed as a regression.
> 
> > 
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.35.  Please verify if it still should be listed and let the tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=18992
> > Subject		: warn_slow_path_common in iwlagn/mac80211 in 2.6.36-rc5
> > Submitter	: rocko <rockorequin@hotmail.com>
> > Date		: 2010-09-23 03:07 (4 days old)
Comment 8 John W. Linville 2010-09-28 12:48:28 UTC
Pleae do bisection against this tree:

git://git.kernel.org/pub/scm/linux/kernel/git/linville/wireless-next-2.6.git

Note You need to log in before you can comment on or make changes to this bug.