Bug 189171 - ACPI Lid state does not switch from closed to open after suspend
Summary: ACPI Lid state does not switch from closed to open after suspend
Status: CLOSED DUPLICATE of bug 187271
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Lv Zheng
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-26 04:19 UTC by alecbcscott
Modified: 2016-12-16 03:59 UTC (History)
2 users (show)

See Also:
Kernel Version: 4.8.8
Tree: Mainline
Regression: No


Attachments

Description alecbcscott 2016-11-26 04:19:25 UTC
On fedora 25 with kernel 4.8.8 on a Razerblade 2014 the ACPI lid state does not return to open after the lid is closed and then opened which causes the computer to enter a suspend loop. The lid0 state after the one use never returns to "open" unless the computer is rebooted. Other people on other makes of computers are also having this problem. 

Thanks,
Alecbcs
Comment 1 Lv Zheng 2016-11-30 02:13:01 UTC
You need to use button.lid_init_state=ignore mode with userspace changed.
If the userspace remains unchanged, you need to use button.lid_init_state=open.
However the latter doesn't help much.
Please try it and if it can fix the issue please raise your problem to systemd community..
Comment 2 Lv Zheng 2016-11-30 02:23:57 UTC
However there is still an issue for freeze mode and hardware reduced platform.
Please also upload your acpidump for confirmation.

Thanks
Lv
Comment 3 alecbcscott 2016-12-04 01:05:24 UTC
(In reply to Lv Zheng from comment #2)
> However there is still an issue for freeze mode and hardware reduced
> platform.
> Please also upload your acpidump for confirmation.
> 
> Thanks
> Lv

Hi there, I'm sorry but I don't really know what you mean by "You need to use button.lid_init_state=ignore mode with userspace changed." is there a command that I should do in the terminal or a file I should edit? (I'm faily new to acpi and systemd. Does this simply make it so that the lid state is ignored? (I've done that with gnome tweak tool and it seems to be working fine). Also in my continued research to learn about this bug I found that Arch had a form post about this and some users created a patch in the kernel for it and if you could take a look at that I will link it below. Also how would I create or find my acpidump?

Thank you for you help,
Alec

Arch conversation: https://bbs.archlinux.org/viewtopic.php?id=192814
Patch that the user created: https://github.com/cthulhuology/razer-lid-patch
Comment 4 Lv Zheng 2016-12-05 02:57:30 UTC
button.lid_init_state=ignore is a Linux kernel boot parameter.
But I don't think your usserspace have been changed.
So please try to use this kernel boot parameter: "button.lid_init_state=open". It's a workaround during the period the userspace hasn't been changed.

For this:
https://github.com/cthulhuology/razer-lid-patch
Please drop the patch, it's already determined to be a wrong approach by all parties in the community.

Please don't forget to upload acpidump.
Comment 5 Lv Zheng 2016-12-05 02:59:52 UTC
The story about this patch:
https://github.com/cthulhuology/razer-lid-patch
I proposed idea of this and Yu helped to implement it.

After knowing more use cases, we determined this fix was wrong.
So finally Linux upstream has merged the following 2 fixes:
button.lid_init_state=open
button.lid_init_state=ignore
Comment 6 Lv Zheng 2016-12-05 03:14:54 UTC
Please check Docuemntation/acpi/acpi-lid.txt.

IMO,

If your problem is related to suspend-to-mem, then there will be no code fix needed to be done in kernel acpi-lid driver.
What I'm doing here is to obtain necessary information before closing this bug.
You need to ask systemd developer to do further investigations.

If your problem is related to suspend-to-idle, then I'll just assign it to suspend category and leave it for the experts.

Thanks
Lv
Comment 7 Lv Zheng 2016-12-05 03:18:21 UTC
And please check the following bugs for more information:
Bug 187271 / Bug 106941 / Bug 89211 / Bug 106151 / Bug 51731.

Thanks
Comment 8 Lv Zheng 2016-12-06 00:48:41 UTC
Maybe what you need to know can be found here:
https://wiki.ubuntu.com/Kernel/KernelBootParameters

Thanks
Lv
Comment 9 Lv Zheng 2016-12-16 03:58:57 UTC
Closing due to this as a duplicated bug.

*** This bug has been marked as a duplicate of bug 187271 ***

Note You need to log in before you can comment on or make changes to this bug.