Bug 18852 - Kernel panic in 2.6.36-rc4 after suspend/resume
Kernel panic in 2.6.36-rc4 after suspend/resume
Status: CLOSED OBSOLETE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
: 18882 (view as bug list)
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-09-20 17:37 UTC by vaibhav
Modified: 2012-06-14 17:28 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.36-rc4
Tree: Mainline
Regression: No


Attachments
Text displayed at panic (2.90 KB, text/plain)
2010-09-20 17:39 UTC, vaibhav
Details

Description vaibhav 2010-09-20 17:37:40 UTC
Hi,

 I am using kernel 2.6.34-rc4 directly taken from kernel.org. After suspend to ram if I leave it for few hours and resume then kernel panic happens (screen of death). If I suspend and resume immediately then it works fine. I am attaching hand copied text which was displayed at panic.

Its a dual core intel machine. Let me know what other information is needed from my side.
I had sent a mail to lkml. Response from lkml :

"I think that sta_addba_resp_timer_expired() is a red herring.  More likely the
problem is related to cpuidle.  Apparently, the suspend-resume cycle causes
the ACPI cpuidle driver to malfunction." - Rafael J. Wysocki

http://lkml.org/lkml/2010/9/18/373
Comment 1 vaibhav 2010-09-20 17:39:44 UTC
Created attachment 30792 [details]
Text displayed at panic
Comment 2 Rafael J. Wysocki 2010-09-20 17:52:49 UTC
Have you tried to put acpi_sleep=nonvs into the kernel command line?
Comment 3 Rafael J. Wysocki 2010-09-20 19:39:31 UTC
*** Bug 18882 has been marked as a duplicate of this bug. ***
Comment 4 vaibhav 2010-09-23 17:15:21 UTC
Panic occurred even without suspend/resume and details looked similar to one I have already reported. So I think it is not really suspend/resume issue. It is hard to reproduce this bug, I have no idea when and what would trigger the panic.
Comment 5 Rafael J. Wysocki 2011-01-16 22:38:42 UTC
Is this still and issue with 2.6.37?

Note You need to log in before you can comment on or make changes to this bug.