Bug 18572 - (reset_after_suspend) System reboots itself on resume (coming from suspend)
(reset_after_suspend)
System reboots itself on resume (coming from suspend)
Status: CLOSED DUPLICATE of bug 16396
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 16055
  Show dependency treegraph
 
Reported: 2010-09-15 10:24 UTC by Claudio M. Camacho
Modified: 2010-09-20 19:50 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.36-rc4
Tree: Mainline
Regression: Yes


Attachments
Kernel configuration 2.6.36-rc4 (54.55 KB, application/octet-stream)
2010-09-15 10:24 UTC, Claudio M. Camacho
Details
Claudio's acpidump (166.60 KB, text/plain)
2010-09-20 13:29 UTC, Claudio M. Camacho
Details
Claudio's dmidecode (5.06 KB, text/plain)
2010-09-20 13:29 UTC, Claudio M. Camacho
Details
PM / ACPI: Blacklist system known to require acpi_sleep=nonvs (894 bytes, patch)
2010-09-20 17:14 UTC, Rafael J. Wysocki
Details | Diff

Description Claudio M. Camacho 2010-09-15 10:24:12 UTC
Created attachment 30112 [details]
Kernel configuration 2.6.36-rc4

My Debian Sid (on a 2.6.36-rc4 kernel) reboots itself after opening my laptop's lid, that is coming from the suspend-to-RAM.

My computer is a Sony Vaio SR11M with an HD4500 Intel graphics card. Suspend and hibernate have always worked perfectly. However, with 2.6.36-rc4, although suspend to RAM works, coming from suspend (on resume) the laptop is reseted and it reboots.

Please find enclosed a copy of my .config


Kind regards,


--Claudio
Comment 1 Claudio M. Camacho 2010-09-15 10:26:17 UTC
Just in case you need extra information, I have a Core 2 Duo with 4GB RAM. Here is the graphics stack I'm currently using:


Mesa 7.8.2
Intel-gfx (driver) 2.12.0
Xorg 7.5
Xorg-core 1.7.7
libdrm2 2.4.21


Kind regards,


--Claudio
Comment 2 Claudio M. Camacho 2010-09-15 10:31:27 UTC
By the way, this happens with 2.6.35.4 as well. I just tried and there is the same situation.

Kind regards,


--Claudio
Comment 3 Rafael J. Wysocki 2010-09-15 18:49:48 UTC
Well, so what's the last known good kernel?
Comment 4 Claudio M. Camacho 2010-09-16 04:49:13 UTC
The last good kernel for my hardware is 2.6.34.7 (or any in the series 2.6.34.x). With 2.6.35 this issue happens.

Kind regards,


--Claudio
Comment 5 Rafael J. Wysocki 2010-09-16 18:12:15 UTC
Please try to boot with acpi_sleep=nonvs in the kernel command line and let me
know if that helps.
Comment 6 Claudio M. Camacho 2010-09-17 05:56:14 UTC
Hi,

"acpi_sleep=nonvs" works. If I use that option, suspend and resume work properly and the system does not reboot.
Comment 7 Rafael J. Wysocki 2010-09-17 21:23:16 UTC
OK, please post the output of dmidecode from your machine.
Comment 8 Matthew Garrett 2010-09-17 21:26:10 UTC
Also, could you provide the output of acpidump?
Comment 9 Claudio M. Camacho 2010-09-20 13:29:23 UTC
Created attachment 30732 [details]
Claudio's acpidump
Comment 10 Claudio M. Camacho 2010-09-20 13:29:54 UTC
Created attachment 30742 [details]
Claudio's dmidecode
Comment 11 Claudio M. Camacho 2010-09-20 13:30:57 UTC
Hello,

I uploaded acpidump and dmidecode. Yesterday bugzilla was not working, so I couldn't do it earlier, I hope they help!

Kind regards,


--Claudio
Comment 12 Rafael J. Wysocki 2010-09-20 17:14:49 UTC
Created attachment 30772 [details]
PM / ACPI: Blacklist system known to require acpi_sleep=nonvs

Please check if your machine resumes correctly with this patch applied.
Comment 13 Rafael J. Wysocki 2010-09-20 17:29:15 UTC
This in fact is a duplicate of bug 16396, so I'm marking it as resolved, but please test the patch from comment #12 nevertheless.

*** This bug has been marked as a duplicate of bug 16396 ***
Comment 14 Claudio M. Camacho 2010-09-20 19:22:04 UTC
Hi,

The patch works for my SR11M :)


--Claudio
Comment 15 Rafael J. Wysocki 2010-09-20 19:50:06 UTC
OK, so I assume the analogous patch in bug 16396 will work for you as well.

I'm closing this bug now, the patch from bug 16396 is going to go into 2.6.37.

Note You need to log in before you can comment on or make changes to this bug.