Bug 185581 - WARNING: func [module] has no CRC! when CONFIG_RELOCATABLE is not set
Summary: WARNING: func [module] has no CRC! when CONFIG_RELOCATABLE is not set
Status: CLOSED CODE_FIX
Alias: None
Product: Other
Classification: Unclassified
Component: Other (show other bugs)
Hardware: x86-64 Linux
: P1 high
Assignee: other_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-29 14:27 UTC by Ivan Bulatovic
Modified: 2018-06-27 20:26 UTC (History)
4 users (show)

See Also:
Kernel Version: 4.9.0-rc1
Tree: Mainline
Regression: No


Attachments

Description Ivan Bulatovic 2016-10-29 14:27:44 UTC
Hi,

ever since commit https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=84d69848c97faab0c25aa2667b273404d2e2a64a

Merge branch 'kbuild' of git://git.kernel.org/pub/scm/linux/kernel/git/mmarek/kbuild

I get warnings during build:

...
WARNING: "_copy_from_user" [drivers/md/dm-mod.ko] has no CRC!
WARNING: "___preempt_schedule" [drivers/md/dm-crypt.ko] has no CRC!
WARNING: "__sw_hweight64" [drivers/md/dm-crypt.ko] has no CRC!
WARNING: "memcpy" [drivers/md/dm-crypt.ko] has no CRC!
WARNING: "memset" [drivers/md/dm-crypt.ko] has no CRC!
WARNING: "__get_user_8" [drivers/input/serio/serport.ko] has no CRC!
WARNING: "__get_user_4" [drivers/input/serio/serport.ko] has no CRC!
WARNING: "__put_user_1" [drivers/input/serio/serio_raw.ko] has no CRC!
WARNING: "__get_user_1" [drivers/input/serio/serio_raw.ko] has no CRC!
WARNING: "__sw_hweight32" [drivers/input/serio/pcips2.ko] has no CRC!
WARNING: "_copy_to_user" [drivers/input/mousedev.ko] has no CRC!
...

Reverting the commit fixes the issue, as selecting CONFIG_RELOCATABLE in kernel config, so issue only occur if CONFIG_RELOCATABLE is not set.

This is a default setting on most distros since it's a requirement for UEFI, but saw it on LKML too:

https://lkml.org/lkml/2016/10/27/471

Commit message clearly states that it does bring a regression, but I'm not sure if it's related, hence the bug report so it could be tracked.

Regards,

Ivan
Comment 1 Daniel Exner 2016-11-07 16:16:57 UTC
I can confirm this issue even with CONFIG_RELOCATABLE set.
Comment 2 karl.beldan 2016-11-10 10:27:47 UTC
(In reply to Daniel Exner from comment #1)
> I can confirm this issue even with CONFIG_RELOCATABLE set.

+1
Comment 3 karl.beldan 2016-11-30 17:05:53 UTC
Fixed by the recent MODVERSIONS commits.
Comment 4 ntzrmtthihu777 2016-12-16 04:17:59 UTC
unless I'm missing something, I still get these errors on gentoo's sys-kernel/gentoo-sources-4.9.0, building an efistub kernel, is this going to be part of say 4.9.1 ?
Comment 5 Randy Dunlap 2018-04-08 00:28:18 UTC
Fixed 2016-NOV-29 by commit ID faaae2a581435f32781a105dda3501df388fddcb.

Note You need to log in before you can comment on or make changes to this bug.