Bug 1845 - S3 resume: freeze -- Dell D600
S3 resume: freeze -- Dell D600
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-12 06:39 UTC by Bart Lamiroy
Modified: 2005-08-17 20:04 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.1
Tree: Mainline
Regression: ---


Attachments
Problem does not seem to be video related (42.40 KB, text/plain)
2004-11-04 01:56 UTC, Bart Lamiroy
Details

Description Bart Lamiroy 2004-01-12 06:39:56 UTC
Distribution: Mandrake 9.2
Hardware Environment: Dell Latitude D600
Software Environment:
Problem Description:
This bug is probably related to bugs 1415, 1661, 1801 and 1199 but I have no
idea as how to check. 
ACPI sleep to state S3 operates correctly (echo 3 > /proc/acpi/sleep) but
resuming (pressing the power button) freezes my laptop. The system powers up
apparently correctly (/var/log/acpid proves that) but then freezes without
display. /var/log/syslog does not show any events after wakeup. The unpredicible
part of it is that sometimes ACPI is able to catch the power button interrupt
and starts a clean shutdown (once in a while CTRL-ALT-DEL works also). The
system enters shutdown, but freezes in the process. Eventually only hard
resetting is always necessary.
FYI, S4 (suspend on disk) works like a charm !
Steps to reproduce:
Comment 1 Venkatesh Pallipadi 2004-11-03 18:38:55 UTC
Is the problem still there with latest 2.6 kernel?

If yes, can you make sure whether the problem is only with restore of the 
video (try connecting through network or serial after resume).

If it is only the video problem, 
- Please try the options in Documentation/power/video.txt
- Try the workaround in bug #3670
Comment 2 Bart Lamiroy 2004-11-04 01:56:20 UTC
Created attachment 3954 [details]
Problem does not seem to be video related

I don't believe it is a simple failure of reactivating video.

Impossible to reconnect over ssh to  the box after resume. Since a few kernel
releases (I'm currently using 2.6.8.1) the random part of the bug has
disappeared. Resuming irremedably ends in a full freeze.

I attached the kernel .config for information.

Bart
Comment 3 Len Brown 2005-01-03 14:21:45 UTC
still a problem with linux-2.6.10 or later?
Comment 4 Bart Lamiroy 2005-01-04 09:16:19 UTC
Yes ... upon your request, I specially retrieved the 2.6.10 kernel. Problem stil
remains. I even compiled the kernel with debug options, but I did't get much out
of it.

Did I miss something (RTFM) by simply doing

echo 3 > /proc/acpi/sleep

I'd apreciate hints on how to provide more detailed information.
Comment 5 Donn Morrison 2005-03-13 20:02:48 UTC
I have this problem as well. I'm using a Dell Inspiron 600m. S1 and S4 work but
S3 hangs my machine upon resume (suspend works correctly). I cannot access it
over the network and a hard reset is required. I've confirmed this with 2.6.11.3.
Comment 6 Alexey Starikovskiy 2005-05-30 09:26:14 UTC
Same problem on Samsung P35 -- hard freeze on 2.6.12-rc4-mm.
Comment 7 Shaohua 2005-05-30 18:23:44 UTC
Alex, please try the patch at:
http://sourceforge.net/mailarchive/message.php?msg_id=10655102
Comment 8 Len Brown 2005-08-17 20:04:21 UTC
S3 works find with Linux-2.6.13-rc6 on RHEL4-U1
on my Dell Latitude D600 running BIOS A14

My unit has ATI video:
[lenb@d600 ~]$ lspci
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller 
(rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 
03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) 
USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) 
USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) 
USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI 
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge 
(rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 
01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM 
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 
9000] (rev 02)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702X Gigabit 
Ethernet (rev 02)
02:01.0 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 
20)
02:01.1 CardBus bridge: O2 Micro, Inc. OZ711EC1 SmartCardBus Controller (rev 
20)

If your D600 doesn't work, please re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.