Bug 17952 - bdi-default hung waiting for kthread_stop to finish
bdi-default hung waiting for kthread_stop to finish
Status: CLOSED CODE_FIX
Product: File System
Classification: Unclassified
Component: CIFS
All Linux
: P1 normal
Assigned To: Jeff Layton
:
Depends on:
Blocks: 16444
  Show dependency treegraph
 
Reported: 2010-09-06 18:15 UTC by Maciej Rutecki
Modified: 2010-09-19 19:32 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.36-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-09-06 18:15:40 UTC
Subject    : bdi-default hung waiting for kthread_stop to finish
Submitter  : Jeff Layton <jlayton@redhat.com>
Date       : 2010-09-02 18:55
Message-ID : 20100902145509.28e4f998@tlielax.poochiereds.net
References : http://marc.info/?l=linux-kernel&m=128345371904504&w=2

This entry is being used for tracking a regression from 2.6.35. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jeff Layton 2010-09-14 00:42:55 UTC
I just tried reproducing this on a more recent kernel and wasn't able to do so. Not sure what fixed it, but I can no longer reproduce it.
Comment 2 Jeff Layton 2010-09-14 00:46:11 UTC
The kernel I just tested was a more recent Fedora rawhide kernel:

2.6.36-0.20.rc3.git4.fc15.x86_64
Comment 3 Jeff Layton 2010-09-14 00:50:10 UTC
Assigning this bug to myself and closing it with a resolution of CODE_FIX even though I'm not sure what the actual fix was...

Note You need to log in before you can comment on or make changes to this bug.