Bug 178271 - Asus Laptop Touchpad not detected
Summary: Asus Laptop Touchpad not detected
Status: RESOLVED DUPLICATE of bug 120181
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 high
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-18 09:31 UTC by nvsl
Modified: 2016-12-17 20:29 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.4.21
Tree: Mainline
Regression: No


Attachments

Description nvsl 2016-10-18 09:31:41 UTC
I've just get a new laptop: ASUS Zenbook ProUX501UW FY102T and after installing Gentoo the touchpad is not recognized. I've spent days googling and test a LOT of solutions but nothing worked.

What I've tried:

- test kernel from 4.3 to 4.9 (from official github this one)
- tried tons of parameters into kernel boot like noloop, nopnp, nomux, reset etc..
- installing synaptics, evdev, libinput
- Live CD ubuntu 14, 15 (16 freeze at the boot), latest fedora, arch linux: no one get a working touchpad
- compile the whole list of i2c drivers and load them as modules or in-built

It seems a lot of people got/is getting this problem, some patches have been pushed into the kernel to solve their problem but nothing worked for my case.

Here the important information:

# lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 191b (rev 06)
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H LPSS I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H LPSS I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #2 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 960M] (rev a2)
02:00.0 Unassigned class [ff00]: Alcor Micro Device 6621
03:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
3d:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a802 (rev 01)



# libinput-list-devices
Device:           Power Button
Kernel:           /dev/input/event2
Group:            1
Seat:             seat0, default
Capabilities:     keyboard
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           Video Bus
Kernel:           /dev/input/event3
Group:            2
Seat:             seat0, default
Capabilities:     keyboard
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           Video Bus
Kernel:           /dev/input/event4
Group:            2
Seat:             seat0, default
Capabilities:     keyboard
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           Sleep Button
Kernel:           /dev/input/event1
Group:            3
Seat:             seat0, default
Capabilities:     keyboard
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a

Device:           Logitech USB-PS/2 Optical Mouse
Kernel:           /dev/input/event7
Group:            4
Seat:             seat0, default
Capabilities:     pointer
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a

Device:           AT Translated Set 2 keyboard
Kernel:           /dev/input/event6
Group:            5
Seat:             seat0, default
Capabilities:     keyboard
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      n/a
Nat.scrolling:    n/a
Middle emulation: n/a
Calibration:      n/a
Scroll methods:   none
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   n/a
Rotation:         n/a


# cat /proc/bus/input/devices
I: Bus=0019 Vendor=0000 Product=0005 Version=0000
N: Name="Lid Switch"
P: Phys=PNP0C0D/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
U: Uniq=
H: Handlers=event0 evbug
B: PROP=0
B: EV=21
B: SW=1

I: Bus=0019 Vendor=0000 Product=0003 Version=0000
N: Name="Sleep Button"
P: Phys=PNP0C0E/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
U: Uniq=
H: Handlers=kbd event1 evbug
B: PROP=0
B: EV=3
B: KEY=4000 0 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
U: Uniq=
H: Handlers=kbd event2 evbug
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input3
U: Uniq=
H: Handlers=kbd event3 evbug
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:12/LNXVIDEO:01/input/input4
U: Uniq=
H: Handlers=kbd event4 evbug
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0010 Vendor=001f Product=0001 Version=0100
N: Name="PC Speaker"
P: Phys=isa0061/input0
S: Sysfs=/devices/platform/pcspkr/input/input6
U: Uniq=
H: Handlers=kbd event5 evbug
B: PROP=0
B: EV=40001
B: SND=6

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input5
U: Uniq=
H: Handlers=sysrq kbd leds event6 evbug
B: PROP=0
B: EV=120013
B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=046d Product=c045 Version=0110
N: Name="Logitech USB-PS/2 Optical Mouse"
P: Phys=usb-0000:00:14.0-6/input0
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-6/1-6:1.0/0003:046D:C045.0001/input/input7
U: Uniq=
H: Handlers=mouse0 event7 evbug
B: PROP=0
B: EV=17
B: KEY=ff0000 0 0 0 0
B: REL=143
B: MSC=10


# xinput list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse            id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Video Bus                                  id=8   [slave  keyboard (3)]
    ↳ Sleep Button                               id=9   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=11   [slave  keyboard (3)]


# lsmod
Module                  Size  Used by
i2c_emev2               3856  0
i2c_designware_pci      3715  0
i2c_designware_platform     4610  0
i2c_designware_core     7279  2 i2c_designware_pci,i2c_designware_platform
x86_pkg_temp_thermal     5367  0
iwlmvm                224940  0
iwlwifi               160977  1 iwlmvm
efivarfs                6055  1

# grep keyboard /var/log/kern.log
Oct 18 01:40:28 masamune kernel: [    0.461005] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5

# grep mouse /var/log/kern.log
Oct 18 01:40:28 masamune kernel: [    0.369936] usbcore: registered new interface driver idmouse
Oct 18 01:40:28 masamune kernel: [    0.420508] mousedev: PS/2 mouse device common for all mice

# cat /var/log/kern.log | grep i8042
Oct 18 10:58:03 masamune kernel: [    0.000000] Kernel command line: root=/dev/nvme0n1p5 rootfstype=ext4 raid=noautodetect acpi_osi= i8042.nopnp
Oct 18 10:58:03 masamune kernel: [    0.343160] i8042: PNP detection disabled
Oct 18 10:58:03 masamune kernel: [    0.347758] i8042: Detected active multiplexing controller, rev 1.1
Oct 18 10:58:03 masamune kernel: [    0.350008] serio: i8042 KBD port at 0x60,0x64 irq 1
Oct 18 10:58:03 masamune kernel: [    0.350013] serio: i8042 AUX0 port at 0x60,0x64 irq 12
Oct 18 10:58:03 masamune kernel: [    0.350036] serio: i8042 AUX1 port at 0x60,0x64 irq 12
Oct 18 10:58:03 masamune kernel: [    0.350055] serio: i8042 AUX2 port at 0x60,0x64 irq 12
Oct 18 10:58:03 masamune kernel: [    0.350074] serio: i8042 AUX3 port at 0x60,0x64 irq 12
Oct 18 10:58:03 masamune kernel: [    0.440930] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
Comment 1 mirh 2016-12-17 20:26:13 UTC
Try to see if i8042.nomux, i8042.nopnp, i8042.reset or i8042.kbdreset boot parameters change anything.
Comment 2 nvsl 2016-12-17 20:29:24 UTC

*** This bug has been marked as a duplicate of bug 120181 ***

Note You need to log in before you can comment on or make changes to this bug.